summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-12 21:09:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-12 21:09:21 +0000
commit8914d669778ec7d6b5e7e2d6394fb025876a2ea4 (patch)
treedd49a311e45bdb69ce1e8e5536d0605c5d5a21aa
parentVersion bump, drop old. Capitalize description. (diff)
downloadgentoo-2-8914d669778ec7d6b5e7e2d6394fb025876a2ea4.tar.gz
gentoo-2-8914d669778ec7d6b5e7e2d6394fb025876a2ea4.tar.bz2
gentoo-2-8914d669778ec7d6b5e7e2d6394fb025876a2ea4.zip
Version bump; use the new rspec recipe for testing; install the real gemspec (fixed) so that bundler won't complain about missing diff-lcs.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog10
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.11.2.ebuild (renamed from dev-ruby/rspec-expectations/rspec-expectations-2.11.1.ebuild)17
2 files changed, 19 insertions, 8 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 43947b045346..726827ac321b 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.29 2012/07/26 12:54:21 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.30 2012/08/12 21:09:21 flameeyes Exp $
+
+*rspec-expectations-2.11.2 (12 Aug 2012)
+
+ 12 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +rspec-expectations-2.11.2.ebuild, -rspec-expectations-2.11.1.ebuild:
+ Version bump; use the new rspec recipe for testing; install the real gemspec
+ (fixed) so that bundler won't complain about missing diff-lcs.
26 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
rspec-expectations-2.6.0-r1.ebuild:
@@ -130,4 +137,3 @@
13 Sep 2010; Hans de Graaff <graaff@gentoo.org>
+rspec-expectations-2.0.0_beta22.ebuild, +metadata.xml:
Initial import of rspec-2.
-
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.11.1.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.11.2.ebuild
index bccbaa4263a8..e15052be4054 100644
--- a/dev-ruby/rspec-expectations/rspec-expectations-2.11.1.ebuild
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.11.2.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.11.1.ebuild,v 1.1 2012/07/15 06:57:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.11.2.ebuild,v 1.1 2012/08/12 21:09:21 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ree18 ruby19 jruby"
-RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_S="rspec-${PN}-*"
+
inherit ruby-fakegem
DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
HOMEPAGE="http://rspec.rubyforge.org/"
SRC_URI="https://github.com/rspec/${PN}/tarball/v${PV} -> ${P}-git.tgz"
-RUBY_S="rspec-${PN}-*"
LICENSE="MIT"
SLOT="2"
@@ -35,8 +38,10 @@ all_ruby_prepare() {
# Remove the Gemfile to avoid running through 'bundle exec'
rm Gemfile || die
-}
-each_ruby_test() {
- PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rspec spec || die
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
}