summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 15:33:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 15:33:37 +0000
commit8a1863a3524865a2c9dda9b9a030c77f46f9ff48 (patch)
treecedee3b10226e580a24bc2d310e47d383323a63e
parentVarious cleanups. (diff)
downloadgentoo-2-8a1863a3524865a2c9dda9b9a030c77f46f9ff48.tar.gz
gentoo-2-8a1863a3524865a2c9dda9b9a030c77f46f9ff48.tar.bz2
gentoo-2-8a1863a3524865a2c9dda9b9a030c77f46f9ff48.zip
Various cleanups.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-ruby/pg/ChangeLog5
-rw-r--r--dev-ruby/pg/pg-0.9.0-r1.ebuild15
2 files changed, 14 insertions, 6 deletions
diff --git a/dev-ruby/pg/ChangeLog b/dev-ruby/pg/ChangeLog
index 74e4bd66456c..89bf3ef4528e 100644
--- a/dev-ruby/pg/ChangeLog
+++ b/dev-ruby/pg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/pg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.14 2010/05/01 11:13:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/ChangeLog,v 1.15 2010/05/22 15:33:37 flameeyes Exp $
+
+ 22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> pg-0.9.0-r1.ebuild:
+ Various cleanups.
01 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> pg-0.9.0-r1.ebuild:
Make testing explicit with RSpec rather than using the Rakefile, this way
diff --git a/dev-ruby/pg/pg-0.9.0-r1.ebuild b/dev-ruby/pg/pg-0.9.0-r1.ebuild
index c56db715dfbd..7e694832b182 100644
--- a/dev-ruby/pg/pg-0.9.0-r1.ebuild
+++ b/dev-ruby/pg/pg-0.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.9.0-r1.ebuild,v 1.2 2010/05/01 11:13:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pg/pg-0.9.0-r1.ebuild,v 1.3 2010/05/22 15:33:37 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ruby19"
@@ -21,16 +21,21 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-RDEPEND="dev-db/postgresql-base"
-DEPEND="${RDEPEND}
+RDEPEND="${RDEPEND}
+ dev-db/postgresql-base"
+DEPEND="${DEPEND}
+ dev-db/postgresql-base
test? ( dev-db/postgresql-server )"
# For the rakefile (and thus doc generation and testing) to work as
# intended, you need both rake-compiler _and_ the real RubyGems
# package; what is shipped with Ruby 1.9 is not good enough as it
# lacks the packaging tasks for Rake.
-ruby_add_bdepend doc "dev-ruby/rake-compiler dev-ruby/rubygems"
-ruby_add_bdepend test dev-ruby/rspec
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/rake-compiler
+ dev-ruby/rubygems )
+ test? ( dev-ruby/rspec )"
each_ruby_configure() {
pushd ext