summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-18 15:04:25 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-18 15:04:25 +0000
commit8c6142671aedd5375132244f2d19d368483e68f4 (patch)
tree9134f33a22fc96386478591ba6e95ce541c9840a
parentStable for ppc, wrt bug #488268 (diff)
downloadgentoo-2-8c6142671aedd5375132244f2d19d368483e68f4.tar.gz
gentoo-2-8c6142671aedd5375132244f2d19d368483e68f4.tar.bz2
gentoo-2-8c6142671aedd5375132244f2d19d368483e68f4.zip
Cleanup old EAPI1 and superseded ebuilds.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--media-sound/snd/ChangeLog6
-rw-r--r--media-sound/snd/snd-12.7.ebuild124
-rw-r--r--media-sound/snd/snd-9.11.ebuild118
3 files changed, 5 insertions, 243 deletions
diff --git a/media-sound/snd/ChangeLog b/media-sound/snd/ChangeLog
index 3ac3aca2917d..148a560b0f93 100644
--- a/media-sound/snd/ChangeLog
+++ b/media-sound/snd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/snd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.71 2014/10/18 14:31:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.72 2014/10/18 15:04:25 mrueg Exp $
+
+ 18 Oct 2014; Manuel Rüger <mrueg@gentoo.org> -snd-12.7.ebuild,
+ -snd-9.11.ebuild:
+ Cleanup old EAPI1 and superseded ebuilds.
18 Oct 2014; Agostino Sarubbo <ago@gentoo.org> snd-12.8.ebuild:
Stable for ppc, wrt bug #518780
diff --git a/media-sound/snd/snd-12.7.ebuild b/media-sound/snd/snd-12.7.ebuild
deleted file mode 100644
index c88cb23ecf3a..000000000000
--- a/media-sound/snd/snd-12.7.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-12.7.ebuild,v 1.6 2013/04/17 18:22:42 ulm Exp $
-
-EAPI="4"
-
-inherit autotools eutils flag-o-matic multilib
-
-DESCRIPTION="Snd is a sound editor"
-HOMEPAGE="http://ccrma.stanford.edu/software/snd/"
-SRC_URI="ftp://ccrma-ftp.stanford.edu/pub/Lisp/${P}.tar.gz"
-
-LICENSE="Snd BSD-2 HPND GPL-2+ LGPL-2.1+ LGPL-3+ ruby? ( free-noncomm ) s7? ( free-noncomm )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE="alsa doc fam fftw gmp gsl gtk jack ladspa motif opengl oss portaudio pulseaudio readline ruby +s7"
-
-RDEPEND="media-libs/audiofile
- alsa? ( media-libs/alsa-lib )
- fam? ( virtual/fam )
- fftw? ( sci-libs/fftw )
- gmp? ( dev-libs/gmp
- dev-libs/mpc
- dev-libs/mpfr )
- gsl? ( sci-libs/gsl )
- gtk? ( x11-libs/gtk+:3
- x11-libs/pango
- x11-libs/cairo
- opengl? ( x11-libs/gtkglext ) )
- jack? ( media-sound/jack-audio-connection-kit )
- ladspa? ( media-libs/ladspa-sdk )
- motif? ( >=x11-libs/motif-2.3:0 )
- opengl? ( virtual/opengl )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- readline? ( sys-libs/readline )
- ruby? ( dev-lang/ruby )"
-
-REQUIRED_USE="
- portaudio? ( !pulseaudio )
- pulseaudio? ( !portaudio )
- ^^ (
- ( !ruby !s7 )
- ( ruby !s7 )
- ( !ruby s7 )
- )"
-
-pkg_setup() {
- if ! use gtk && ! use motif ; then
- ewarn "Warning: no graphic toolkit selected (gtk or motif)."
- ewarn "Upstream suggests to enable one of the toolkits (or both)"
- ewarn "or only the command line utilities will be helpful."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-12.6-as-needed.patch
- sed -i -e "s:-O2 ::" configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- # Workaround executable sections QA warning (bug #348754)
- append-ldflags -Wl,-z,noexecstack
-
- local myconf
- if use opengl ; then
- myconf+=" --with-just-gl"
- else
- myconf+=" --without-gl"
- fi
-
- if ! use ruby && ! use s7 ; then
- myconf+=" --without-extension-language"
- fi
-
- econf \
- $(use_with alsa) \
- $(use_with fam) \
- $(use_with fftw) \
- $(use_with gmp) \
- $(use_with gsl) \
- $(use_with gtk) \
- $(use_with jack) \
- $(use_with ladspa) \
- $(use_with motif) \
- $(use_with oss) \
- $(use_with portaudio) \
- $(use_with pulseaudio) \
- $(use_enable readline) \
- $(use_with ruby) \
- $(use_with s7) \
- --with-float-samples \
- ${myconf}
-
-}
-
-src_compile() {
- emake snd
-
- # Do not compile ruby extensions for command line programs since they fail
- sed -i -e "s:HAVE_RUBY 1:HAVE_RUBY 0:" mus-config.h || die
-
- for i in sndinfo audinfo sndplay ; do
- emake ${i}
- done
-}
-
-src_install () {
- dobin snd sndplay sndinfo audinfo
-
- if use ruby ; then
- insinto /usr/share/snd
- doins *.rb
- fi
-
- if use s7 ; then
- insinto /usr/share/snd
- doins *.scm
- fi
-
- dodoc README.Snd HISTORY.Snd NEWS
- use doc && dohtml -r *.html pix/*.png tutorial
-}
diff --git a/media-sound/snd/snd-9.11.ebuild b/media-sound/snd/snd-9.11.ebuild
deleted file mode 100644
index 3ffe387333b2..000000000000
--- a/media-sound/snd/snd-9.11.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-9.11.ebuild,v 1.10 2013/04/17 18:22:42 ulm Exp $
-
-EAPI=1
-
-inherit multilib eutils versionator
-
-DESCRIPTION="Snd is a sound editor"
-HOMEPAGE="http://ccrma.stanford.edu/software/snd/"
-SRC_URI="ftp://ccrma-ftp.stanford.edu/pub/Lisp/${P}.tar.gz"
-
-LICENSE="Snd BSD-2 HPND GPL-2+ LGPL-2.1+ free-noncomm"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE="alsa cairo fam fftw gsl gtk guile jack ladspa motif nls opengl oss ruby xpm"
-
-RDEPEND="media-libs/audiofile
- motif? ( >=x11-libs/motif-2.3:0 )
- alsa? ( media-libs/alsa-lib )
- fam? ( virtual/fam )
- fftw? ( sci-libs/fftw )
- gsl? ( >=sci-libs/gsl-0.8 )
- gtk? ( x11-libs/gtk+:2
- opengl? ( x11-libs/gtkglext )
- cairo? ( x11-libs/cairo ) )
- guile? ( >=dev-scheme/guile-1.3.4 )
- jack? ( media-sound/jack-audio-connection-kit )
- ladspa? ( media-libs/ladspa-sdk )
- nls? ( sys-devel/gettext )
- opengl? ( virtual/opengl )
- ruby? ( dev-lang/ruby )
- xpm? ( x11-libs/libXpm )"
-
-#S=${WORKDIR}/${PN}-$(get_version_component_range 1)
-
-pkg_setup() {
- if ! use gtk && ! use motif; then
- ewarn "Warning: no graphic toolkit selected (gtk or motif)."
- ewarn "Upstream suggests to enable one of the toolkits (or both)"
- ewarn "or only the command line utilities will be helpful."
- fi
-}
-
-src_compile() {
- local myconf
-
- if use opengl; then
- if use guile; then
- myconf="${myconf} --with-gl"
- else
- myconf="${myconf} --with-just-gl"
- fi
- else
- myconf="${myconf} --without-gl"
- fi
-
- econf \
- $(use_with alsa) \
- $(use_with oss) \
- --without-esd \
- $(use_with fam) \
- $(use_with fftw) \
- $(use_with gsl) \
- $(use_with gtk) \
- $(use_with guile) \
- $(use_with jack) \
- $(use_with ladspa) \
- $(use_with motif) \
- $(use_enable nls) \
- $(use_with ruby) \
- $(use_with cairo) \
- $(use_with xpm) \
- --with-float-samples \
- ${myconf} || die
-
- emake snd || die "emake snd failed"
-
- # compiling command-line programs. See bug #112695
- # do not compile ruby extensions for command line programs
- # those fail to compile
- if use ruby; then
- econf \
- $(use_with alsa) \
- --without-esd \
- $(use_with fam) \
- $(use_with fftw) \
- $(use_with gsl) \
- $(use_with gtk) \
- $(use_with guile) \
- $(use_with jack) \
- $(use_with ladspa) \
- $(use_with motif) \
- $(use_enable nls) \
- $(use_with xpm) \
- --without-ruby \
- --with-float-samples \
- ${myconf} || die
- fi
-
- for i in sndrecord sndinfo audinfo sndplay; do
- emake ${i} || die "make ${i} failed"
- done
-}
-
-src_install () {
- dobin snd
- dobin sndplay
- dobin sndrecord
- dobin sndinfo
- dobin audinfo
-
- insinto /usr/$(get_libdir)/snd/scheme
- doins *.scm
-
- dodoc README.Snd HISTORY.Snd TODO.Snd Snd.ad
- dohtml -r *.html *.png tutorial
-}