summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2003-10-23 22:48:16 +0000
committerStefan Jones <cretin@gentoo.org>2003-10-23 22:48:16 +0000
commit8ce7e874ee16bba3f83a22e74ac9f9453c46d898 (patch)
tree8ed9450194e533a69eded052adae4ef5f28b6d7b
parentminor fix (diff)
downloadgentoo-2-8ce7e874ee16bba3f83a22e74ac9f9453c46d898.tar.gz
gentoo-2-8ce7e874ee16bba3f83a22e74ac9f9453c46d898.tar.bz2
gentoo-2-8ce7e874ee16bba3f83a22e74ac9f9453c46d898.zip
New ebuild
-rw-r--r--dev-util/oprofile/ChangeLog10
-rw-r--r--dev-util/oprofile/Manifest3
-rw-r--r--dev-util/oprofile/files/digest-oprofile-0.71
-rw-r--r--dev-util/oprofile/oprofile-0.7.ebuild59
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
new file mode 100644
index 000000000000..ed0f3d8dcc64
--- /dev/null
+++ b/dev-util/oprofile/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/oprofile
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.1 2003/10/23 22:48:16 cretin Exp $
+
+*oprofile-0.7 (23 Oct 2003)
+
+ 23 Oct 2003; Stefan Jones <cretin@gentoo.org>:
+ Initial import. Ebuild submitted by Marc Bevand <bevand_m@epita.fr>.
+ See bug #31101.
+
diff --git a/dev-util/oprofile/Manifest b/dev-util/oprofile/Manifest
new file mode 100644
index 000000000000..cfb3a17b3c85
--- /dev/null
+++ b/dev-util/oprofile/Manifest
@@ -0,0 +1,3 @@
+MD5 bdaedbd1d27e7c91a6d7cc35abcb7b3e oprofile-0.7.ebuild 1731
+MD5 908127b0c92bd9c241dddacfe4b0dfbe ChangeLog 295
+MD5 06028442781220898a045871c9db7de6 files/digest-oprofile-0.7 64
diff --git a/dev-util/oprofile/files/digest-oprofile-0.7 b/dev-util/oprofile/files/digest-oprofile-0.7
new file mode 100644
index 000000000000..a42a017bb86a
--- /dev/null
+++ b/dev-util/oprofile/files/digest-oprofile-0.7
@@ -0,0 +1 @@
+MD5 7ea8ee0c2efd2edf4294ff8316f2cb66 oprofile-0.7.tar.gz 533420
diff --git a/dev-util/oprofile/oprofile-0.7.ebuild b/dev-util/oprofile/oprofile-0.7.ebuild
new file mode 100644
index 000000000000..7b3ea5dadc20
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.7.ebuild,v 1.1 2003/10/23 22:48:16 cretin Exp $
+
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://oprofile.sourceforge.net"
+SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+# IUSE: it also needs kernel sources but all gentoo users have them
+IUSE="qt"
+DEPEND="
+ >=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt? ( >=x11-libs/qt-3.2.1-r2 )"
+
+src_compile() {
+ check_KV
+
+ local myconf=""
+
+ myconf="${myconf} --with-x"
+ # note: compilation has only been tested with a 2.4 kernel
+ case $KV in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=/usr/src/linux";;
+ 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
+ *) die "Kernel version '$KV' not supported";;
+ esac
+ econf ${myconf} || die "econf failed"
+
+ local mymake=""
+
+ sed -i -e "s,depmod -a,:,g" Makefile
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ local myinst=""
+
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV}"
+ make DESTDIR=${D} ${myinst} install || die "make install failed"
+
+ dodoc ChangeLog* README TODO
+}
+
+pkg_postinst() {
+ # media-video/nvidia-kernel does the following:
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ echo
+ einfo "Now load the oprofile module by running:"
+ einfo " # opcontrol --init"
+ einfo "Then read manpages and this html doc:"
+ einfo " /usr/share/doc/oprofile/oprofile.html"
+ echo
+}