summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-21 17:53:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-21 17:53:31 +0000
commit8f2b6d101dc957fda34b8e958e7c68a17628dcfe (patch)
tree57298271146493bc32cef646584b75636d227f08
parentAdd ~amd64 (diff)
downloadgentoo-2-8f2b6d101dc957fda34b8e958e7c68a17628dcfe.tar.gz
gentoo-2-8f2b6d101dc957fda34b8e958e7c68a17628dcfe.tar.bz2
gentoo-2-8f2b6d101dc957fda34b8e958e7c68a17628dcfe.zip
Add a live ebuild
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--x11-libs/libva-vdpau-driver/ChangeLog8
-rw-r--r--x11-libs/libva-vdpau-driver/libva-vdpau-driver-9999.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/x11-libs/libva-vdpau-driver/ChangeLog b/x11-libs/libva-vdpau-driver/ChangeLog
index 89055066c494..099085f71402 100644
--- a/x11-libs/libva-vdpau-driver/ChangeLog
+++ b/x11-libs/libva-vdpau-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libva-vdpau-driver
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/ChangeLog,v 1.1 2012/11/21 17:39:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/ChangeLog,v 1.2 2012/11/21 17:53:31 aballier Exp $
+
+*libva-vdpau-driver-9999 (21 Nov 2012)
+
+ 21 Nov 2012; Alexis Ballier <aballier@gentoo.org>
+ +libva-vdpau-driver-9999.ebuild:
+ Add a live ebuild
*libva-vdpau-driver-0.7.4 (21 Nov 2012)
*libva-vdpau-driver-0.7.3 (21 Nov 2012)
diff --git a/x11-libs/libva-vdpau-driver/libva-vdpau-driver-9999.ebuild b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-9999.ebuild
new file mode 100644
index 000000000000..9fe5110c63fd
--- /dev/null
+++ b/x11-libs/libva-vdpau-driver/libva-vdpau-driver-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-vdpau-driver/libva-vdpau-driver-9999.ebuild,v 1.1 2012/11/21 17:53:31 aballier Exp $
+
+EAPI=4
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-2
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/vdpau-driver"
+fi
+
+inherit autotools ${SCM}
+
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="http://www.freedesktop.org/software/vaapi/releases/libva-vdpau-driver/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86"
+else
+ KEYWORDS=""
+fi
+IUSE="debug opengl"
+
+RDEPEND=">=x11-libs/libva-1.1.0[X,opengl?]
+ opengl? ( virtual/opengl )
+ x11-libs/libvdpau
+ !x11-libs/vdpau-video"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable debug) \
+ $(use_enable opengl glx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS README AUTHORS
+ find "${D}" -name '*.la' -delete
+}