summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-27 00:59:15 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-27 00:59:15 +0000
commit90045bc9ff6762da905b5a22504885dd39fc7d09 (patch)
tree9e65eb3c3cedf8f5ec43caea99de099e1ab68991
parentarm/hppa/ia64/s390/sh stable (diff)
downloadgentoo-2-90045bc9ff6762da905b5a22504885dd39fc7d09.tar.gz
gentoo-2-90045bc9ff6762da905b5a22504885dd39fc7d09.tar.bz2
gentoo-2-90045bc9ff6762da905b5a22504885dd39fc7d09.zip
Version bump.
(Portage version: 2.1_pre3-r1)
-rw-r--r--sys-apps/acl/ChangeLog9
-rw-r--r--sys-apps/acl/acl-2.2.34.ebuild52
-rw-r--r--sys-apps/acl/files/digest-acl-2.2.341
-rw-r--r--sys-apps/attr/ChangeLog9
-rw-r--r--sys-apps/attr/attr-2.4.28.ebuild54
-rw-r--r--sys-apps/attr/files/digest-attr-2.4.281
-rw-r--r--sys-apps/dmapi/ChangeLog9
-rw-r--r--sys-apps/dmapi/dmapi-2.2.3.ebuild44
-rw-r--r--sys-apps/dmapi/files/digest-dmapi-2.2.31
-rw-r--r--sys-fs/xfsdump/ChangeLog9
-rw-r--r--sys-fs/xfsdump/files/digest-xfsdump-2.2.331
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.33.ebuild47
12 files changed, 229 insertions, 8 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index e7736ad65f37..c87a4ac59102 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/acl
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.44 2005/11/29 02:28:10 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.45 2006/01/27 00:58:05 vapier Exp $
+
+*acl-2.2.34 (27 Jan 2006)
+
+ 27 Jan 2006; Mike Frysinger <vapier@gentoo.org> +acl-2.2.34.ebuild:
+ Version bump.
*acl-2.2.32 (29 Nov 2005)
diff --git a/sys-apps/acl/acl-2.2.34.ebuild b/sys-apps/acl/acl-2.2.34.ebuild
new file mode 100644
index 000000000000..ac0b758e0302
--- /dev/null
+++ b/sys-apps/acl/acl-2.2.34.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.34.ebuild,v 1.1 2006/01/27 00:58:05 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Access control list utilities, libraries and headers"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz
+ ftp://xfs.org/mirror/SGI/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=">=sys-apps/attr-2.4
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.32-only-symlink-when-needed.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install install-dev install-lib || die
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libacl.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libacl.so
+}
diff --git a/sys-apps/acl/files/digest-acl-2.2.34 b/sys-apps/acl/files/digest-acl-2.2.34
new file mode 100644
index 000000000000..53ae0f83301e
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-2.2.34
@@ -0,0 +1 @@
+MD5 50f1c271071048539d25ad67f1e8b375 acl-2.2.34.src.tar.gz 144773
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index a5d836c30065..a032e0b3046e 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/attr
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.51 2005/11/29 02:27:32 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.52 2006/01/27 00:59:15 vapier Exp $
+
+*attr-2.4.28 (27 Jan 2006)
+
+ 27 Jan 2006; Mike Frysinger <vapier@gentoo.org> +attr-2.4.28.ebuild:
+ Version bump.
*attr-2.4.24 (29 Nov 2005)
diff --git a/sys-apps/attr/attr-2.4.28.ebuild b/sys-apps/attr/attr-2.4.28.ebuild
new file mode 100644
index 000000000000..238f33afde06
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.28.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.28.ebuild,v 1.1 2006/01/27 00:59:15 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz
+ ftp://xfs.org/mirror/SGI/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ nls? ( sys-devel/gettext )
+ sys-devel/libtool"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.4.24-only-symlink-when-needed.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install install-lib install-dev || die
+ # the man-pages packages provides the man2 files
+ rm -r "${D}"/usr/share/man/man2
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libattr.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libattr.so
+}
diff --git a/sys-apps/attr/files/digest-attr-2.4.28 b/sys-apps/attr/files/digest-attr-2.4.28
new file mode 100644
index 000000000000..1ae412814bd0
--- /dev/null
+++ b/sys-apps/attr/files/digest-attr-2.4.28
@@ -0,0 +1 @@
+MD5 4fe11d4221199e51f6eeeee37d5dd84c attr-2.4.28.src.tar.gz 106506
diff --git a/sys-apps/dmapi/ChangeLog b/sys-apps/dmapi/ChangeLog
index 9dcc9a0ecaf9..5b842d7b38ad 100644
--- a/sys-apps/dmapi/ChangeLog
+++ b/sys-apps/dmapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dmapi
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/ChangeLog,v 1.27 2005/11/29 02:22:43 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/ChangeLog,v 1.28 2006/01/27 00:57:21 vapier Exp $
+
+*dmapi-2.2.3 (27 Jan 2006)
+
+ 27 Jan 2006; Mike Frysinger <vapier@gentoo.org> +dmapi-2.2.3.ebuild:
+ Version bump.
29 Nov 2005; Mike Frysinger <vapier@gentoo.org>
+files/dmapi-2.2.1-only-symlink-when-needed.patch, dmapi-2.2.1.ebuild:
diff --git a/sys-apps/dmapi/dmapi-2.2.3.ebuild b/sys-apps/dmapi/dmapi-2.2.3.ebuild
new file mode 100644
index 000000000000..90c501940db5
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.2.3.ebuild,v 1.1 2006/01/27 00:57:21 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="XFS data management API library"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-fs/xfsprogs"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.1-only-symlink-when-needed.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf --libexecdir=/usr/$(get_libdir) || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install install-dev || die
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libdm.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libdm.so
+}
diff --git a/sys-apps/dmapi/files/digest-dmapi-2.2.3 b/sys-apps/dmapi/files/digest-dmapi-2.2.3
new file mode 100644
index 000000000000..b1b4a31ec27e
--- /dev/null
+++ b/sys-apps/dmapi/files/digest-dmapi-2.2.3
@@ -0,0 +1 @@
+MD5 e3bb24818f07139e7c5f024dc4e7bb89 dmapi-2.2.3.src.tar.gz 78451
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index a1b002a3b15c..5557bf58bbeb 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/xfsdump
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.23 2005/09/04 05:16:09 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.24 2006/01/27 00:57:24 vapier Exp $
+
+*xfsdump-2.2.33 (27 Jan 2006)
+
+ 27 Jan 2006; Mike Frysinger <vapier@gentoo.org> +xfsdump-2.2.33.ebuild:
+ Version bump.
04 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+files/xfsdump-2.2.30-docs.patch, xfsdump-2.2.30.ebuild:
diff --git a/sys-fs/xfsdump/files/digest-xfsdump-2.2.33 b/sys-fs/xfsdump/files/digest-xfsdump-2.2.33
new file mode 100644
index 000000000000..20693f6168f1
--- /dev/null
+++ b/sys-fs/xfsdump/files/digest-xfsdump-2.2.33
@@ -0,0 +1 @@
+MD5 d891a6f0215f4ad33840ddf60a295ec7 xfsdump-2.2.33.src.tar.gz 576941
diff --git a/sys-fs/xfsdump/xfsdump-2.2.33.ebuild b/sys-fs/xfsdump/xfsdump-2.2.33.ebuild
new file mode 100644
index 000000000000..121c6fb8aa29
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.33.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.33.ebuild,v 1.1 2006/01/27 00:57:24 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc -sparc ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/xfsdump-2.2.30-docs.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ include/builddefs.in \
+ || die
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install || die
+ prepalldocs
+}