summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-24 16:03:07 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-24 16:03:07 +0000
commit90ad1c89fcfa988c67d8b1d615a1b30f36989af7 (patch)
tree5d6dff6c2509cd3818389f89d4eaef10f693e681
parentVersion bumped. (diff)
downloadgentoo-2-90ad1c89fcfa988c67d8b1d615a1b30f36989af7.tar.gz
gentoo-2-90ad1c89fcfa988c67d8b1d615a1b30f36989af7.tar.bz2
gentoo-2-90ad1c89fcfa988c67d8b1d615a1b30f36989af7.zip
Version bumped.
-rw-r--r--media-sound/alsa-tools/ChangeLog7
-rw-r--r--media-sound/alsa-tools/Manifest4
-rw-r--r--media-sound/alsa-tools/alsa-tools-0.9.8.ebuild69
-rw-r--r--media-sound/alsa-tools/files/digest-alsa-tools-0.9.81
-rw-r--r--media-sound/alsa-utils/ChangeLog7
-rw-r--r--media-sound/alsa-utils/Manifest4
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.9.8.ebuild60
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-0.9.81
8 files changed, 147 insertions, 6 deletions
diff --git a/media-sound/alsa-tools/ChangeLog b/media-sound/alsa-tools/ChangeLog
index a6b4e3a8b8af..f0dc79724232 100644
--- a/media-sound/alsa-tools/ChangeLog
+++ b/media-sound/alsa-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-tools
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.29 2003/10/07 10:01:24 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.30 2003/10/24 15:59:26 mholzer Exp $
+
+*alsa-tools-0.9.8 (25 Oct 2003)
+
+ 25 Oct 2003; Martin Holzer <mholzer@gentoo.org> alsa-tools-0.9.8.ebuild:
+ Version bumped.
07 Oct 2003; Bartosch Pixa <darkspecter@gentoo.org> alsa-tools-0.9.7.ebuild:
minor econf tweak
diff --git a/media-sound/alsa-tools/Manifest b/media-sound/alsa-tools/Manifest
index 3c38afd81213..1f061ea33d2d 100644
--- a/media-sound/alsa-tools/Manifest
+++ b/media-sound/alsa-tools/Manifest
@@ -1,7 +1,7 @@
-MD5 af501d08ebdf5a48a209d019713b757b ChangeLog 4385
+MD5 ad0c0b34458bbc17e59c3a67abc38119 ChangeLog 4508
MD5 64c9009618163c95b3f051ad3c99136c alsa-tools-0.9.0_rc1-r1.ebuild 1299
MD5 b2733e2f3b4d24bd1cd9f64d538820f0 alsa-tools-0.9.1.ebuild 1276
-MD5 da42a5203faf03be0d46daf0d460cb18 alsa-tools-0.9.8.ebuild 1822
+MD5 34b34200e3bd057014f8f636c9f03a68 alsa-tools-0.9.8.ebuild 1819
MD5 3467e9b3ac3ee6b19ed809b7cf09203c alsa-tools-0.9.6.ebuild 1282
MD5 5a4a356c90a8cffd49a886cbad19f5df alsa-tools-0.9.6-r1.ebuild 1570
MD5 569e45b019904737f73ee99df2dfd161 alsa-tools-0.9.7.ebuild 1802
diff --git a/media-sound/alsa-tools/alsa-tools-0.9.8.ebuild b/media-sound/alsa-tools/alsa-tools-0.9.8.ebuild
new file mode 100644
index 000000000000..7186cccffd26
--- /dev/null
+++ b/media-sound/alsa-tools/alsa-tools-0.9.8.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-0.9.8.ebuild,v 1.1 2003/10/24 15:59:26 mholzer Exp $
+
+IUSE=""
+
+DESCRIPTION="Advanced Linux Sound Architecture tools"
+HOMEPAGE="http://www.alsa-project.org"
+SRC_URI="mirror://alsaproject/tools/${P}.tar.bz2"
+RESTRICT="nomirror"
+
+SLOT="0.9"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+
+DEPEND=">=media-libs/alsa-lib-0.9.8
+ virtual/alsa
+ =x11-libs/fltk-1.1*
+ =x11-libs/gtk+-1.2*"
+
+# This is a list of the tools in the package.
+# Some of the tools don't make proper use of CFLAGS, even though
+# all of them seem to use autoconf. This needs to be fixed.
+ALSA_TOOLS="ac3dec as10k1 envy24control hdspmixer mixartloader rmedigicontrol \
+ sb16_csp seq/sbiload vxloader"
+# The below two tools do not compile with linux-headers from 2.4 kernels
+# as of alsa-tools-0.9.7, so I removed them from the list for now.
+# Bug reports have been sent to the alsa-devel mailing list.
+#
+# hdsploader
+# sscape_ctl
+
+src_compile() {
+ # hdspmixer requires fltk
+ export LDFLAGS="-L/usr/lib/fltk-1.1"
+ export CPPFLAGS="-I/usr/include/fltk-1.1"
+
+ # hdspmixer is missing depconf - copy from the hdsploader directory
+ cp ${S}/hdsploader/depcomp ${S}/hdspmixer/
+
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ cd "${S}/${f}"
+ econf --with-kernel="${KV}" || die "configure failed"
+ emake || die "make failed"
+ done
+}
+
+src_install() {
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ # Install the main stuff
+ cd "${S}/${f}"
+ make DESTDIR="${D}" install || die
+
+ # Install the text documentation
+ local doc
+ for doc in README TODO ChangeLog COPYING AUTHORS
+ do
+ if [ -f "${doc}" ]
+ then
+ mv "${doc}" "${doc}.`basename ${f}`"
+ dodoc "${doc}.`basename ${f}`"
+ fi
+ done
+ done
+}
diff --git a/media-sound/alsa-tools/files/digest-alsa-tools-0.9.8 b/media-sound/alsa-tools/files/digest-alsa-tools-0.9.8
new file mode 100644
index 000000000000..11ec5ad67b0f
--- /dev/null
+++ b/media-sound/alsa-tools/files/digest-alsa-tools-0.9.8
@@ -0,0 +1 @@
+MD5 22f87849e79b3fdab9385c2f9772a0df alsa-tools-0.9.8.tar.bz2 1491132
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 524e40895f67..8332ef4874ff 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.30 2003/10/02 22:08:15 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.31 2003/10/24 16:03:02 mholzer Exp $
+
+*alsa-utils-0.9.8 (25 Oct 2003)
+
+ 25 Oct 2003; Martin Holzer <mholzer@gentoo.org> alsa-utils-0.9.8.ebuild:
+ Version bumped.
04 Sep 2003; John Mylchreest <johnm@gentoo.org>; files/alsasound:
Updating init script to load all oss compat modules. not just pcm-oss
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index 0ed176def39b..fe67098a4134 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -1,4 +1,4 @@
-MD5 d13988c0c19d5d92391ec9fcd7b40557 ChangeLog 5115
+MD5 ca7e27afbd2aeb5a5d8096a14030a33e ChangeLog 5242
MD5 b268f1eb52b27b8146ddf58e76c55d4f alsa-utils-0.5.10-r8.ebuild 970
MD5 0d1f89bc0713a7239243219ee57a1b7b alsa-utils-0.9.0_rc2.ebuild 921
MD5 140f4dd3c22323f5e9f671306f048d4d alsa-utils-0.9.2.ebuild 907
@@ -9,7 +9,7 @@ MD5 8d8a738c55cb1b609acd49712b71566e alsa-utils-0.9.6-r1.ebuild 1827
MD5 a7b579dbc473137239d11d3044a960c4 alsa-utils-0.9.6.ebuild 892
MD5 0aa35474d99922f05f33a617587da4c9 alsa-utils-0.9.7.ebuild 1823
MD5 e1147a642867b3b3ea43518a1376f6d2 metadata.xml 250
-MD5 320af82f0716aa15324e19f00a43fcd3 alsa-utils-0.9.8.ebuild 1843
+MD5 8779e74fa59ff612c542462297d7f961 alsa-utils-0.9.8.ebuild 1843
MD5 dcc66ee6a9db24006a4158e2be0da3f2 files/alsa-0.5.10 392
MD5 f8aff370f9c369682ac793f5b3f4886e files/alsa-modules.conf-rc 1158
MD5 f20045fc395596290d5a6d807ba311fc files/alsa-utils-0.5.10-aplay-destdir.diff 626
diff --git a/media-sound/alsa-utils/alsa-utils-0.9.8.ebuild b/media-sound/alsa-utils/alsa-utils-0.9.8.ebuild
new file mode 100644
index 000000000000..0aefd5d2965b
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-0.9.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.9.8.ebuild,v 1.1 2003/10/24 16:03:02 mholzer Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+DEPEND=">=sys-libs/ncurses-5.1
+ >=media-libs/alsa-lib-0.9.8"
+
+SLOT="0.9"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2"
+RESTRICT="nomirror"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ econf || die "./configure failed"
+ emake || die "Parallel Make Failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="COPYING ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ dodir /etc/init.d
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run update-modules. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && update-modules"
+ echo
+ ewarn "Pausing for 20 seconds to give you time to read..."
+ sleep 20
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-0.9.8 b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.8
new file mode 100644
index 000000000000..eb1112b97381
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.8
@@ -0,0 +1 @@
+MD5 09f3ac08683da2ad1d4d1a27401a5d66 alsa-utils-0.9.8.tar.bz2 108607