summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-22 14:24:39 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-22 14:24:39 +0000
commit9366bdecedd02d86e14fe2d5bb8077d715b29ded (patch)
tree95dbd9e5e96da8c59114b25e1de13b461cb8fa78
parentnew ebuild for dunst (diff)
downloadgentoo-2-9366bdecedd02d86e14fe2d5bb8077d715b29ded.tar.gz
gentoo-2-9366bdecedd02d86e14fe2d5bb8077d715b29ded.tar.bz2
gentoo-2-9366bdecedd02d86e14fe2d5bb8077d715b29ded.zip
Version bump, thanks to Andreis Vinogradovs. Sync live ebuild
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/vzctl-4.2.ebuild76
-rw-r--r--sys-cluster/vzctl/vzctl-9999.ebuild24
3 files changed, 99 insertions, 9 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 79771e82602a..ff1b39b5deb7 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.104 2013/02/16 13:02:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.105 2013/02/22 14:24:39 pinkbyte Exp $
+
+*vzctl-4.2 (22 Feb 2013)
+
+ 22 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> +vzctl-4.2.ebuild,
+ vzctl-9999.ebuild:
+ Version bump, thanks to Andreis Vinogradovs. Sync live ebuild
16 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #96436
diff --git a/sys-cluster/vzctl/vzctl-4.2.ebuild b/sys-cluster/vzctl/vzctl-4.2.ebuild
new file mode 100644
index 000000000000..ccc6769579a0
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-4.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-4.2.ebuild,v 1.1 2013/02/22 14:24:39 pinkbyte Exp $
+
+EAPI="5"
+
+inherit base bash-completion-r1 eutils toolchain-funcs udev
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgroup +ploop"
+
+RDEPEND="
+ net-firewall/iptables
+ sys-apps/ed
+ >=sys-apps/iproute2-3.3.0
+ sys-fs/vzquota
+ ploop? ( >=sys-cluster/ploop-1.5 )
+ cgroup? ( >=dev-libs/libcgroup-0.37 )
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo
+ sed -i -e 's:=redhat-:=gentoo-:' etc/dists/default || die 'sed on etc/dists/default failed'
+ # Set proper udev directory
+ sed -i -e "s:/lib/udev:$(udev_get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate \
+ $(use_with ploop) \
+ $(use_with cgroup)
+}
+
+src_install() {
+ emake DESTDIR="${D}" udevdir="$(udev_get_udevdir)"/rules.d install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+
+ if use cgroup; then
+ ewarn "You have chose to use experimental CGROUP feature"
+ ewarn "please do NOT file bugs to Gentoo bugzilla,"
+ ewarn "use upstream bug tracker instead"
+ fi
+}
diff --git a/sys-cluster/vzctl/vzctl-9999.ebuild b/sys-cluster/vzctl/vzctl-9999.ebuild
index 86f3c1440ce2..5684f68c5b61 100644
--- a/sys-cluster/vzctl/vzctl-9999.ebuild
+++ b/sys-cluster/vzctl/vzctl-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.13 2012/12/13 08:45:38 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.14 2013/02/22 14:24:39 pinkbyte Exp $
EAPI="5"
-inherit bash-completion-r1 autotools git-2 udev toolchain-funcs
+inherit bash-completion-r1 autotools git-2 toolchain-funcs udev
DESCRIPTION="OpenVZ ConTainers control utility"
HOMEPAGE="http://openvz.org/"
@@ -14,24 +14,26 @@ EGIT_REPO_URI="git://git.openvz.org/pub/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="+ploop +cgroup"
+IUSE="cgroup +ploop"
RDEPEND="
net-firewall/iptables
sys-apps/ed
- >=sys-apps/iproute2-3.0
+ >=sys-apps/iproute2-3.3.0
sys-fs/vzquota
ploop? ( >=sys-cluster/ploop-1.5 )
- cgroup? ( >=dev-libs/libcgroup-0.37 )"
+ cgroup? ( >=dev-libs/libcgroup-0.37 )
+"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
# Set default OSTEMPLATE on gentoo
- sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+ sed -i -e 's:=redhat-:=gentoo-:' etc/dists/default || die 'sed on etc/dists/default failed'
+ # Set proper udev directory
+ sed -i -e "s:/lib/udev:$(udev_get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
eautoreconf
- sed -i -e "s:/lib/udev:$(udev_get_udevdir):" src/lib/dev.c || die
}
src_configure() {
@@ -67,4 +69,10 @@ pkg_postinst() {
ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
ewarn "/etc/init.d/vzeventd."
+
+ if use cgroup; then
+ ewarn "You have chose to use experimental CGROUP feature"
+ ewarn "please do NOT file bugs to Gentoo bugzilla,"
+ ewarn "use upstream bug tracker instead"
+ fi
}