summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-04-02 03:47:28 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-04-02 03:47:28 +0000
commit93ae2ef34e6861fe580155b4a382d44add8eedd4 (patch)
treeba6fff21512e56b07f0a33941bc4b5e2f35ef158
parentfixing Manifest (diff)
downloadgentoo-2-93ae2ef34e6861fe580155b4a382d44add8eedd4.tar.gz
gentoo-2-93ae2ef34e6861fe580155b4a382d44add8eedd4.tar.bz2
gentoo-2-93ae2ef34e6861fe580155b4a382d44add8eedd4.zip
Updated with patches to fix recent DoS in Unreal engine based games. See bug #44351 for more information.
-rw-r--r--games-fps/ut2003-demo/ChangeLog10
-rw-r--r--games-fps/ut2003-demo/files/digest-ut2003-demo-2206-r3 (renamed from games-fps/ut2003-demo/files/digest-ut2003-demo-2206-r2)0
-rw-r--r--games-fps/ut2003-demo/files/ut2003-demo.desktop8
-rw-r--r--games-fps/ut2003-demo/ut2003-demo-2206-r3.ebuild (renamed from games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild)39
4 files changed, 38 insertions, 19 deletions
diff --git a/games-fps/ut2003-demo/ChangeLog b/games-fps/ut2003-demo/ChangeLog
index aa0e6e0cdb8b..ee7d9a142c25 100644
--- a/games-fps/ut2003-demo/ChangeLog
+++ b/games-fps/ut2003-demo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-fps/ut2003-demo
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-demo/ChangeLog,v 1.5 2004/02/27 16:49:42 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-demo/ChangeLog,v 1.6 2004/04/02 03:47:28 wolf31o2 Exp $
+
+*ut2003-demo-2206-r3 (01 Apr 2004)
+
+ 01 Apr 2004; Chris Gianelloni <wolf31o2@gentoo.org>
+ ut2003-demo-2206-r2.ebuild, ut2003-demo-2206-r3.ebuild,
+ files/ut2003-demo.desktop:
+ Updated with patches to fix recent DoS in Unreal engine based games. See bug
+ #44351 for more information.
27 Feb 2004; Chris Gianelloni <wolf31o2@gentoo.org>
ut2003-demo-2206-r2.ebuild:
diff --git a/games-fps/ut2003-demo/files/digest-ut2003-demo-2206-r2 b/games-fps/ut2003-demo/files/digest-ut2003-demo-2206-r3
index 58d9e4e609c5..58d9e4e609c5 100644
--- a/games-fps/ut2003-demo/files/digest-ut2003-demo-2206-r2
+++ b/games-fps/ut2003-demo/files/digest-ut2003-demo-2206-r3
diff --git a/games-fps/ut2003-demo/files/ut2003-demo.desktop b/games-fps/ut2003-demo/files/ut2003-demo.desktop
deleted file mode 100644
index 14681a951004..000000000000
--- a/games-fps/ut2003-demo/files/ut2003-demo.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Name=UT2003-demo
-Comment=Unreal Tournament 2003 Demo
-Exec=ut2003-demo
-Icon=ut2003.png
-Terminal=0
-Type=Application
-Categories=Application;Game;
diff --git a/games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild b/games-fps/ut2003-demo/ut2003-demo-2206-r3.ebuild
index dfac32bfd091..0147c3a21266 100644
--- a/games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild
+++ b/games-fps/ut2003-demo/ut2003-demo-2206-r3.ebuild
@@ -1,19 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-demo/ut2003-demo-2206-r2.ebuild,v 1.6 2004/02/27 16:49:42 wolf31o2 Exp $.
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-demo/ut2003-demo-2206-r3.ebuild,v 1.1 2004/04/02 03:47:28 wolf31o2 Exp $.
inherit games
DESCRIPTION="Unreal Tournament 2003 Demo"
HOMEPAGE="http://www.ut2003.com/"
-SRC_URI="http://unreal.epicgames.com/linux/ut2003/ut2003demo-lnx-${PV}.sh.bin"
+SRC_URI="http://unreal.epicgames.com/linux/ut2003/ut2003demo-lnx-${PV}.sh.bin
+ http://download.factoryunreal.com/mirror/UT2003CrashFix.zip"
LICENSE="ut2003-demo"
SLOT="0"
KEYWORDS="-* x86"
RESTRICT="nostrip"
-DEPEND="virtual/opengl"
+DEPEND="virtual/opengl
+ app-arch/unzip"
+IUSE=""
S=${WORKDIR}
@@ -23,7 +26,10 @@ pkg_setup() {
}
src_unpack() {
- unpack_makeself
+ unpack_makeself ${DISTDIR}/ut2003demo-lnx-${PV}.sh.bin \
+ || die "unpacking demo"
+ unzip unzip ${DISTDIR}/UT2003CrashFix.zip \
+ || die "unpacking crash-fix"
tar -zxf setupstuff.tar.gz || die
}
@@ -57,10 +63,18 @@ src_install() {
exeinto ${dir}/Benchmark
doexe ${FILESDIR}/{benchmark,results.sh}
- # Security patch
- #cd ${D}/opt/ut2003-demo/System
- #cp ${DISTDIR}/IpDrv.so.bz2 .
- #bunzip2 --force IpDrv.so.bz2
+ # Here we apply DrSiN's crash patch
+ cp ${S}/CrashFix/System/crashfix.u ${Ddir}/System
+
+ed ${Ddir}/System/Default.ini >/dev/null 2>&1 <<EOT
+$
+?Engine.GameInfo?
+a
+AccessControlClass=crashfix.iaccesscontrolini
+.
+w
+q
+EOT
# create menu entry (closes bug #27594)
insinto /usr/share/applications
@@ -71,15 +85,20 @@ src_install() {
}
pkg_postinst() {
+ einfo "To play the game run:"
+ einfo " ut2003"
echo
- einfo "Type 'ut2003-demo' to start the game."
einfo "You can run benchmarks by typing 'ut2003-demo --bench' (MinDetail seems"
einfo "to not be working for some unknown reason :/)"
echo
einfo "Read ${dir}/README.linux for instructions on how to run a"
einfo "dedicated server."
echo
- einfo "Have fun :)"
+ ewarn "If you are not installing for the first time and you plan on running"
+ ewarn "a server, you will probably need to edit your"
+ ewarn "~/.ut2003/System/UT2003.ini file and add a line that says"
+ ewarn "AccessControlClass=crashfix.iaccesscontrolini to your"
+ ewarn "[Engine.GameInfo] section to close a security issue."
games_pkg_postinst
}