summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-01-05 20:15:24 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-01-05 20:15:24 +0000
commit967b36761adba88a916cd4daa406ee409a16c8ef (patch)
tree68694cc7dd666d08d546fd6b49945228d0a65575
parentEAPI 5 (diff)
downloadgentoo-2-967b36761adba88a916cd4daa406ee409a16c8ef.tar.gz
gentoo-2-967b36761adba88a916cd4daa406ee409a16c8ef.tar.bz2
gentoo-2-967b36761adba88a916cd4daa406ee409a16c8ef.zip
EAPI 5
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
-rw-r--r--games-arcade/tuxdash/ChangeLog7
-rw-r--r--games-arcade/tuxdash/tuxdash-0.8.ebuild11
2 files changed, 11 insertions, 7 deletions
diff --git a/games-arcade/tuxdash/ChangeLog b/games-arcade/tuxdash/ChangeLog
index fe4dd9fd46af..443bee5d029f 100644
--- a/games-arcade/tuxdash/ChangeLog
+++ b/games-arcade/tuxdash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/tuxdash
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxdash/ChangeLog,v 1.8 2010/09/30 04:29:54 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxdash/ChangeLog,v 1.9 2015/01/05 20:15:24 tupone Exp $
+
+ 05 Jan 2015; Tupone Alfredo <tupone@gentoo.org> tuxdash-0.8.ebuild:
+ EAPI 5
30 Sep 2010; Tupone Alfredo <tupone@gentoo.org> tuxdash-0.8.ebuild,
+files/tuxdash-0.8-ldflags.patch:
diff --git a/games-arcade/tuxdash/tuxdash-0.8.ebuild b/games-arcade/tuxdash/tuxdash-0.8.ebuild
index 14e389dd5b01..fef0a4e893af 100644
--- a/games-arcade/tuxdash/tuxdash-0.8.ebuild
+++ b/games-arcade/tuxdash/tuxdash-0.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxdash/tuxdash-0.8.ebuild,v 1.8 2010/10/12 04:28:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxdash/tuxdash-0.8.ebuild,v 1.9 2015/01/05 20:15:24 tupone Exp $
-EAPI=2
+EAPI=5
inherit eutils games
DESCRIPTION="A simple BoulderDash clone"
@@ -16,6 +16,7 @@ IUSE=""
DEPEND="media-libs/libsdl[video]
media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
src_prepare() {
rm -f GPL TuxDash
@@ -37,11 +38,11 @@ src_prepare() {
}
src_compile() {
- emake E_CXXFLAGS="${CXXFLAGS}" -C src || die "emake failed"
+ emake E_CXXFLAGS="${CXXFLAGS}" -C src
}
src_install() {
- dogamesbin tuxdash || die "dogamesbin failed"
+ dogamesbin tuxdash
dodir "${GAMES_DATADIR}/${PN}"
cp -r themes maps fonts savegames config "${D}/${GAMES_DATADIR}/${PN}" \
|| die "cp failed"