summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-10 20:56:15 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-10 20:56:15 +0000
commit96f2f4e0485076d95b68e00669b7a1ee3662fa17 (patch)
treee7a1652a858d3d9bf47ab55c878cfe5cb18350b1
parentppc stable, bug #98358 (diff)
downloadgentoo-2-96f2f4e0485076d95b68e00669b7a1ee3662fa17.tar.gz
gentoo-2-96f2f4e0485076d95b68e00669b7a1ee3662fa17.tar.bz2
gentoo-2-96f2f4e0485076d95b68e00669b7a1ee3662fa17.zip
QA: Removed 'emake || make || die' and variants. Either a package is parallel build safe or it is not. There's nothing like trying and falling back.
(Portage version: 2.0.51.22-r1)
-rw-r--r--mail-client/evolution/ChangeLog9
-rw-r--r--mail-client/evolution/evolution-1.2.4.ebuild4
-rw-r--r--mail-client/evolution/evolution-2.0.3-r2.ebuild4
-rw-r--r--mail-client/evolution/evolution-2.0.4.ebuild4
-rw-r--r--mail-client/evolution/evolution-2.2.1.1.ebuild4
-rw-r--r--media-libs/libmpeg2/ChangeLog8
-rw-r--r--media-libs/libmpeg2/libmpeg2-0.3.1.ebuild4
-rw-r--r--media-libs/libmpeg2/libmpeg2-0.3.2_pre20030625.ebuild4
-rw-r--r--net-p2p/gnunet/ChangeLog7
-rw-r--r--net-p2p/gnunet/gnunet-0.6.6b.ebuild4
10 files changed, 35 insertions, 17 deletions
diff --git a/mail-client/evolution/ChangeLog b/mail-client/evolution/ChangeLog
index f32acffa6d82..9883dba48ceb 100644
--- a/mail-client/evolution/ChangeLog
+++ b/mail-client/evolution/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/evolution
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.77 2005/07/08 10:00:54 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.78 2005/07/10 20:52:50 swegener Exp $
+
+ 10 Jul 2005; Sven Wegener <swegener@gentoo.org> evolution-1.2.4.ebuild,
+ evolution-2.0.3-r2.ebuild, evolution-2.0.4.ebuild,
+ evolution-2.2.1.1.ebuild:
+ QA: Removed 'emake || make || die' and variants. Either a package is
+ parallel build safe or it is not. There's nothing like trying and falling
+ back.
*evolution-2.2.3 (07 Jul 2005)
diff --git a/mail-client/evolution/evolution-1.2.4.ebuild b/mail-client/evolution/evolution-1.2.4.ebuild
index 47bed52beb67..226eae82f1e5 100644
--- a/mail-client/evolution/evolution-1.2.4.ebuild
+++ b/mail-client/evolution/evolution-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.2.4.ebuild,v 1.7 2005/03/23 16:17:35 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.2.4.ebuild,v 1.8 2005/07/10 20:52:50 swegener Exp $
IUSE="ssl nls mozilla ldap doc spell pda ipv6 kerberos kde crypt"
@@ -191,7 +191,7 @@ src_compile() {
export LANG="C"
#needs to be able to connect to X display to build.
- Xemake || Xmake || die
+ Xemake -j1 || die
}
src_install() {
diff --git a/mail-client/evolution/evolution-2.0.3-r2.ebuild b/mail-client/evolution/evolution-2.0.3-r2.ebuild
index 20e738faa468..66338ac52418 100644
--- a/mail-client/evolution/evolution-2.0.3-r2.ebuild
+++ b/mail-client/evolution/evolution-2.0.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.0.3-r2.ebuild,v 1.9 2005/06/06 13:47:35 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.0.3-r2.ebuild,v 1.10 2005/07/10 20:52:50 swegener Exp $
inherit eutils gnome2 flag-o-matic alternatives
@@ -124,7 +124,7 @@ src_compile() {
gnome2_src_configure ${G2CONF} ${myconf}
- emake || make || die "make failed"
+ emake -j1 || die "make failed"
}
src_install() {
diff --git a/mail-client/evolution/evolution-2.0.4.ebuild b/mail-client/evolution/evolution-2.0.4.ebuild
index db4c816e4630..e20f3476ef80 100644
--- a/mail-client/evolution/evolution-2.0.4.ebuild
+++ b/mail-client/evolution/evolution-2.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.0.4.ebuild,v 1.9 2005/06/06 13:47:35 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.0.4.ebuild,v 1.10 2005/07/10 20:52:50 swegener Exp $
inherit eutils gnome2 flag-o-matic alternatives
@@ -121,7 +121,7 @@ src_compile() {
gnome2_src_configure ${G2CONF} ${myconf}
- emake || make || die "make failed"
+ emake -j1 || die "make failed"
}
src_install() {
diff --git a/mail-client/evolution/evolution-2.2.1.1.ebuild b/mail-client/evolution/evolution-2.2.1.1.ebuild
index b8aca6d3a206..0a7a494147ed 100644
--- a/mail-client/evolution/evolution-2.2.1.1.ebuild
+++ b/mail-client/evolution/evolution-2.2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.2.1.1.ebuild,v 1.12 2005/06/25 13:03:33 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.2.1.1.ebuild,v 1.13 2005/07/10 20:52:50 swegener Exp $
inherit eutils gnome2 flag-o-matic alternatives
@@ -133,7 +133,7 @@ src_compile() {
gnome2_src_configure ${G2CONF} ${myconf}
- emake || make || die "make failed"
+ emake -j1 || die "make failed"
}
src_install() {
diff --git a/media-libs/libmpeg2/ChangeLog b/media-libs/libmpeg2/ChangeLog
index 4e9236f222e1..9fb6966faffe 100644
--- a/media-libs/libmpeg2/ChangeLog
+++ b/media-libs/libmpeg2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmpeg2
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.41 2005/07/02 13:37:38 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.42 2005/07/10 20:56:15 swegener Exp $
+
+ 10 Jul 2005; Sven Wegener <swegener@gentoo.org> libmpeg2-0.3.1.ebuild,
+ libmpeg2-0.3.2_pre20030625.ebuild:
+ QA: Removed 'emake || make || die' and variants. Either a package is
+ parallel build safe or it is not. There's nothing like trying and falling
+ back.
02 Jul 2005; Bryan Østergaard <kloeri@gentoo.org> libmpeg2-0.4.0b.ebuild:
Stable on alpha.
diff --git a/media-libs/libmpeg2/libmpeg2-0.3.1.ebuild b/media-libs/libmpeg2/libmpeg2-0.3.1.ebuild
index 4971a2093280..6347956abe13 100644
--- a/media-libs/libmpeg2/libmpeg2-0.3.1.ebuild
+++ b/media-libs/libmpeg2/libmpeg2-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.3.1.ebuild,v 1.10 2005/03/21 06:58:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.3.1.ebuild,v 1.11 2005/07/10 20:56:15 swegener Exp $
IUSE="sdl X"
@@ -46,7 +46,7 @@ src_compile() {
econf --enable-shared \
${myconf} || die "./configure failed"
- emake || make || die
+ emake -j1 || die
}
src_install() {
diff --git a/media-libs/libmpeg2/libmpeg2-0.3.2_pre20030625.ebuild b/media-libs/libmpeg2/libmpeg2-0.3.2_pre20030625.ebuild
index 3164d1c1bc3a..8568f409109a 100644
--- a/media-libs/libmpeg2/libmpeg2-0.3.2_pre20030625.ebuild
+++ b/media-libs/libmpeg2/libmpeg2-0.3.2_pre20030625.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.3.2_pre20030625.ebuild,v 1.7 2005/03/21 06:58:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.3.2_pre20030625.ebuild,v 1.8 2005/07/10 20:56:15 swegener Exp $
IUSE="sdl X"
@@ -45,7 +45,7 @@ src_compile() {
econf --enable-shared \
${myconf} || die "./configure failed"
- emake || make || die
+ emake -j1 || die
}
src_install() {
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
index ef23279b53df..ac07ae5e5efd 100644
--- a/net-p2p/gnunet/ChangeLog
+++ b/net-p2p/gnunet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/gnunet
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.30 2005/05/29 21:26:17 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.31 2005/07/10 20:54:37 swegener Exp $
+
+ 10 Jul 2005; Sven Wegener <swegener@gentoo.org> gnunet-0.6.6b.ebuild:
+ QA: Removed 'emake || make || die' and variants. Either a package is
+ parallel build safe or it is not. There's nothing like trying and falling
+ back.
29 May 2005; Karol Wojtaszek <sekretarz@gentoo.org>
+files/gnunet-0.6.6b-autotools.patch, gnunet-0.6.6b.ebuild:
diff --git a/net-p2p/gnunet/gnunet-0.6.6b.ebuild b/net-p2p/gnunet/gnunet-0.6.6b.ebuild
index b88b54c1e3f2..39af816d304f 100644
--- a/net-p2p/gnunet/gnunet-0.6.6b.ebuild
+++ b/net-p2p/gnunet/gnunet-0.6.6b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.6.6b.ebuild,v 1.3 2005/05/29 21:26:17 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.6.6b.ebuild,v 1.4 2005/07/10 20:54:37 swegener Exp $
inherit eutils libtool
@@ -55,7 +55,7 @@ src_compile() {
econf ${myconf} || die "econf failed"
- emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "emake failed"
+ emake -j1 || die "emake failed"
}
src_install() {