summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-09-24 11:52:52 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-09-24 11:52:52 +0000
commit99980a6a43c40ece01bd2d70080807b164ea73e9 (patch)
tree5beb005bf781c2122c794c18277ff2c0ee608e61
parentVersion bump, drop old. Correct python USE dependencies (diff)
downloadgentoo-2-99980a6a43c40ece01bd2d70080807b164ea73e9.tar.gz
gentoo-2-99980a6a43c40ece01bd2d70080807b164ea73e9.tar.bz2
gentoo-2-99980a6a43c40ece01bd2d70080807b164ea73e9.zip
Version bump, wrt bug #475706
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
-rw-r--r--net-misc/quagga/ChangeLog7
-rw-r--r--net-misc/quagga/quagga-0.99.22.4.ebuild116
2 files changed, 122 insertions, 1 deletions
diff --git a/net-misc/quagga/ChangeLog b/net-misc/quagga/ChangeLog
index 47e04bab215b..501cff009657 100644
--- a/net-misc/quagga/ChangeLog
+++ b/net-misc/quagga/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/quagga
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/ChangeLog,v 1.155 2013/05/26 07:24:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/ChangeLog,v 1.156 2013/09/24 11:52:52 pinkbyte Exp $
+
+*quagga-0.99.22.4 (24 Sep 2013)
+
+ 24 Sep 2013; Sergey Popov <pinkbyte@gentoo.org> +quagga-0.99.22.4.ebuild:
+ Version bump, wrt bug #475706
26 May 2013; Agostino Sarubbo <ago@gentoo.org> quagga-0.99.22.1.ebuild:
Stable for ppc, wrt bug #464218
diff --git a/net-misc/quagga/quagga-0.99.22.4.ebuild b/net-misc/quagga/quagga-0.99.22.4.ebuild
new file mode 100644
index 000000000000..d4e3b6f1825d
--- /dev/null
+++ b/net-misc/quagga/quagga-0.99.22.4.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/quagga-0.99.22.4.ebuild,v 1.1 2013/09/24 11:52:52 pinkbyte Exp $
+
+EAPI="5"
+
+CLASSLESS_BGP_PATCH=ht-20040304-classless-bgp.patch
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils flag-o-matic multilib pam readme.gentoo user
+
+DESCRIPTION="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP"
+HOMEPAGE="http://quagga.net/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz
+ bgpclassless? ( http://hasso.linux.ee/stuff/patches/quagga/${CLASSLESS_BGP_PATCH} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="bgpclassless caps doc elibc_glibc ipv6 multipath ospfapi pam +readline snmp tcp-zebra"
+
+COMMON_DEPEND="
+ caps? ( sys-libs/libcap )
+ snmp? ( net-analyzer/net-snmp )
+ readline? (
+ sys-libs/readline
+ pam? ( sys-libs/pam )
+ )
+ !elibc_glibc? ( dev-libs/libpcre )"
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ >=sys-devel/libtool-2.2.4"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/openrc
+ sys-apps/iproute2"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="Sample configuration files can be found in /usr/share/doc/${PF}/samples
+You have to create config files in /etc/quagga before
+starting one of the daemons.
+
+You can pass additional options to the daemon by setting the EXTRA_OPTS
+variable in their respective file in /etc/conf.d
+
+Starting from version 0.99.18, quagga no longer supports the realms patch.
+The patch was abandoned upstream and once again didn't apply; it needs a
+dedicated maintainer, if it is still necessary."
+
+pkg_setup() {
+ enewgroup quagga
+ enewuser quagga -1 -1 /var/empty quagga
+}
+
+src_prepare() {
+ # Classless prefixes for BGP
+ # http://hasso.linux.ee/doku.php/english:network:quagga
+ use bgpclassless && epatch "${DISTDIR}/${CLASSLESS_BGP_PATCH}"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # do not build PDF docs
+ export ac_cv_prog_PDFLATEX=no
+ export ac_cv_prog_LATEXMK=no
+
+ local myeconfargs=(
+ --enable-user=quagga
+ --enable-group=quagga
+ --enable-vty-group=quagga
+ --with-cflags="${CFLAGS}"
+ --sysconfdir=/etc/quagga
+ --enable-exampledir=/usr/share/doc/${PF}/samples
+ --localstatedir=/run/quagga
+ --disable-static
+ --disable-pie
+ $(use_enable caps capabilities)
+ $(usex snmp '--enable-snmp' '' '' '')
+ $(use_enable !elibc_glibc pcreposix)
+ $(use_enable tcp-zebra)
+ $(use_enable doc)
+ $(usex multipath $(use_enable multipath) '' '=0' '')
+ $(usex ospfapi '--enable-opaque-lsa --enable-ospf-te --enable-ospfclient' '' '' '')
+ $(use_enable readline vtysh)
+ $(use_with pam libpam)
+ $(use_enable ipv6)
+ $(use_enable ipv6 babeld) # babeld does not build properly with USE="-ipv6", bug #446289
+ $(use_enable ipv6 ripngd)
+ $(use_enable ipv6 ospf6d)
+ $(use_enable ipv6 rtadv)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ readme.gentoo_create_doc
+
+ keepdir /etc/quagga
+ fowners root:quagga /etc/quagga
+ fperms 0770 /etc/quagga
+
+ # install zebra as a file, symlink the rest
+ newinitd "${FILESDIR}"/quagga-services.init.3 zebra
+
+ for service in ripd ospfd bgpd $(use ipv6 && echo babeld ripngd ospf6d); do
+ dosym zebra /etc/init.d/${service}
+ done
+
+ use readline && newpamd "${FILESDIR}/quagga.pam" quagga
+
+ insinto /etc/logrotate.d
+ newins redhat/quagga.logrotate quagga
+}