summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-15 21:12:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-15 21:12:32 +0000
commit9b1cb2d2b69f8db38fc83f57e61a4ce9c13d22b9 (patch)
tree2c65355259f8049ea9dc4e1c2e9cf11709685f1b
parentVersion bump, wrt bug #419907 - EAPI 5, add ~amd64-linux keyword. Thanks to F... (diff)
downloadgentoo-2-9b1cb2d2b69f8db38fc83f57e61a4ce9c13d22b9.tar.gz
gentoo-2-9b1cb2d2b69f8db38fc83f57e61a4ce9c13d22b9.tar.bz2
gentoo-2-9b1cb2d2b69f8db38fc83f57e61a4ce9c13d22b9.zip
version bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--media-sound/vmpk/ChangeLog9
-rw-r--r--media-sound/vmpk/vmpk-0.5.1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/media-sound/vmpk/ChangeLog b/media-sound/vmpk/ChangeLog
index 3cbd3bbac176..a0f1b836de76 100644
--- a/media-sound/vmpk/ChangeLog
+++ b/media-sound/vmpk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/vmpk
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/ChangeLog,v 1.15 2012/08/02 12:49:43 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/ChangeLog,v 1.16 2013/02/15 21:12:32 aballier Exp $
+
+*vmpk-0.5.1 (15 Feb 2013)
+
+ 15 Feb 2013; Alexis Ballier <aballier@gentoo.org> +vmpk-0.5.1.ebuild:
+ version bump
02 Aug 2012; Alexis Ballier <aballier@gentoo.org> -vmpk-0.3.1.ebuild,
-vmpk-0.3.2.ebuild, -vmpk-0.3.3.ebuild:
diff --git a/media-sound/vmpk/vmpk-0.5.1.ebuild b/media-sound/vmpk/vmpk-0.5.1.ebuild
new file mode 100644
index 000000000000..fbb4525856da
--- /dev/null
+++ b/media-sound/vmpk/vmpk-0.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/vmpk-0.5.1.ebuild,v 1.1 2013/02/15 21:12:32 aballier Exp $
+
+EAPI=4
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Virtual MIDI Piano Keyboard"
+HOMEPAGE="http://vmpk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vmpk/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus jack"
+
+RDEPEND=">=x11-libs/qt-core-4.8:4
+ >=x11-libs/qt-gui-4.8:4
+ >=x11-libs/qt-svg-4.8:4
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( >=x11-libs/qt-dbus-4.8:4 )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable alsa ALSA)"
+ "$(cmake-utils_use_enable dbus DBUS)"
+ "$(cmake-utils_use_enable jack JACK)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -rf "${D}/usr/share/doc/packages"
+}