summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-10-05 23:21:23 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-10-05 23:21:23 +0000
commit9d0b48cac86da502e6a0422b68798b222c985ea5 (patch)
tree2dde65eee1d06d6182cb457e77b3b91287f08164
parentFix parallel build for bug #194720. (diff)
downloadgentoo-2-9d0b48cac86da502e6a0422b68798b222c985ea5.tar.gz
gentoo-2-9d0b48cac86da502e6a0422b68798b222c985ea5.tar.bz2
gentoo-2-9d0b48cac86da502e6a0422b68798b222c985ea5.zip
Version bump to 0.6.5069
(Portage version: 2.1.3.9)
-rw-r--r--games-action/btanks/ChangeLog8
-rw-r--r--games-action/btanks/btanks-0.6.5069.ebuild57
-rw-r--r--games-action/btanks/files/btanks-0.6.5069-scons-blows.patch35
-rw-r--r--games-action/btanks/files/digest-btanks-0.6.50693
4 files changed, 102 insertions, 1 deletions
diff --git a/games-action/btanks/ChangeLog b/games-action/btanks/ChangeLog
index 3c7ef2e9339d..2254af90960e 100644
--- a/games-action/btanks/ChangeLog
+++ b/games-action/btanks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/btanks
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.3 2007/08/28 20:22:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.4 2007/10/05 23:21:23 tupone Exp $
+
+*btanks-0.6.5069 (05 Oct 2007)
+
+ 05 Oct 2007; Tupone Alfredo <tupone@gentoo.org>
+ +files/btanks-0.6.5069-scons-blows.patch, +btanks-0.6.5069.ebuild:
+ Version bump to 0.6.5069
28 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org>
btanks-0.5.4740-r1.ebuild:
diff --git a/games-action/btanks/btanks-0.6.5069.ebuild b/games-action/btanks/btanks-0.6.5069.ebuild
new file mode 100644
index 000000000000..4a8db3adaa23
--- /dev/null
+++ b/games-action/btanks/btanks-0.6.5069.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.6.5069.ebuild,v 1.1 2007/10/05 23:21:23 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="Fast 2D tank arcade game with multiplayer and split-screen modes"
+HOMEPAGE="http://btanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libsigc++-2.0
+ media-libs/openal
+ media-libs/libsdl
+ media-libs/libvorbis
+ virtual/opengl
+ dev-libs/expat
+ media-libs/sdl-image"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-scons-blows.patch
+}
+
+src_compile() {
+ scons \
+ mode="release" \
+ prefix=/usr \
+ lib_dir="$(games_get_libdir)/${PN}" \
+ resources_dir="${GAMES_DATADIR}/${PN}" \
+ || die "scons"
+}
+
+src_install() {
+ newgamesbin bt btanks || die "newgamesbin"
+
+ insinto "$(games_get_libdir)"/${PN}
+ doins lib{mrt,bt,sdlx}.so || die "doins for lib.so failed"
+
+ exeinto "${GAMES_DATADIR}/${PN}"
+ doexe libbt_objects.so || die "doins for libbt_objects.so failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data || die "doins for data failed"
+ dodoc ChangeLog *.txt
+
+ newicon src/bt.xpm ${PN}.xpm || die "newicon"
+ make_desktop_entry ${PN} "Battle Tanks" ${PN}.xpm
+
+ prepgamesdirs
+}
diff --git a/games-action/btanks/files/btanks-0.6.5069-scons-blows.patch b/games-action/btanks/files/btanks-0.6.5069-scons-blows.patch
new file mode 100644
index 000000000000..f3e9fed3bd76
--- /dev/null
+++ b/games-action/btanks/files/btanks-0.6.5069-scons-blows.patch
@@ -0,0 +1,35 @@
+Respect env build settings, dont force crappy flags, and make sure -rpath is added properly.
+
+--- SConstruct
++++ SConstruct
+@@ -81,16 +81,10 @@
+ if env['gcc_visibility']:
+ env.Append(CCFLAGS=' -fvisibility-inlines-hidden -fvisibility=hidden ');
+ env.Append(CPPFLAGS=' -fvisibility-inlines-hidden -fvisibility=hidden ');
+- if debug:
+- env.Append(CCFLAGS='-ggdb ')
+- env.Append(CPPFLAGS='-ggdb ')
+- else:
+- env.Append(CCFLAGS='-O3 ')
+- env.Append(CPPFLAGS='-O3 ')
+
+ al_lib = 'openal'
+- env.Append(CPPFLAGS=' -Wall -pedantic -Wno-long-long -pipe -pthread ')
+- env.Append(CCFLAGS=' -Wall -pedantic -Wno-long-long -pipe -pthread ')
++ env.Append(CPPFLAGS=' -Wall -pedantic -Wno-long-long -pthread ')
++ env.Append(CCFLAGS=' -Wall -pedantic -Wno-long-long -pthread ')
+
+
+ conf_env = env.Copy()
+--- SConscript
++++ SConscript
+@@ -94,7 +94,7 @@
+
+ Import('lib_dir')
+ if sys.platform != 'win32':
+- bt_env.Append(LINKFLAGS=' -Wl,-rpath '+ lib_dir + ' -Wl,-rpath-link,build/' + env['mode'] + '/mrt')
+- bt_env.Append(LINKFLAGS=' -Wl,-rpath '+ lib_dir + ' -Wl,-rpath-link,build/' + env['mode'] + '/sdlx')
++ bt_env.Append(LINKFLAGS=' -Wl,-rpath,'+ lib_dir + ' -Wl,-rpath-link,build/' + env['mode'] + '/mrt')
++ bt_env.Append(LINKFLAGS=' -Wl,-rpath,'+ lib_dir + ' -Wl,-rpath-link,build/' + env['mode'] + '/sdlx')
+
+ bt_main = bt_env.Program('bt', bt_main_sources, LIBS=bt_main_libs, RPATH=[lib_dir])
diff --git a/games-action/btanks/files/digest-btanks-0.6.5069 b/games-action/btanks/files/digest-btanks-0.6.5069
new file mode 100644
index 000000000000..141eb292433d
--- /dev/null
+++ b/games-action/btanks/files/digest-btanks-0.6.5069
@@ -0,0 +1,3 @@
+MD5 51eaa2897196ca36b7718fec465e115a btanks-0.6.5069.tar.bz2 47758457
+RMD160 011e709d6006b71d9bc429ec559718989a90631d btanks-0.6.5069.tar.bz2 47758457
+SHA256 63f662b61c918b34f950acf86f22101bdbc433e3b2d9e78059394ac01537a334 btanks-0.6.5069.tar.bz2 47758457