summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-22 05:11:00 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-22 05:11:00 +0000
commit9d6208b7be16e733d149050ae5da7106c9167716 (patch)
tree9934ff218bb449a3e2959b4262e04a9812f2cd2b
parentVersion bump. (diff)
downloadgentoo-2-9d6208b7be16e733d149050ae5da7106c9167716.tar.gz
gentoo-2-9d6208b7be16e733d149050ae5da7106c9167716.tar.bz2
gentoo-2-9d6208b7be16e733d149050ae5da7106c9167716.zip
remove multilib cruft
(Portage version: 2.0.51.19)
-rw-r--r--games-emulation/zsnes/zsnes-1.42.ebuild32
1 files changed, 12 insertions, 20 deletions
diff --git a/games-emulation/zsnes/zsnes-1.42.ebuild b/games-emulation/zsnes/zsnes-1.42.ebuild
index a2ba65030074..4a175d21a34c 100644
--- a/games-emulation/zsnes/zsnes-1.42.ebuild
+++ b/games-emulation/zsnes/zsnes-1.42.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.4 2005/03/21 07:59:59 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.5 2005/03/22 05:11:00 vapier Exp $
inherit eutils flag-o-matic games
@@ -13,10 +13,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 x86"
IUSE="opengl png"
-# we need libsdl for headers on amd64, even though we'll technically be using
-# the 32bit sdl from emul-linux-x86-sdl.
-RDEPEND="virtual/libc
- >=media-libs/libsdl-1.2.0
+RDEPEND=">=media-libs/libsdl-1.2.0
>=sys-libs/zlib-1.1
amd64? ( app-emulation/emul-linux-x86-sdl )
opengl? ( virtual/opengl )
@@ -28,20 +25,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}_${PV//./_}"
-multilib_check() {
- if use amd64; then
- if has_multilib_profile; then
- ABI_ALLOW="x86"
-
- # And until we get a real multilib portage...
- append-ldflags "-L/emul/linux/x86/usr/lib -L/emul/linux/x86/lib -L/usr/lib32 -L/lib32"
- ABI="x86"
- elif has_m32 ; then
- einfo "multilib detected, adding -m32 to CFLAGS."
- append-flags -m32
- else
- die "zsnes requires multilib support in gcc. please re-emerge gcc with multilib in USE and try again"
- fi
+pkg_setup() {
+ use amd64 || return 0
+ if has_m32 ; then
+ append-flags -m32
+ else
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
fi
}
@@ -54,7 +47,6 @@ src_unpack() {
}
src_compile() {
- use amd64 && multilib_check
cd src
egamesconf \
$(use_enable png libpng) \