summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-05-21 18:31:01 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-05-21 18:31:01 +0000
commit9dad23e9b8f0fd36f8c56a154306deb816de3b08 (patch)
tree933fc084a73099d9b832f7aff815debbc246d564
parentStable on ppc; bug #215006 (diff)
downloadgentoo-2-9dad23e9b8f0fd36f8c56a154306deb816de3b08.tar.gz
gentoo-2-9dad23e9b8f0fd36f8c56a154306deb816de3b08.tar.bz2
gentoo-2-9dad23e9b8f0fd36f8c56a154306deb816de3b08.zip
patch rev bump, remove older version of 4.6
(Portage version: 2.1.5_rc10)
-rw-r--r--sys-libs/db/ChangeLog8
-rw-r--r--sys-libs/db/db-4.6.21.ebuild145
-rw-r--r--sys-libs/db/db-4.6.21_p1.ebuild (renamed from sys-libs/db/db-4.6.19.ebuild)4
3 files changed, 9 insertions, 148 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index f969cced44a9..2ddf7d96187a 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.242 2008/03/20 00:34:02 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.243 2008/05/21 18:31:01 caleb Exp $
+
+*db-4.6.21_p1 (21 May 2008)
+
+ 21 May 2008; Caleb Tennis <caleb@gentoo.org> -db-4.6.19.ebuild,
+ -db-4.6.21.ebuild, +db-4.6.21_p1.ebuild:
+ patch rev bump, remove older versions of 4.6
20 Mar 2008; Ryan Hill <dirtyepic@gentoo.org> db-4.5.20_p2.ebuild:
Keyword ~mips for bug #178750.
diff --git a/sys-libs/db/db-4.6.21.ebuild b/sys-libs/db/db-4.6.21.ebuild
deleted file mode 100644
index 1e22b7f64834..000000000000
--- a/sys-libs/db/db-4.6.21.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21.ebuild,v 1.1 2007/11/04 18:58:11 caleb Exp $
-
-inherit eutils db flag-o-matic java-pkg-opt-2
-
-#Number of official patches
-#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
-PATCHNO=${PV/*.*.*_p}
-if [[ ${PATCHNO} == "${PV}" ]] ; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
-else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
-fi
-
-S="${WORKDIR}/${MY_P}/build_unix"
-DESCRIPTION="Oracle Berkeley DB"
-HOMEPAGE="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
-SRC_URI="http://download-west.oracle.com/berkeley-db/${MY_P}.tar.gz"
-for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
-done
-
-LICENSE="OracleDB"
-SLOT="4.6"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="tcl java doc nocxx bootstrap"
-
-DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
- java? ( >=virtual/jdk-1.4 )
- >=sys-devel/binutils-2.16.1"
-RDEPEND="tcl? ( dev-lang/tcl )
- java? ( >=virtual/jre-1.4 )"
-
-src_unpack() {
- unpack "${MY_P}".tar.gz
- cd "${WORKDIR}"/"${MY_P}"
- for (( i=1 ; i<=${PATCHNO} ; i++ ))
- do
- epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
- done
- epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-libtool.patch
-
- # use the includes from the prefix
- epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-jni-check-prefix-first.patch
- epatch "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
-
- sed -i \
- -e "s,\(ac_compiler\|\${MAKEFILE_CC}\|\${MAKEFILE_CXX}\|\$CC\)\( *--version\),\1 -dumpversion,g" \
- "${S}"/../dist/configure
-}
-
-src_compile() {
- # compilation with -O0 fails on amd64, see bug #171231
- if use amd64; then
- replace-flags -O0 -O2
- is-flag -O[s123] || append-flags -O2
- fi
-
- local myconf=""
-
- use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
-
- use bootstrap \
- && myconf="${myconf} --disable-cxx" \
- || myconf="${myconf} $(use_enable !nocxx cxx)"
-
- use tcl \
- && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
- || myconf="${myconf} --disable-tcl"
-
- myconf="${myconf} $(use_enable java)"
- if use java; then
- myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
- # Can't get this working any other way, since it returns spaces, and
- # bash doesn't seem to want to pass correctly in any way i try
- local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
- fi
-
- [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
-
- # the entire testsuite needs the TCL functionality
- if use tcl && has test $FEATURES ; then
- myconf="${myconf} --enable-test"
- else
- myconf="${myconf} --disable-test"
- fi
-
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU; then
- append-ldflags -Wl,--default-symver
- fi
-
- cd "${S}" && ECONF_SOURCE="${S}"/../dist econf \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --libdir=/usr/"$(get_libdir)" \
- --enable-compat185 \
- --without-uniquename \
- --enable-rpc \
- --host="${CHOST}" \
- ${myconf} "${javaconf}" || die "configure failed"
-
- sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
- && mv Makefile.cpy Makefile
-
- emake -j1 || die "make failed"
-}
-
-src_install() {
- einstall libdir="${D}/usr/$(get_libdir)" STRIP="none" || die
-
- db_src_install_usrbinslot
-
- db_src_install_headerslot
-
- db_src_install_doc
-
- db_src_install_usrlibcleanup
-
- dodir /usr/sbin
- mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db46_svc
-
- if use java; then
- java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
- rm -f "${D}"/usr/"$(get_libdir)"/*.jar
- fi
-}
-
-pkg_postinst() {
- db_fix_so
-}
-
-pkg_postrm() {
- db_fix_so
-}
diff --git a/sys-libs/db/db-4.6.19.ebuild b/sys-libs/db/db-4.6.21_p1.ebuild
index 0a425668522f..da2e8e915ee6 100644
--- a/sys-libs/db/db-4.6.19.ebuild
+++ b/sys-libs/db/db-4.6.21_p1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.19.ebuild,v 1.2 2007/10/24 07:07:55 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p1.ebuild,v 1.1 2008/05/21 18:31:01 caleb Exp $
inherit eutils db flag-o-matic java-pkg-opt-2