summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 02:32:26 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 02:32:26 +0000
commit9db4a4eaf77dff59d8175e7c9e16fb6ccb260e77 (patch)
tree81238fa5a0387a31287aff8608634f53e2b061d8
parentadd inherit eutils (diff)
downloadgentoo-2-9db4a4eaf77dff59d8175e7c9e16fb6ccb260e77.tar.gz
gentoo-2-9db4a4eaf77dff59d8175e7c9e16fb6ccb260e77.tar.bz2
gentoo-2-9db4a4eaf77dff59d8175e7c9e16fb6ccb260e77.zip
add inherit eutils
-rw-r--r--dev-java/kaffe/kaffe-1.1.3.ebuild20
-rw-r--r--dev-lang/gforth/gforth-0.6.2.ebuild14
-rw-r--r--dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild12
-rw-r--r--dev-lang/lua/lua-5.0.2.ebuild14
-rw-r--r--dev-lang/nasm/nasm-0.98.36.ebuild20
-rw-r--r--dev-lang/ocaml/ocaml-3.06.ebuild11
-rw-r--r--dev-lang/prc-tools/prc-tools-2.3.ebuild4
-rw-r--r--dev-lang/python/python-2.3.3.ebuild29
-rw-r--r--dev-lang/smlnj/smlnj-110.43.ebuild16
9 files changed, 70 insertions, 70 deletions
diff --git a/dev-java/kaffe/kaffe-1.1.3.ebuild b/dev-java/kaffe/kaffe-1.1.3.ebuild
index c2b979d64e9e..31eb2738cccb 100644
--- a/dev-java/kaffe/kaffe-1.1.3.ebuild
+++ b/dev-java/kaffe/kaffe-1.1.3.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/kaffe/kaffe-1.1.3.ebuild,v 1.3 2004/03/11 01:46:26 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/kaffe/kaffe-1.1.3.ebuild,v 1.4 2004/04/16 02:27:41 vapier Exp $
-inherit java
+inherit java eutils
-S=${WORKDIR}/${P/_/-}
DESCRIPTION="A cleanroom, open source Java VM and class libraries"
-SRC_URI="http://www.kaffe.org/ftp/pub/kaffe/v1.1.x-development/${P/_/-}.tar.gz"
HOMEPAGE="http://www.kaffe.org/"
+SRC_URI="http://www.kaffe.org/ftp/pub/kaffe/v1.1.x-development/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
DEPEND=">=dev-libs/gmp-3.1
>=media-libs/jpeg-6b
>=media-libs/libpng-1.2.1
virtual/glibc
virtual/x11
>=dev-java/java-config-0.2.4"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~sparc"
src_unpack() {
unpack ${A}
@@ -28,13 +29,14 @@ src_compile() {
--prefix=/opt/${P} \
--host=${CHOST} \
`use_enable alsa`\
- `use_enable esd`
+ `use_enable esd` \
+ || die
# --with-bcel
# --with-profiling
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
set_java_env ${FILESDIR}/${VMHANDLE} || die
diff --git a/dev-lang/gforth/gforth-0.6.2.ebuild b/dev-lang/gforth/gforth-0.6.2.ebuild
index 8898750f14de..aa1df238113a 100644
--- a/dev-lang/gforth/gforth-0.6.2.ebuild
+++ b/dev-lang/gforth/gforth-0.6.2.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2.ebuild,v 1.2 2004/03/14 02:29:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2.ebuild,v 1.3 2004/04/16 02:28:06 vapier Exp $
-IUSE="emacs"
-
-inherit elisp-common
+inherit elisp-common eutils
DESCRIPTION="GNU Forth is a fast and portable implementation of the ANSI Forth language"
HOMEPAGE="http://www.gnu.org/software/gforth"
@@ -13,6 +11,7 @@ SRC_URI="http://www.complang.tuwien.ac.at/forth/gforth//${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE="emacs"
DEPEND="virtual/glibc
emacs? ( virtual/emacs )"
@@ -30,15 +29,16 @@ src_compile() {
use emacs && emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
}
-src_install () {
- make install libdir=${D}/usr/lib \
+src_install() {
+ make \
+ libdir=${D}/usr/lib \
infodir=${D}/usr/share/info \
mandir=${D}/usr/share/man \
datadir=${D}/usr/share \
bindir=${D}/usr/bin \
install || die
- dodoc AUTHORS BUGS COPYING* ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
+ dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
if use emacs; then
elisp-install ${PN} *.el *.elc
diff --git a/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild b/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild
index 9dc8f5af0b15..176a77607105 100644
--- a/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild
+++ b/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild
@@ -1,16 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild,v 1.3 2004/02/22 19:55:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.1_beta20031003-r2.ebuild,v 1.4 2004/04/16 02:28:34 vapier Exp $
+
+inherit eutils
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="http://www.lua.org/"
SRC_URI="http://www.lua.org/ftp/lua-5.0.1.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha -hppa ~mips ~ppc ~sparc ~x86 ~amd64"
IUSE="readline"
+
DEPEND=">=sys-apps/sed-4
sys-apps/findutils"
+
S=${WORKDIR}/lua-5.0.1
src_unpack() {
@@ -34,7 +39,7 @@ src_unpack() {
sed -i doc/readme.html \
-e 's:\(/README\)\("\):\1.gz\2:g'
- if [ `use readline` ]; then
+ if use readline ; then
sed -i config \
-e "s:^#\(USERCONF=-DLUA_USERCONFIG='\"\$(LUA)/etc/saconfig.c\"' -DUSE_READLINE\):\1:" \
-e 's:^#\(EXTRA_LIBS= -lm -ldl -lreadline\) # \(-lhistory -lcurses -lncurses\):\1 \2:'
@@ -54,7 +59,6 @@ Version: ${PV/_*/}
Cflags: -I\${includedir}
Libs: -L\${libdir} -llua -llualib -ldl -lm
EOF
-
}
src_compile() {
@@ -64,7 +68,6 @@ src_compile() {
}
src_install() {
-
make DESTDIR=${D} install soinstall || die "make install soinstall failed"
dodoc COPYRIGHT HISTORY UPDATE
@@ -82,5 +85,4 @@ src_install() {
doins etc/lua.xpm
insinto /usr/lib/pkgconfig
doins etc/lua.pc
-
}
diff --git a/dev-lang/lua/lua-5.0.2.ebuild b/dev-lang/lua/lua-5.0.2.ebuild
index 01381faf2b7f..c9d328125df4 100644
--- a/dev-lang/lua/lua-5.0.2.ebuild
+++ b/dev-lang/lua/lua-5.0.2.ebuild
@@ -1,19 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.2.ebuild,v 1.3 2004/03/29 19:04:12 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.2.ebuild,v 1.4 2004/04/16 02:29:02 vapier Exp $
+
+inherit eutils
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="http://www.lua.org/"
SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha -hppa ~mips ~ppc sparc x86 ~amd64"
IUSE="readline"
+
DEPEND=">=sys-apps/sed-4
sys-apps/findutils"
src_unpack() {
-
unpack ${A}
epatch ${FILESDIR}/lua-${PV}-pic.patch
@@ -32,7 +35,7 @@ src_unpack() {
sed -i doc/readme.html \
-e 's:\(/README\)\("\):\1.gz\2:g'
- if [ `use readline` ]; then
+ if use readline ; then
sed -i config \
-e "s:^#\(USERCONF=-DLUA_USERCONFIG='\"\$(LUA)/etc/saconfig.c\"' -DUSE_READLINE\):\1:" \
-e 's:^#\(EXTRA_LIBS= -lm -ldl -lreadline\) # \(-lhistory -lcurses -lncurses\):\1 \2:'
@@ -52,7 +55,6 @@ Version: ${PV}
Cflags: -I\${includedir}
Libs: -L\${libdir} -llua -llualib -ldl -lm
EOF
-
}
src_compile() {
@@ -62,10 +64,9 @@ src_compile() {
}
src_install() {
-
make DESTDIR=${D} install soinstall || die "make install soinstall failed"
- dodoc COPYRIGHT HISTORY UPDATE
+ dodoc HISTORY UPDATE
dohtml doc/*.html doc/*.gif
for i in `find . -name README -printf "%h\n"`; do
docinto ${i#.}
@@ -80,5 +81,4 @@ src_install() {
doins etc/lua.xpm
insinto /usr/lib/pkgconfig
doins etc/lua.pc
-
}
diff --git a/dev-lang/nasm/nasm-0.98.36.ebuild b/dev-lang/nasm/nasm-0.98.36.ebuild
index f2510f46454d..387bcbd8ecb1 100644
--- a/dev-lang/nasm/nasm-0.98.36.ebuild
+++ b/dev-lang/nasm/nasm-0.98.36.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.36.ebuild,v 1.6 2003/12/09 18:05:14 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98.36.ebuild,v 1.7 2004/04/16 02:29:47 vapier Exp $
+
+inherit etuils
DESCRIPTION="groovy little assembler"
HOMEPAGE="http://nasm.sourceforge.net/"
@@ -17,15 +19,15 @@ DEPEND="!build? ( dev-lang/perl )
src_unpack() {
unpack ${A}
-
- [ -z "`use doc`" ] && cd ${S} && epatch ${FILESDIR}/${P}-remove-doc-target.diff
+ cd ${S}
+ use doc || epatch ${FILESDIR}/${P}-remove-doc-target.diff
}
src_compile() {
./configure --prefix=/usr || die
- if [ `use build` ] ; then
- make nasm
+ if use build ; then
+ make nasm || die
else
make everything || die
fi
@@ -33,14 +35,14 @@ src_compile() {
}
src_install() {
- if [ `use build` ] ; then
+ if use build ; then
dobin nasm
else
dobin nasm ndisasm rdoff/{ldrdf,rdf2bin,rdf2ihx,rdfdump,rdflib,rdx}
dosym /usr/bin/rdf2bin /usr/bin/rdf2com
doman nasm.1 ndisasm.1
- dodoc AUTHORS CHANGES COPYING ChangeLog INSTALL README TODO
- if [ `use doc` ] ; then
+ dodoc AUTHORS CHANGES ChangeLog INSTALL README TODO
+ if use doc ; then
doinfo doc/info/*
dohtml doc/html/*
dodoc doc/nasmdoc.*
diff --git a/dev-lang/ocaml/ocaml-3.06.ebuild b/dev-lang/ocaml/ocaml-3.06.ebuild
index a67cf644f78e..1171684c11c2 100644
--- a/dev-lang/ocaml/ocaml-3.06.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.11 2004/02/27 19:38:42 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.12 2004/04/16 02:30:10 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -17,7 +17,7 @@ DEPEND="virtual/glibc
tcltk? ( >=dev-lang/tk-3.3.3 )"
src_compile() {
-filter-flags "-fstack-protector"
+ filter-flags "-fstack-protector"
local myconf
use tcltk || myconf="-no-tk"
@@ -31,7 +31,6 @@ filter-flags "-fstack-protector"
myconf="${myconfg} -host sparc-unknown-linux-gnu"
fi
-
./configure -prefix /usr \
-bindir /usr/bin \
-libdir /usr/lib/ocaml \
@@ -53,5 +52,5 @@ src_install() {
dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
# documentation
- dodoc Changes INSTALL LICENSE README Upgrading
+ dodoc Changes INSTALL README Upgrading
}
diff --git a/dev-lang/prc-tools/prc-tools-2.3.ebuild b/dev-lang/prc-tools/prc-tools-2.3.ebuild
index 9a0950d0f6a8..8c78425b0924 100644
--- a/dev-lang/prc-tools/prc-tools-2.3.ebuild
+++ b/dev-lang/prc-tools/prc-tools-2.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/prc-tools/prc-tools-2.3.ebuild,v 1.5 2004/04/06 03:01:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/prc-tools/prc-tools-2.3.ebuild,v 1.6 2004/04/16 02:30:27 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
BIN_V="binutils-2.14"
GDB_V="gdb-5.3"
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index 28e3d1e32ccf..222f59d7984e 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.22 2004/03/10 15:42:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.23 2004/04/16 02:31:53 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
# in dev-lang/python. It _WILL_ stop people installing from
# Gentoo 1.4 images.
-inherit flag-o-matic python
+inherit flag-o-matic python eutils
MY_PV=${PV/_rc/c}
PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
@@ -22,22 +22,21 @@ HOMEPAGE="http://www.python.org"
IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X"
LICENSE="PSF-2.2"
SLOT="2.3"
-
KEYWORDS="x86 ppc sparc hppa amd64 s390 alpha ia64"
-# "~alpha ~mips ~arm"
DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
- !build? ( X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
- ncurses? ( >=sys-libs/ncurses-5.2 readline? ( >=sys-libs/readline-4.1 ) )
- berkdb? ( >=sys-libs/db-3.1 )
- gdbm? ( sys-libs/gdbm )
- ssl? ( dev-libs/openssl )
- doc? ( =dev-python/python-docs-${PV}* )
- dev-libs/expat
+ !build? (
+ X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
+ ncurses? ( >=sys-libs/ncurses-5.2 readline? ( >=sys-libs/readline-4.1 ) )
+ berkdb? ( >=sys-libs/db-3.1 )
+ gdbm? ( sys-libs/gdbm )
+ ssl? ( dev-libs/openssl )
+ doc? ( =dev-python/python-docs-${PV}* )
+ dev-libs/expat
)"
-
-RDEPEND="${DEPEND} dev-python/python-fchksum"
+RDEPEND="${DEPEND}
+ dev-python/python-fchksum"
# The dev-python/python-fchksum RDEPEND is needed to that this python provides
# the functionality expected from previous pythons.
@@ -59,7 +58,7 @@ src_unpack() {
src_configure() {
# disable extraneous modules with extra dependencies
- if [ -n "`use build`" ]; then
+ if use build ; then
export PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter"
export PYTHON_DISABLE_SSL=1
else
@@ -69,7 +68,7 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} dbm bsddb"
use readline \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} readline"
- [ -z "use X" -o -z "use tcltk" ] \
+ [ -z "`use X`" -o -z "`use tcltk`" ] \
&& PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _tkinter"
use ncurses \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
diff --git a/dev-lang/smlnj/smlnj-110.43.ebuild b/dev-lang/smlnj/smlnj-110.43.ebuild
index fc5948d07abf..e2338f322f42 100644
--- a/dev-lang/smlnj/smlnj-110.43.ebuild
+++ b/dev-lang/smlnj/smlnj-110.43.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/smlnj/smlnj-110.43.ebuild,v 1.2 2003/10/03 05:24:38 kumba Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smlnj/smlnj-110.43.ebuild,v 1.3 2004/04/16 02:32:26 vapier Exp $
DESCRIPTION="Standard ML of New Jersey compiler and libraries"
+HOMEPAGE="http://cm.bell-labs.com/cm/cs/what/smlnj/"
SRC_URI="ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/config.tgz
ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/runtime.tgz
ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/boot.x86-unix.tgz
@@ -15,12 +14,11 @@ SRC_URI="ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/config.tgz
ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/cml.tgz
ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/eXene.tgz"
-HOMEPAGE="http://cm.bell-labs.com/cm/cs/what/smlnj/"
-
LICENSE="BSD"
+SLOT="0"
KEYWORDS="-* ~x86"
+IUSE=""
-SLOT="0"
DEPEND="virtual/glibc"
SMLNJ_DEST="/usr/share/smlnj"
@@ -65,8 +63,7 @@ src_compile() {
./config/install.sh || die
}
-src_install () {
-
+src_install() {
dodir ${SMLNJ_DEST}
cp -r ${WORKDIR}/{bin,lib} ${D}${SMLNJ_DEST} || die
@@ -82,5 +79,4 @@ src_install () {
dosym ${SMLNJ_DEST}/bin/ml-makedepend /usr/bin
dosym ${SMLNJ_DEST}/bin/ml-yacc /usr/bin
dosym ${SMLNJ_DEST}/bin/sml /usr/bin
-
}