summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-08-17 22:46:37 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-08-17 22:46:37 +0000
commit9f52cc25d3c5ab24e18e95eb21da8ef9488ac23b (patch)
treebe7860d830704a06f46ae973edad7f5b6c647119
parentremove sysroot since it doesnt work yet (diff)
downloadgentoo-2-9f52cc25d3c5ab24e18e95eb21da8ef9488ac23b.tar.gz
gentoo-2-9f52cc25d3c5ab24e18e95eb21da8ef9488ac23b.tar.bz2
gentoo-2-9f52cc25d3c5ab24e18e95eb21da8ef9488ac23b.zip
Stable on sh.
(Portage version: 2.0.51.22-r2)
-rw-r--r--dev-db/postgresql/ChangeLog6
-rw-r--r--dev-db/postgresql/files/postgresql-8.0.3-sh.patch34
-rw-r--r--dev-db/postgresql/postgresql-8.0.3.ebuild5
-rw-r--r--dev-libs/libxslt/ChangeLog5
-rw-r--r--dev-libs/libxslt/libxslt-1.1.14-r2.ebuild4
5 files changed, 48 insertions, 6 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 76445d0f25ae..892561af513c 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.234 2005/08/03 21:17:22 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.235 2005/08/17 22:46:37 matsuu Exp $
+
+ 17 Aug 2005; MATSUU Takuto <matsuu@gentoo.org>
+ +files/postgresql-8.0.3-sh.patch, postgresql-8.0.3.ebuild:
+ Stable on sh.
03 Aug 2005; Bryan Østergaard <kloeri@gentoo.org>
postgresql-8.0.3.ebuild:
diff --git a/dev-db/postgresql/files/postgresql-8.0.3-sh.patch b/dev-db/postgresql/files/postgresql-8.0.3-sh.patch
new file mode 100644
index 000000000000..fc59d52af0e8
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.0.3-sh.patch
@@ -0,0 +1,34 @@
+--- src/include/storage/s_lock.h~ 2005-01-01 07:03:42.000000000 +0900
++++ src/include/storage/s_lock.h 2005-08-17 23:09:19.000000000 +0900
+@@ -239,6 +239,31 @@
+ #endif /* __s390__ || __s390x__ */
+
+
++#if defined(__sh__)
++#define HAS_TEST_AND_SET
++
++typedef unsigned char slock_t;
++
++#define TAS(lock) tas(lock)
++
++static __inline__ int
++tas(volatile slock_t *lock)
++{
++ register int _res = 1;
++
++ __asm__ __volatile__(
++ "tas.b @%1\n\t"
++ "movt %0\n\t"
++ "xor #1,%0"
++: "=z"(_res)
++: "r"(lock)
++: "t","memory");
++ return _res;
++}
++
++#endif /* __sh__ */
++
++
+ #if defined(__sparc__)
+ #define HAS_TEST_AND_SET
+
diff --git a/dev-db/postgresql/postgresql-8.0.3.ebuild b/dev-db/postgresql/postgresql-8.0.3.ebuild
index 6fd564fbd0e0..0ba0ee5d6d7d 100644
--- a/dev-db/postgresql/postgresql-8.0.3.ebuild
+++ b/dev-db/postgresql/postgresql-8.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.3.ebuild,v 1.11 2005/08/07 09:14:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.3.ebuild,v 1.12 2005/08/17 22:46:37 matsuu Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -16,7 +16,7 @@ SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${MY_PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
IUSE="ssl nls python tcltk perl libg++ pam readline xml2 zlib doc selinux kerberos pg-intdatetime pg-hier"
S=${WORKDIR}/${MY_P}
@@ -67,6 +67,7 @@ src_unpack() {
cd ${S}
use pg-hier && epatch ${WORKDIR}/${P_HIERPG}.diff
epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${P}-sh.patch
}
src_compile() {
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index 3dc9ceb83e59..ef9068252c62 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libxslt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.116 2005/08/08 14:38:10 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.117 2005/08/17 22:42:10 matsuu Exp $
+
+ 17 Aug 2005; MATSUU Takuto <matsuu@gentoo.org> libxslt-1.1.14-r2.ebuild:
+ Stable on sh.
08 Aug 2005; Markus Rothe <corsair@gentoo.org> libxslt-1.1.14-r2.ebuild:
Stable on ppc64
diff --git a/dev-libs/libxslt/libxslt-1.1.14-r2.ebuild b/dev-libs/libxslt/libxslt-1.1.14-r2.ebuild
index d2058312ca90..56270168fac2 100644
--- a/dev-libs/libxslt/libxslt-1.1.14-r2.ebuild
+++ b/dev-libs/libxslt/libxslt-1.1.14-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.14-r2.ebuild,v 1.6 2005/08/14 03:59:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.14-r2.ebuild,v 1.7 2005/08/17 22:42:10 matsuu Exp $
inherit libtool gnome.org eutils python
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.xmlsoft.org/"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="alpha ~amd64 arm hppa ~ia64 ~mips ~ppc ppc64 s390 sparc x86"
+KEYWORDS="alpha ~amd64 arm hppa ~ia64 ~mips ~ppc ppc64 s390 sh sparc x86"
IUSE="crypt debug python static"
DEPEND=">=dev-libs/libxml2-2.6.17