summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 08:24:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 08:24:24 +0000
commita1322487570c90a5c707f9ae7d50bc2baaa2b38a (patch)
treee49a1ac339e370f6ff3afd3cf02c02f053eb43e2
parentdont access $CC (diff)
downloadgentoo-2-a1322487570c90a5c707f9ae7d50bc2baaa2b38a.tar.gz
gentoo-2-a1322487570c90a5c707f9ae7d50bc2baaa2b38a.tar.bz2
gentoo-2-a1322487570c90a5c707f9ae7d50bc2baaa2b38a.zip
dont access $CC
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.1.51-r1.ebuild6
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.1.53.ebuild6
-rw-r--r--app-sci/primegen/primegen-0.97.ebuild15
-rw-r--r--app-sci/rasmol/rasmol-2.7.1.1.ebuild4
-rw-r--r--app-sci/rasmol/rasmol-2.7.2.1.1.ebuild8
5 files changed, 20 insertions, 19 deletions
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.1.51-r1.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.1.51-r1.ebuild
index 7a0f27c524e0..6c909229eea9 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.1.51-r1.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.1.51-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.51-r1.ebuild,v 1.1 2004/04/25 11:41:11 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.51-r1.ebuild,v 1.2 2004/04/27 08:20:39 vapier Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -346,8 +346,8 @@ src_compile() {
if [ -z "$(grep 'CCCOMP' ${S}/${LinuxEnvSet})" ]
then
# Set CCCOMP and CXXCOMP. This is still needed for STLport
- export CCCOMP=${CC}
- export CXXCOMP=${CXX}
+ export CCCOMP="$(gcc-getCC)"
+ export CXXCOMP="$(gcc-getCXX)"
fi
einfo "Bootstrapping OpenOffice.org..."
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.1.53.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.1.53.ebuild
index fc6494efeac6..ddaf5f2a4185 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.1.53.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.1.53.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.53.ebuild,v 1.2 2004/04/20 16:18:35 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.53.ebuild,v 1.3 2004/04/27 08:20:39 vapier Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -341,8 +341,8 @@ src_compile() {
if [ -z "$(grep 'CCCOMP' ${S}/${LinuxEnvSet})" ]
then
# Set CCCOMP and CXXCOMP. This is still needed for STLport
- export CCCOMP=${CC}
- export CXXCOMP=${CXX}
+ export CCCOMP="$(gcc-getCC)"
+ export CXXCOMP="$(gcc-getCXX)"
fi
einfo "Bootstrapping OpenOffice.org..."
diff --git a/app-sci/primegen/primegen-0.97.ebuild b/app-sci/primegen/primegen-0.97.ebuild
index 390df1a91cc9..f258a9dd3179 100644
--- a/app-sci/primegen/primegen-0.97.ebuild
+++ b/app-sci/primegen/primegen-0.97.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/primegen/primegen-0.97.ebuild,v 1.3 2003/04/06 07:42:01 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/primegen/primegen-0.97.ebuild,v 1.4 2004/04/27 08:22:03 vapier Exp $
-IUSE=""
+inherit gcc
DESCRIPTION="A small, fast library to generate primes in order"
HOMEPAGE="http://cr.yp.to/primegen.html"
@@ -11,21 +11,22 @@ SRC_URI="http://cr.yp.to/primegen/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
DEPEND="virtual/glibc"
src_compile() {
- echo ${CC} ${CFLAGS} > conf-cc
+ echo $(gcc-getCC) ${CFLAGS} > conf-cc
echo /usr > conf-home
- echo ${CC} ${CFLAGS} > conf-ld
+ echo $(gcc-getCC) ${CFLAGS} > conf-ld
emake || die
}
src_install() {
- dobin primegaps primes primespeed
+ dobin primegaps primes primespeed || die "dobin failed"
doman primegaps.1 primes.1 primespeed.1
doman error.3 error_str.3 primegen.3
- dolib.a primegen.a
+ dolib.a primegen.a || die "dolib.a failed"
insinto /usr/include
doins primegen.h uint32.h uint64.h
dodoc BLURB CHANGES README
diff --git a/app-sci/rasmol/rasmol-2.7.1.1.ebuild b/app-sci/rasmol/rasmol-2.7.1.1.ebuild
index 260cb64d0b93..a8aff7d2ae81 100644
--- a/app-sci/rasmol/rasmol-2.7.1.1.ebuild
+++ b/app-sci/rasmol/rasmol-2.7.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.1.1.ebuild,v 1.4 2004/04/27 08:23:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.1.1.ebuild,v 1.5 2004/04/27 08:24:24 vapier Exp $
inherit gcc
@@ -32,7 +32,7 @@ src_unpack() {
src_compile() {
cd src
xmkmf || die "xmkmf failed"
- make DEPTHDEF=-DEIGHTBIT CC=${CC} \
+ make DEPTHDEF=-DEIGHTBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "8-bit make failed"
mv rasmol rasmol.8
diff --git a/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild b/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
index 67f89a4dc2ad..310f24b51a0e 100644
--- a/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
+++ b/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild,v 1.3 2004/04/27 08:23:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild,v 1.4 2004/04/27 08:24:24 vapier Exp $
inherit gcc
@@ -31,17 +31,17 @@ src_unpack() {
src_compile() {
cd src
xmkmf || die "xmkmf failed"
- make DEPTHDEF=-DEIGHTBIT CC=${CC} \
+ make DEPTHDEF=-DEIGHTBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "8-bit make failed"
mv rasmol rasmol.8
make clean
- make DEPTHDEF=-DSIXTEENBIT CC=${CC} \
+ make DEPTHDEF=-DSIXTEENBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "16-bit make failed"
mv rasmol rasmol.16
make clean
- make DEPTHDEF=-DTHIRTYTWOBIT CC=${CC} \
+ make DEPTHDEF=-DTHIRTYTWOBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "32-bit make failed"
mv rasmol rasmol.32