summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-03-15 12:31:17 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-03-15 12:31:17 +0000
commita5aff8d81770794db3dd59c896ed138c29bff2a8 (patch)
tree9b1ebea43e65434e516dbe87d9cc90ab7f27903d
parentVersion bump. (diff)
downloadgentoo-2-a5aff8d81770794db3dd59c896ed138c29bff2a8.tar.gz
gentoo-2-a5aff8d81770794db3dd59c896ed138c29bff2a8.tar.bz2
gentoo-2-a5aff8d81770794db3dd59c896ed138c29bff2a8.zip
Bumped amarok-utils to the 2.3.0 release.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--media-sound/amarok-utils/ChangeLog8
-rw-r--r--media-sound/amarok-utils/amarok-utils-2.3.0.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/media-sound/amarok-utils/ChangeLog b/media-sound/amarok-utils/ChangeLog
index 6611fade4681..f17e7b66d096 100644
--- a/media-sound/amarok-utils/ChangeLog
+++ b/media-sound/amarok-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.19 2010/02/25 11:02:11 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.20 2010/03/15 12:31:17 jmbsvicetto Exp $
+
+*amarok-utils-2.3.0 (15 Mar 2010)
+
+ 15 Mar 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-utils-2.3.0.ebuild:
+ Bumped amarok-utils to the 2.3.0 release.
25 Feb 2010; Christian Faulhammer <fauli@gentoo.org>
amarok-utils-2.2.2-r1.ebuild:
diff --git a/media-sound/amarok-utils/amarok-utils-2.3.0.ebuild b/media-sound/amarok-utils/amarok-utils-2.3.0.ebuild
new file mode 100644
index 000000000000..0ff2997b0a90
--- /dev/null
+++ b/media-sound/amarok-utils/amarok-utils-2.3.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/amarok-utils-2.3.0.ebuild,v 1.1 2010/03/15 12:31:17 jmbsvicetto Exp $
+
+EAPI="2"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git"
+ EGIT_PROJECT="amarok"
+ EGIT_REPO_URI="git://gitorious.org/amarok/amarok.git"
+fi
+
+inherit base cmake-utils ${GIT_ECLASS}
+
+MY_PN="amarok"
+
+DESCRIPTION="Various utility programs for Amarok."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_PN}-${PV}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+"
+RDEPEND="${DEPEND}
+ !<media-sound/amarok-2.1.80:2
+ !<media-sound/amarok-2.1.80:${SLOT}
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS="TODO README ChangeLog AUTHORS"
+
+src_prepare() {
+ # Disable po processing
+ sed -e "s:include(MacroOptionalAddSubdirectory)::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ sed -e "s:macro_optional_add_subdirectory( po )::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+
+ base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_PLAYER=OFF
+ -DWITH_UTILITIES=ON
+ )
+
+ cmake-utils_src_configure
+}