summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-01-19 15:38:55 +0000
committerBrian Evans <grknight@gentoo.org>2015-01-19 15:38:55 +0000
commita745e3dc3e5d54a3fc093345b26b0598a650ec8f (patch)
treec452f86ea7f3fa0698c75673387630ccc569fea8
parentRemove dev-php/suhosin from package.mask (diff)
downloadgentoo-2-a745e3dc3e5d54a3fc093345b26b0598a650ec8f.tar.gz
gentoo-2-a745e3dc3e5d54a3fc093345b26b0598a650ec8f.tar.bz2
gentoo-2-a745e3dc3e5d54a3fc093345b26b0598a650ec8f.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key D1F781EFF9F4A3B6)
-rw-r--r--dev-php/suhosin/ChangeLog10
-rw-r--r--dev-php/suhosin/files/suhosin-0.9.37.1-libcrypt.patch12
-rw-r--r--dev-php/suhosin/suhosin-0.9.37.1.ebuild57
3 files changed, 77 insertions, 2 deletions
diff --git a/dev-php/suhosin/ChangeLog b/dev-php/suhosin/ChangeLog
index 5a948cee3ee0..99794de7440f 100644
--- a/dev-php/suhosin/ChangeLog
+++ b/dev-php/suhosin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/suhosin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/ChangeLog,v 1.17 2014/10/10 01:47:55 grknight Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/ChangeLog,v 1.18 2015/01/19 15:38:55 grknight Exp $
+
+*suhosin-0.9.37.1 (19 Jan 2015)
+
+ 19 Jan 2015; Brian Evans <grknight@gentoo.org>
+ +files/suhosin-0.9.37.1-libcrypt.patch, +suhosin-0.9.37.1.ebuild:
+ Version bump
*suhosin-0.9.36 (08 Oct 2014)
diff --git a/dev-php/suhosin/files/suhosin-0.9.37.1-libcrypt.patch b/dev-php/suhosin/files/suhosin-0.9.37.1-libcrypt.patch
new file mode 100644
index 000000000000..02b5aba1af2b
--- /dev/null
+++ b/dev-php/suhosin/files/suhosin-0.9.37.1-libcrypt.patch
@@ -0,0 +1,12 @@
+Index: suhosin-0.9.32.1/config.m4
+===================================================================
+--- suhosin-0.9.33.orig/config.m4
++++ suhosin-0.9.33/config.m4
+@@ -6,4 +6,7 @@ PHP_ARG_ENABLE(suhosin, whether to enabl
+
+ if test "$PHP_SUHOSIN" != "no"; then
+ PHP_NEW_EXTENSION(suhosin, suhosin.c sha256.c memory_limit.c treat_data.c ifilter.c post_handler.c ufilter.c rfc1867.c rfc1867_new.c log.c header.c execute.c ex_imp.c session.c aes.c crypt.c, $ext_shared)
++ PHP_CHECK_LIBRARY(crypt, crypt,
++ [PHP_ADD_LIBRARY(crypt,, SUHOSIN_SHARED_LIBADD)])
++ PHP_SUBST(SUHOSIN_SHARED_LIBADD)
+ fi
diff --git a/dev-php/suhosin/suhosin-0.9.37.1.ebuild b/dev-php/suhosin/suhosin-0.9.37.1.ebuild
new file mode 100644
index 000000000000..27a0e51c8bd6
--- /dev/null
+++ b/dev-php/suhosin/suhosin-0.9.37.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/suhosin-0.9.37.1.ebuild,v 1.1 2015/01/19 15:38:55 grknight Exp $
+
+EAPI="5"
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations"
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://download.suhosin.org/${P}.tar.gz"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/php[unicode]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}"/${P}-libcrypt.patch
+ done
+ php-ext-source-r2_src_prepare
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc CREDITS
+
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ for inifile in ${PHPINIFILELIST} ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+ done
+}
+
+src_test() {
+ # Makefile passes a hard-coded -d extension_dir=./modules, we move the lib
+ # away from there in src_compile
+ for slot in `php_get_slots`; do
+ php_init_slot_env ${slot}
+ NO_INTERACTION="yes" emake test || die "emake test failed for slot ${slot}"
+ done
+}