summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-02-28 13:00:42 +0000
committerMarinus Schraal <foser@gentoo.org>2003-02-28 13:00:42 +0000
commita798fb9ab8c774e002542153024d97afec263d6e (patch)
tree8ad36e7367c57ee70c3956bc1eb884c7ff216e5f
parentFix for building sparc32 on sparc64 (diff)
downloadgentoo-2-a798fb9ab8c774e002542153024d97afec263d6e.tar.gz
gentoo-2-a798fb9ab8c774e002542153024d97afec263d6e.tar.bz2
gentoo-2-a798fb9ab8c774e002542153024d97afec263d6e.zip
removed redundant patch
-rw-r--r--dev-lang/mono/ChangeLog5
-rw-r--r--dev-lang/mono/files/mono-0.20-unix_rootdir_env.patch56
-rw-r--r--dev-lang/mono/mono-0.20-r1.ebuild10
3 files changed, 6 insertions, 65 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index d244d7b2002c..f2653841bddd 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.14 2003/02/27 17:09:15 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.15 2003/02/28 13:00:42 foser Exp $
*mono-0.20-r1 (27 Feb 2003)
+ 28 Feb 2003; foser <foser@gentoo.org> mono-0.20-r1.ebuild :
+ Removed redundant patch, there was another way to do this duh :/
+
27 Feb 2003; foser <foser@gentoo.org> mono-0.20-r1.ebuild :
Compiles mcs from scratch now
Initial work done by Artur Brodowski <bzdurqa@wp.pl> in #16316
diff --git a/dev-lang/mono/files/mono-0.20-unix_rootdir_env.patch b/dev-lang/mono/files/mono-0.20-unix_rootdir_env.patch
deleted file mode 100644
index 0bff7f8293d0..000000000000
--- a/dev-lang/mono/files/mono-0.20-unix_rootdir_env.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Only in mono-0.20.patched/mono/os/unix/: .deps
-diff -ur mono-0.20/mono/os/unix/Makefile.am mono-0.20.patched/mono/os/unix/Makefile.am
---- mono-0.20/mono/os/unix/Makefile.am 2002-07-19 19:08:25.000000000 +0200
-+++ mono-0.20.patched/mono/os/unix/Makefile.am 2003-02-25 23:27:13.000000000 +0100
-@@ -1,5 +1,6 @@
-
--INCLUDES = -I$(top_srcdir)
-+INCLUDES = -I$(top_srcdir) \
-+ $(GLIB_CFLAGS)
-
- noinst_LTLIBRARIES = libmonoos.la
-
-diff -ur mono-0.20/mono/os/unix/Makefile.in mono-0.20.patched/mono/os/unix/Makefile.in
---- mono-0.20/mono/os/unix/Makefile.in 2003-02-24 00:58:18.000000000 +0100
-+++ mono-0.20.patched/mono/os/unix/Makefile.in 2003-02-25 23:29:33.000000000 +0100
-@@ -109,7 +109,8 @@
- libmono_cflags = @libmono_cflags@
- libmono_ldflags = @libmono_ldflags@
-
--INCLUDES = -I$(top_srcdir)
-+INCLUDES = -I$(top_srcdir) \
-+ $(GLIB_CFLAGS)
-
- noinst_LTLIBRARIES = libmonoos.la
-
-diff -ur mono-0.20/mono/os/unix/util.c mono-0.20.patched/mono/os/unix/util.c
---- mono-0.20/mono/os/unix/util.c 2002-08-28 16:14:24.000000000 +0200
-+++ mono-0.20.patched/mono/os/unix/util.c 2003-02-25 23:45:19.000000000 +0100
-@@ -8,6 +8,7 @@
- */
- #include <config.h>
- #include <mono/os/util.h>
-+#include <mono/metadata/metadata.h>
-
- /*
- * mono_set_rootdir:
-@@ -18,7 +19,18 @@
- void
- mono_set_rootdir (void)
- {
-- /* nothing on Unix */
-+ gchar *moddir, *root;
-+
-+ moddir = (gchar*)g_getenv ("MONO_ROOTDIR");
-+
-+ if (moddir)
-+ {
-+ root = g_build_path (G_DIR_SEPARATOR_S, moddir, NULL);
-+
-+ mono_assembly_setrootdir (root);
-+
-+ g_free (root);
-+ }
- }
-
-
diff --git a/dev-lang/mono/mono-0.20-r1.ebuild b/dev-lang/mono/mono-0.20-r1.ebuild
index 218ae2829c46..84292a4fb754 100644
--- a/dev-lang/mono/mono-0.20-r1.ebuild
+++ b/dev-lang/mono/mono-0.20-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.20-r1.ebuild,v 1.1 2003/02/27 17:06:58 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-0.20-r1.ebuild,v 1.2 2003/02/28 13:00:42 foser Exp $
inherit eutils mono
@@ -28,12 +28,6 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- # patch to select a diff corlib rootdir
- # needed for in-place mcs compilation
- # patch by foser <foser@gentoo.org>
- epatch ${FILESDIR}/${P}-unix_rootdir_env.patch
-
# add our own little in-place mcs script
echo "${S}/mono/jit/mono ${S}/runtime/mcs.exe \"\$@\" " > ${S}/runtime/mcs
chmod +x ${S}/runtime/mcs
@@ -44,7 +38,7 @@ src_compile() {
MAKEOPTS="-j1" emake || die "MONO compilation failure"
cd ${MCS_S}
- PATH=${PATH}:${S}/runtime:${S}/mono/jit MONO_ROOTDIR=${S}/runtime emake -f makefile.gnu || die "MCS compilation failure"
+ PATH=${PATH}:${S}/runtime:${S}/mono/jit MONO_PATH=${MONO_PATH}:${S}/runtime emake -f makefile.gnu || die "MCS compilation failure"
}
src_install () {