summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-06 17:32:33 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-06 17:32:33 +0000
commita861fd5b5e04f05e466b5f8709cc16539b6a6eb7 (patch)
treeaa2e4d1c0c703a1522d739bca30c7b2bd9b42807
parentStable for HPPA (bug #236390). (diff)
downloadgentoo-2-a861fd5b5e04f05e466b5f8709cc16539b6a6eb7.tar.gz
gentoo-2-a861fd5b5e04f05e466b5f8709cc16539b6a6eb7.tar.bz2
gentoo-2-a861fd5b5e04f05e466b5f8709cc16539b6a6eb7.zip
Fix test suite compilation with gcc4.3+ (bug #236744).
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5 x86_64)
-rw-r--r--dev-util/oprofile/ChangeLog6
-rw-r--r--dev-util/oprofile/files/oprofile-0.9.4-gcc43.patch31
-rw-r--r--dev-util/oprofile/oprofile-0.9.4.ebuild9
3 files changed, 43 insertions, 3 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 5797c42a0750..5425159df6c8 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.52 2008/08/20 19:08:28 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.53 2008/09/06 17:32:32 spock Exp $
+
+ 06 Sep 2008; Michał Januszewski <spock@gentoo.org>
+ +files/oprofile-0.9.4-gcc43.patch, oprofile-0.9.4.ebuild:
+ Fix test suite compilation with gcc4.3+ (bug #236744).
20 Aug 2008; Michał Januszewski <spock@gentoo.org> oprofile-0.9.4.ebuild:
Add a check for CONFIG_OPROFILE in the kernel's .config (bug #235285).
diff --git a/dev-util/oprofile/files/oprofile-0.9.4-gcc43.patch b/dev-util/oprofile/files/oprofile-0.9.4-gcc43.patch
new file mode 100644
index 000000000000..2acc961ea05f
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-0.9.4-gcc43.patch
@@ -0,0 +1,31 @@
+--- libregex/tests/java_test.cpp.old 2008-09-03 00:57:19.357004497 +0200
++++ libregex/tests/java_test.cpp 2008-09-03 00:57:38.234025373 +0200
+@@ -16,6 +16,7 @@
+
+ #include <iostream>
+ #include <fstream>
++#include <cstdlib>
+
+ using namespace std;
+
+--- libregex/tests/regex_test.cpp.old 2008-09-03 00:55:18.564005266 +0200
++++ libregex/tests/regex_test.cpp 2008-09-03 00:55:43.576001018 +0200
+@@ -20,6 +20,7 @@
+
+ #include <iostream>
+ #include <fstream>
++#include <cstdlib>
+
+ using namespace std;
+
+--- libabi/tests/abi_test.cpp.old 2005-08-17 21:15:42.000000000 +0200
++++ libabi/tests/abi_test.cpp 2008-09-03 01:00:04.091003916 +0200
+@@ -17,6 +17,8 @@
+
+ #include <fstream>
+ #include <iostream>
++#include <cstring>
++#include <cstdlib>
+
+ using namespace std;
+
diff --git a/dev-util/oprofile/oprofile-0.9.4.ebuild b/dev-util/oprofile/oprofile-0.9.4.ebuild
index 1daff42b79c7..f15f061f5cf9 100644
--- a/dev-util/oprofile/oprofile-0.9.4.ebuild
+++ b/dev-util/oprofile/oprofile-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.4.ebuild,v 1.3 2008/08/20 19:08:28 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.4.ebuild,v 1.4 2008/09/06 17:32:32 spock Exp $
EAPI=1
@@ -13,7 +13,6 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-# IUSE: it also needs kernel sources but all gentoo users have them
IUSE="qt3"
DEPEND=">=dev-libs/popt-1.7-r1
>=sys-devel/binutils-2.14.90.0.6-r3
@@ -28,6 +27,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
src_compile() {
local myconf=""