summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-06-10 04:06:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-06-10 04:06:27 +0000
commita87c94b843210d34ff2d9e721a6dfb59ef4f89e8 (patch)
treea2e7049a33395c67be55f80b55683ef953e0da6a
parentFix http url (diff)
downloadgentoo-2-a87c94b843210d34ff2d9e721a6dfb59ef4f89e8.tar.gz
gentoo-2-a87c94b843210d34ff2d9e721a6dfb59ef4f89e8.tar.bz2
gentoo-2-a87c94b843210d34ff2d9e721a6dfb59ef4f89e8.zip
Version bump.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
-rw-r--r--dev-libs/libbsd/ChangeLog10
-rw-r--r--dev-libs/libbsd/libbsd-0.5.2.ebuild37
2 files changed, 44 insertions, 3 deletions
diff --git a/dev-libs/libbsd/ChangeLog b/dev-libs/libbsd/ChangeLog
index a857a36fc1c4..9f85beb788a8 100644
--- a/dev-libs/libbsd/ChangeLog
+++ b/dev-libs/libbsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libbsd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/ChangeLog,v 1.15 2012/07/02 08:28:16 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/ChangeLog,v 1.16 2013/06/10 04:06:27 ssuominen Exp $
+
+*libbsd-0.5.2 (10 Jun 2013)
+
+ 10 Jun 2013; Samuli Suominen <ssuominen@gentoo.org> +libbsd-0.5.2.ebuild:
+ Version bump.
02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -libbsd-0.3.0-r1.ebuild,
-libbsd-0.4.0.ebuild, -libbsd-0.4.1.ebuild:
@@ -64,4 +69,3 @@
+files/libbsd-0.2.0-arc4random-prototypes.patch,
+files/libbsd-0.2.0-move-nlist.patch, +metadata.xml:
New ebuild for libbsd. Ebuild by Kevin McCarthy. See bug #354271
-
diff --git a/dev-libs/libbsd/libbsd-0.5.2.ebuild b/dev-libs/libbsd/libbsd-0.5.2.ebuild
new file mode 100644
index 000000000000..9697f850db01
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.5.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/libbsd-0.5.2.ebuild,v 1.1 2013/06/10 04:06:27 ssuominen Exp $
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="http://libbsd.freedesktop.org/wiki/"
+SRC_URI="http://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+ local f="${ROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}