summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-12-29 15:59:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-12-29 15:59:35 +0000
commita8bc0559723930a0999801ac48e72b2fbfb0f00c (patch)
treeafff7337b2713690b4950af346dd47f82fd1563e
parentFix manifest (diff)
downloadgentoo-2-a8bc0559723930a0999801ac48e72b2fbfb0f00c.tar.gz
gentoo-2-a8bc0559723930a0999801ac48e72b2fbfb0f00c.tar.bz2
gentoo-2-a8bc0559723930a0999801ac48e72b2fbfb0f00c.zip
convert to multilib, bug #496390
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--media-libs/tremor/ChangeLog8
-rw-r--r--media-libs/tremor/tremor-0_pre20130223-r1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/media-libs/tremor/ChangeLog b/media-libs/tremor/ChangeLog
index 081da4706f85..bbb1a1b80be9 100644
--- a/media-libs/tremor/ChangeLog
+++ b/media-libs/tremor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/tremor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tremor/ChangeLog,v 1.17 2013/10/14 05:59:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tremor/ChangeLog,v 1.18 2013/12/29 15:59:35 aballier Exp $
+
+*tremor-0_pre20130223-r1 (29 Dec 2013)
+
+ 29 Dec 2013; Alexis Ballier <aballier@gentoo.org>
+ +tremor-0_pre20130223-r1.ebuild:
+ convert to multilib, bug #496390
14 Oct 2013; Agostino Sarubbo <ago@gentoo.org> tremor-0_pre20120120.ebuild:
Stable for arm, wrt bug #480908
diff --git a/media-libs/tremor/tremor-0_pre20130223-r1.ebuild b/media-libs/tremor/tremor-0_pre20130223-r1.ebuild
new file mode 100644
index 000000000000..fed9b7a2bb59
--- /dev/null
+++ b/media-libs/tremor/tremor-0_pre20130223-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tremor/tremor-0_pre20130223-r1.ebuild,v 1.1 2013/12/29 15:59:35 aballier Exp $
+
+EAPI=5
+
+# svn export http://svn.xiph.org/trunk/Tremor tremor-${PV}
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="A fixed-point version of the Ogg Vorbis decoder (also known as libvorbisidec)"
+HOMEPAGE="http://wiki.xiph.org/Tremor"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="low-accuracy static-libs"
+
+RDEPEND="media-libs/libogg:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( "CHANGELOG" "README" )
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS/s:-O2::' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ configure.in || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable low-accuracy)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dohtml -r doc/*
+ prune_libtool_files
+}