summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-06-14 14:24:29 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-06-14 14:24:29 +0000
commita8fe7e22a0763b33e6bcf3f71f991806e21907bf (patch)
tree2626cf2a5048e9f0ed27dae498ed7aee2c92c9da
parentfix ChangeLog header (diff)
downloadgentoo-2-a8fe7e22a0763b33e6bcf3f71f991806e21907bf.tar.gz
gentoo-2-a8fe7e22a0763b33e6bcf3f71f991806e21907bf.tar.bz2
gentoo-2-a8fe7e22a0763b33e6bcf3f71f991806e21907bf.zip
Version bump and general cleanup. Also removed calls to autoconf and friends (fixes bug #205307 and #226613).
(Portage version: 2.1.4.4)
-rw-r--r--sci-chemistry/bodr/ChangeLog11
-rw-r--r--sci-chemistry/bodr/bodr-6.ebuild28
-rw-r--r--sci-chemistry/bodr/bodr-8.ebuild23
-rw-r--r--sci-chemistry/bodr/files/bodr-6-install.patch26
4 files changed, 70 insertions, 18 deletions
diff --git a/sci-chemistry/bodr/ChangeLog b/sci-chemistry/bodr/ChangeLog
index dd1082592fc4..1df185bb8eb7 100644
--- a/sci-chemistry/bodr/ChangeLog
+++ b/sci-chemistry/bodr/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/bodr
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bodr/ChangeLog,v 1.4 2007/08/27 10:26:05 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bodr/ChangeLog,v 1.5 2008/06/14 14:24:28 markusle Exp $
+
+*bodr-8 (14 Jun 2008)
+
+ 14 Jun 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/bodr-6-install.patch, bodr-6.ebuild, +bodr-8.ebuild:
+ Version bump and general cleanup. Also removed calls to autoconf and
+ friends (fixes bug #205307 and #226613).
27 Aug 2007; Raúl Porcel <armin76@gentoo.org> bodr-6.ebuild:
Add ~x86 wrt #190130
diff --git a/sci-chemistry/bodr/bodr-6.ebuild b/sci-chemistry/bodr/bodr-6.ebuild
index 3c790a2b7119..bde98afeb19e 100644
--- a/sci-chemistry/bodr/bodr-6.ebuild
+++ b/sci-chemistry/bodr/bodr-6.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bodr/bodr-6.ebuild,v 1.3 2007/08/27 10:26:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bodr/bodr-6.ebuild,v 1.4 2008/06/14 14:24:28 markusle Exp $
-DESCRIPTION="The Blue Obelisk Data Repository listing element and isotope
-properties."
-HOMEPAGE="http://wiki.cubic.uni-koeln.de/bowiki/index.php/DataRepository"
+inherit eutils
+
+DESCRIPTION="The Blue Obelisk Data Repository listing element and isotope properties."
+HOMEPAGE="http://sourceforge.net/projects/bodr"
SRC_URI="mirror://sourceforge/bodr/${P}.tar.bz2"
LICENSE="MIT"
@@ -13,19 +14,14 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=">=dev-libs/libxslt-1.1.20"
-RDEPEND=""
-
-src_compile() {
- aclocal || die "aclocal failed"
- automake --gnu -a || die "automake failed"
- autoconf || die "autoconf failed"
- econf || die "econf failed"
- emake || die "emake failed"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/bodr-6-install.patch
}
+
src_install() {
- make install DESTDIR=${D} || die "make install failed"
- mv ${D}/usr/share/doc/${PN} ${D}/usr/share/doc/${PF}
- rm ${D}/usr/share/doc/${PF}/COPYING
+ make install DESTDIR="${D}" || die "make install failed"
}
diff --git a/sci-chemistry/bodr/bodr-8.ebuild b/sci-chemistry/bodr/bodr-8.ebuild
new file mode 100644
index 000000000000..482db0280b07
--- /dev/null
+++ b/sci-chemistry/bodr/bodr-8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bodr/bodr-8.ebuild,v 1.1 2008/06/14 14:24:28 markusle Exp $
+
+DESCRIPTION="The Blue Obelisk Data Repository listing element and isotope properties."
+HOMEPAGE="http://sourceforge.net/projects/bodr"
+SRC_URI="mirror://sourceforge/bodr/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libxslt-1.1.20"
+
+src_compile() {
+ econf --docdir="/usr/share/doc/${P}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+}
diff --git a/sci-chemistry/bodr/files/bodr-6-install.patch b/sci-chemistry/bodr/files/bodr-6-install.patch
new file mode 100644
index 000000000000..644e35da0968
--- /dev/null
+++ b/sci-chemistry/bodr/files/bodr-6-install.patch
@@ -0,0 +1,26 @@
+diff -Naur bodr-6/elements/Makefile.in bodr-6.new/elements/Makefile.in
+--- bodr-6/elements/Makefile.in 2007-03-10 11:32:24.000000000 -0500
++++ bodr-6.new/elements/Makefile.in 2008-06-14 10:01:22.000000000 -0400
+@@ -194,7 +194,7 @@
+ crystal_DATA = crystalstructures.xml
+ elementdir = ${pkgdatadir}
+ element_DATA = elements.xml
+-docsdir = ${datadir}/doc/${PACKAGE}/bibxml
++docsdir = ${datadir}/doc/${PACKAGE}-${VERSION}/bibxml
+ docs_DATA = elements_biblio.html crystalstructures_biblio.html
+ all: all-am
+
+diff -Naur bodr-6/Makefile.in bodr-6.new/Makefile.in
+--- bodr-6/Makefile.in 2007-03-10 11:32:24.000000000 -0500
++++ bodr-6.new/Makefile.in 2008-06-14 09:56:04.000000000 -0400
+@@ -175,8 +175,8 @@
+ # if the generated archives should be removed too, add the following
+ # filename to the maintainer-clean target too:
+ # @PACKAGE@-@VERSION@.tar.{bz2,gz}
+-docsdir = ${datadir}/doc/${PACKAGE}
+-docs_DATA = AUTHORS THANKS ChangeLog COPYING README
++docsdir = ${datadir}/doc/${PACKAGE}-${VERSION}
++docs_DATA = AUTHORS THANKS ChangeLog README
+ pkgconfigdir = ${datadir}/pkgconfig
+ pkgconfig_DATA = bodr.pc
+ all: all-recursive