summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2013-06-02 00:03:11 +0000
committerJonathan Callen <abcd@gentoo.org>2013-06-02 00:03:11 +0000
commitab3423b229556fd16023f758934204da54361e3e (patch)
tree11a7f8ea240764050afff080283d84c43dc629b9
parentcleanup old ebuild (diff)
downloadgentoo-2-ab3423b229556fd16023f758934204da54361e3e.tar.gz
gentoo-2-ab3423b229556fd16023f758934204da54361e3e.tar.bz2
gentoo-2-ab3423b229556fd16023f758934204da54361e3e.zip
Force non-empty PYTHON_TARGETS to ensure that build always succeeds
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 229E5838)
-rw-r--r--gnome-base/gnome-shell/ChangeLog6
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.6.3.1.ebuild4
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.8.2.ebuild4
3 files changed, 11 insertions, 3 deletions
diff --git a/gnome-base/gnome-shell/ChangeLog b/gnome-base/gnome-shell/ChangeLog
index 1cf3b556b3bc..31adce4cfb8c 100644
--- a/gnome-base/gnome-shell/ChangeLog
+++ b/gnome-base/gnome-shell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/gnome-shell
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/ChangeLog,v 1.34 2013/05/24 20:05:27 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/ChangeLog,v 1.35 2013/06/02 00:03:11 abcd Exp $
+
+ 02 Jun 2013; Jonathan Callen <abcd@gentoo.org> gnome-shell-3.6.3.1.ebuild,
+ gnome-shell-3.8.2.ebuild:
+ Force non-empty PYTHON_TARGETS to ensure that build always succeeds
24 May 2013; Pacho Ramos <pacho@gentoo.org> -gnome-shell-3.8.1.ebuild,
gnome-shell-3.8.2.ebuild:
diff --git a/gnome-base/gnome-shell/gnome-shell-3.6.3.1.ebuild b/gnome-base/gnome-shell/gnome-shell-3.6.3.1.ebuild
index 1ec936f0a6d7..8862f686a157 100644
--- a/gnome-base/gnome-shell/gnome-shell-3.6.3.1.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-3.6.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.6.3.1.ebuild,v 1.3 2013/05/19 20:42:05 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.6.3.1.ebuild,v 1.4 2013/06/02 00:03:11 abcd Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -113,6 +113,8 @@ DEPEND="${COMMON_DEPEND}
# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
# https://bugs.gentoo.org/show_bug.cgi?id=360413
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
src_prepare() {
# Fix automagic gnome-bluetooth dep, bug #398145
epatch "${FILESDIR}/${PN}-3.5.x-bluetooth-flag.patch"
diff --git a/gnome-base/gnome-shell/gnome-shell-3.8.2.ebuild b/gnome-base/gnome-shell/gnome-shell-3.8.2.ebuild
index 2a664a7849d6..e48311921bca 100644
--- a/gnome-base/gnome-shell/gnome-shell-3.8.2.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-3.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.8.2.ebuild,v 1.4 2013/05/24 20:05:27 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.8.2.ebuild,v 1.5 2013/06/02 00:03:11 abcd Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -112,6 +112,8 @@ DEPEND="${COMMON_DEPEND}
# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
# https://bugs.gentoo.org/show_bug.cgi?id=360413
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
src_prepare() {
# Fix automagic gnome-bluetooth dep, bug #398145
epatch "${FILESDIR}/${PN}-3.7.90-bluetooth-flag.patch"