summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-10-25 19:24:22 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-10-25 19:24:22 +0000
commitabd1ff298da139226c6fbc2709f47221be76c73d (patch)
treedf6e53d5d4451d3940f7bc1d7bf3da1b140000eb
parentFix changelog (diff)
downloadgentoo-2-abd1ff298da139226c6fbc2709f47221be76c73d.tar.gz
gentoo-2-abd1ff298da139226c6fbc2709f47221be76c73d.tar.bz2
gentoo-2-abd1ff298da139226c6fbc2709f47221be76c73d.zip
Version bump, thanks to Flameeyes for poking me.
(Portage version: 2.1.3.16)
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.7.93
-rw-r--r--net-p2p/rtorrent/rtorrent-0.7.9.ebuild49
3 files changed, 58 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 34a218652c1f..2441ccf8834a 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.93 2007/09/08 22:20:00 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.94 2007/10/25 19:24:21 drizzt Exp $
+
+*rtorrent-0.7.9 (25 Oct 2007)
+
+ 25 Oct 2007; Timothy Redaelli <drizzt@gentoo.org> +rtorrent-0.7.9.ebuild:
+ Version bump, thanks to Flameeyes for poking me.
08 Sep 2007; Hanno Boeck <hanno@gentoo.org> ChangeLog:
Place comment below econf-line, else it breaks.
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.7.9 b/net-p2p/rtorrent/files/digest-rtorrent-0.7.9
new file mode 100644
index 000000000000..47691e28b42b
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.7.9
@@ -0,0 +1,3 @@
+MD5 136202fdd540a92aafbcee29f849d228 rtorrent-0.7.9.tar.gz 489174
+RMD160 8cfee138c0142ad22830b3d518e198f163063a84 rtorrent-0.7.9.tar.gz 489174
+SHA256 f06f72b1fec94177147b1db0aab15be4f62d1b0354811a67ae74e0cd1e50a119 rtorrent-0.7.9.tar.gz 489174
diff --git a/net-p2p/rtorrent/rtorrent-0.7.9.ebuild b/net-p2p/rtorrent/rtorrent-0.7.9.ebuild
new file mode 100644
index 000000000000..6405b0f26f83
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.7.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.7.9.ebuild,v 1.1 2007/10/25 19:24:21 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.11.${PV##*.}
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.15
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ replace-flags -Os -O2
+ append-flags -fno-strict-aliasing
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ econf \
+ $(use_enable debug) \
+ --disable-xmlrpc-c \
+ --disable-dependency-tracking \
+ || die "econf failed"
+ # --disable-xmlrpc-c: I want to keep it disabled while >=dev-libs/xmlrpc-c-1.07 is masked
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ elog "rtorrent now supports a configuration file."
+ elog "A sample configuration file for rtorrent is can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}