summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-09-11 13:33:34 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-09-11 13:33:34 +0000
commitac706ccda4e86db0545f16ce75ae048fbbb0e59a (patch)
treedda60b88b918e55deedb7d9bc851f475ee4daf8f
parentBump (diff)
downloadgentoo-2-ac706ccda4e86db0545f16ce75ae048fbbb0e59a.tar.gz
gentoo-2-ac706ccda4e86db0545f16ce75ae048fbbb0e59a.tar.bz2
gentoo-2-ac706ccda4e86db0545f16ce75ae048fbbb0e59a.zip
Initial import into portage tree (fixes bug #282203).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--sci-libs/qrupdate/ChangeLog10
-rw-r--r--sci-libs/qrupdate/files/qrupdate-1.0.1-makefile.patch24
-rw-r--r--sci-libs/qrupdate/metadata.xml8
-rw-r--r--sci-libs/qrupdate/qrupdate-1.0.1.ebuild48
4 files changed, 90 insertions, 0 deletions
diff --git a/sci-libs/qrupdate/ChangeLog b/sci-libs/qrupdate/ChangeLog
new file mode 100644
index 000000000000..e8b870acc9d3
--- /dev/null
+++ b/sci-libs/qrupdate/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/qrupdate
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.1 2009/09/11 13:33:34 markusle Exp $
+
+*qrupdate-1.0.1 (11 Sep 2009)
+
+ 11 Sep 2009; Markus Dittrich <markusle@gentoo.org> +qrupdate-1.0.1.ebuild,
+ +files/qrupdate-1.0.1-makefile.patch, +metadata.xml:
+ Initial import into portage tree (fixes bug #282203).
+
diff --git a/sci-libs/qrupdate/files/qrupdate-1.0.1-makefile.patch b/sci-libs/qrupdate/files/qrupdate-1.0.1-makefile.patch
new file mode 100644
index 000000000000..fa8925fd8bb6
--- /dev/null
+++ b/sci-libs/qrupdate/files/qrupdate-1.0.1-makefile.patch
@@ -0,0 +1,24 @@
+diff -Naur qrupdate-1.0.1/Makefile qrupdate-1.0.1.new/Makefile
+--- qrupdate-1.0.1/Makefile 2009-02-06 04:12:00.000000000 -0500
++++ qrupdate-1.0.1.new/Makefile 2009-09-10 09:55:32.000000000 -0400
+@@ -34,7 +34,7 @@
+ lib:
+ make -C src/ lib
+ solib:
+- make -C src/ solib
++ +make -C src/ solib
+ test: lib
+ make -C test/
+
+diff -Naur qrupdate-1.0.1/src/Makefile qrupdate-1.0.1.new/src/Makefile
+--- qrupdate-1.0.1/src/Makefile 2009-02-06 04:12:50.000000000 -0500
++++ qrupdate-1.0.1.new/src/Makefile 2009-09-10 09:49:29.000000000 -0400
+@@ -40,7 +40,7 @@
+ ar -cr $@ $(OBJS)
+
+ ../libqrupdate.so: $(OBJS)
+- $(FC) $(FFLAGS) -shared -o $@ -Wl,-soname=libqrupdate.so.$(MAJOR) $(OBJS) \
++ $(FC) $(FFLAGS) $(LDFLAGS) -shared -o $@ -Wl,-soname=libqrupdate.so.$(MAJOR) $(OBJS) \
+ $(BLAS) $(LAPACK)
+
+ $(OBJS): %.o: %.f
diff --git a/sci-libs/qrupdate/metadata.xml b/sci-libs/qrupdate/metadata.xml
new file mode 100644
index 000000000000..a8bc30434eab
--- /dev/null
+++ b/sci-libs/qrupdate/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ qrupdate is a library for fast updating of qr and cholesky decompositions.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/qrupdate/qrupdate-1.0.1.ebuild b/sci-libs/qrupdate/qrupdate-1.0.1.ebuild
new file mode 100644
index 000000000000..5e24236adb1a
--- /dev/null
+++ b/sci-libs/qrupdate/qrupdate-1.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.0.1.ebuild,v 1.1 2009/09/11 13:33:34 markusle Exp $
+
+EAPI="2"
+
+inherit eutils fortran
+
+DESCRIPTION="A library for fast updating of QR and Cholesky decompositions"
+HOMEPAGE="http://sourceforge.net/projects/qrupdate"
+SRC_URI="mirror://sourceforge/qrupdate/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+FORTRAN="gfortran ifc g77"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ local BLAS_LIBS="$(pkg-config --libs blas)"
+ local LAPACK_LIBS="$(pkg-config --libs lapack)"
+
+ sed -i Makeconf \
+ -e "s:gfortran:${FORTRANC}:g" \
+ -e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \
+ -e "s:BLAS=.*:BLAS=${BLAS_LIBS}:" \
+ -e "s:LAPACK=.*:LAPACK=${LAPACK_LIBS}:" \
+ || die "Failed to set up Makeconf"
+}
+
+src_compile() {
+ emake solib || die "emake failed"
+}
+
+src_install() {
+ dolib.so libqrupdate.so \
+ || die "Failed to install libqrupdate.so"
+
+ dodoc README ChangeLog || die "dodoc failed"
+}