summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-27 02:24:09 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-27 02:24:09 +0000
commitaed6cf5d52689813ababf04fd99d40f5f669630d (patch)
tree49b02e8f38e0c629b85637bad9b169b6877faea7
parentAdd ruby21 target. (diff)
downloadgentoo-2-aed6cf5d52689813ababf04fd99d40f5f669630d.tar.gz
gentoo-2-aed6cf5d52689813ababf04fd99d40f5f669630d.tar.bz2
gentoo-2-aed6cf5d52689813ababf04fd99d40f5f669630d.zip
Add ruby21 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--dev-ruby/atomic/ChangeLog7
-rw-r--r--dev-ruby/atomic/atomic-1.1.14-r1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/atomic/ChangeLog b/dev-ruby/atomic/ChangeLog
index e89dea40e0e0..f635ed0e55e3 100644
--- a/dev-ruby/atomic/ChangeLog
+++ b/dev-ruby/atomic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/atomic
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/ChangeLog,v 1.11 2013/12/25 06:50:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/ChangeLog,v 1.12 2013/12/27 02:24:09 mrueg Exp $
+
+*atomic-1.1.14-r1 (27 Dec 2013)
+
+ 27 Dec 2013; Manuel Rüger <mrueg@gentoo.org> +atomic-1.1.14-r1.ebuild:
+ Add ruby21 target.
25 Dec 2013; Hans de Graaff <graaff@gentoo.org> -atomic-1.1.13.ebuild:
Cleanup.
diff --git a/dev-ruby/atomic/atomic-1.1.14-r1.ebuild b/dev-ruby/atomic/atomic-1.1.14-r1.ebuild
new file mode 100644
index 000000000000..dd4c73a2d5f6
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.14-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/atomic-1.1.14-r1.ebuild,v 1.1 2013/12/27 02:24:09 mrueg Exp $
+
+EAPI=5
+# jruby → there is code for this in ext but that requires compiling java.
+USE_RUBY="ruby18 ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}