summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-09 09:10:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-09 09:10:28 +0000
commitaee185aef955870876463e8a6fcafa66e42d1477 (patch)
tree75bef0f4b198acdab6ad1b803ed00f3053c69f4b
parentStable on x86; bug #114883 (diff)
downloadgentoo-2-aee185aef955870876463e8a6fcafa66e42d1477.tar.gz
gentoo-2-aee185aef955870876463e8a6fcafa66e42d1477.tar.bz2
gentoo-2-aee185aef955870876463e8a6fcafa66e42d1477.zip
Add support for non-lazy-bindings non setuid executables. See bug #113937.
(Portage version: 2.0.53)
-rw-r--r--kde-base/kdelibs/ChangeLog6
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.0-bindnow.patch33
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.0.ebuild6
3 files changed, 43 insertions, 2 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 4d1eaf6a04a7..c1840be8d0b9 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.293 2005/12/06 05:31:07 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.294 2005/12/09 09:10:28 flameeyes Exp $
+
+ 09 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kdelibs-3.5.0-bindnow.patch, kdelibs-3.5.0.ebuild:
+ Add support for non-lazy-bindings non setuid executables. See bug #113937.
06 Dec 2005; Joseph Jezak <josejx@gentoo.org> kdelibs-3.4.3.ebuild:
Marked ppc stable for bug #112842.
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.0-bindnow.patch b/kde-base/kdelibs/files/kdelibs-3.5.0-bindnow.patch
new file mode 100644
index 000000000000..3a7e1133a5d7
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.5.0-bindnow.patch
@@ -0,0 +1,33 @@
+Add support for BINDNOW_FLAGS to build kgrantpty and kpac_dhcp_helper with
+non-lazy bindings, to improve security and fix installation on
+FEATURES=stricter.
+See bug #113937.
+
+Requires the ebuild to export BINDNOW_FLAGS="$(bindnow-flags)".
+
+Index: kdelibs-3.5.0/kdecore/Makefile.am
+===================================================================
+--- kdelibs-3.5.0.orig/kdecore/Makefile.am
++++ kdelibs-3.5.0/kdecore/Makefile.am
+@@ -169,7 +169,7 @@ kde_config_LDFLAGS = $(KDE_RPATH) $(KDE_
+
+ kgrantpty_SOURCES = kgrantpty.c
+ kgrantpty_CFLAGS= $(KDE_USE_FPIE)
+-kgrantpty_LDFLAGS = $(KDE_USE_PIE) $(KDE_RPATH) $(all_libraries)
++kgrantpty_LDFLAGS = $(KDE_USE_PIE) $(KDE_RPATH) $(all_libraries) $(BINDNOW_FLAGS)
+ kgrantpty_LDADD = ./libkdefakes.la
+
+ # kgrantpty needs to be installed setuid root
+Index: kdelibs-3.5.0/kio/misc/kpac/Makefile.am
+===================================================================
+--- kdelibs-3.5.0.orig/kio/misc/kpac/Makefile.am
++++ kdelibs-3.5.0/kio/misc/kpac/Makefile.am
+@@ -14,7 +14,7 @@ kded_proxyscout_la_LIBADD = $(LIB_KIO) $
+
+ kpac_dhcp_helper_SOURCES = kpac_dhcp_helper.c
+ kpac_dhcp_helper_CFLAGS = $(KDE_USE_FPIE)
+-kpac_dhcp_helper_LDFLAGS = $(KDE_USE_PIE)
++kpac_dhcp_helper_LDFLAGS = $(KDE_USE_PIE) $(BINDNOW_FLAGS)
+ kpac_dhcp_helper_LDADD = $(LIBSOCKET)
+
+ noinst_HEADERS = proxyscout.h script.h downloader.h discovery.h
diff --git a/kde-base/kdelibs/kdelibs-3.5.0.ebuild b/kde-base/kdelibs/kdelibs-3.5.0.ebuild
index 93389a81f646..70fb06fed5da 100644
--- a/kde-base/kdelibs/kdelibs-3.5.0.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.0.ebuild,v 1.3 2005/12/01 15:20:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.0.ebuild,v 1.4 2005/12/09 09:10:28 flameeyes Exp $
inherit kde flag-o-matic eutils multilib
set-kdedir 3.5
@@ -46,6 +46,8 @@ DEPEND="${RDEPEND}
sys-devel/gettext
dev-util/pkgconfig"
+PATCHES="${FILESDIR}/${P}-bindnow.patch"
+
src_compile() {
myconf="--with-distribution=Gentoo
--enable-libfam $(use_enable kernel_linux dnotify)
@@ -69,6 +71,8 @@ src_compile() {
# closer look... - corsair
use ppc64 && append-flags "-mminimal-toc"
+ export BINDNOW_FLAGS="$(bindnow-flags)"
+
kde_src_compile
if use doc; then