summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-08-07 16:14:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-08-07 16:14:59 +0000
commitb22509d8bbeff6dbdafac8446d34e830ebe60a0d (patch)
tree7b10e23caa028927c00dae96e93cc6631b6cea6c
parentFix building with libpng15 wrt #355893 by Mike Frysinger (diff)
downloadgentoo-2-b22509d8bbeff6dbdafac8446d34e830ebe60a0d.tar.gz
gentoo-2-b22509d8bbeff6dbdafac8446d34e830ebe60a0d.tar.bz2
gentoo-2-b22509d8bbeff6dbdafac8446d34e830ebe60a0d.zip
Fix building with libpng15 wrt #373871 by Stuart Longland. Remove automagic USE="png zlib" and always depend on libpng and zlib.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
-rw-r--r--app-office/dia/ChangeLog7
-rw-r--r--app-office/dia/dia-0.97.1.ebuild13
-rw-r--r--app-office/dia/files/dia-0.97.1-libpng15.patch24
3 files changed, 37 insertions, 7 deletions
diff --git a/app-office/dia/ChangeLog b/app-office/dia/ChangeLog
index 562c7128ed92..0ceb6fbccc2d 100644
--- a/app-office/dia/ChangeLog
+++ b/app-office/dia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/dia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.131 2011/04/14 18:28:15 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.132 2011/08/07 16:14:59 ssuominen Exp $
+
+ 07 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> dia-0.97.1.ebuild,
+ +files/dia-0.97.1-libpng15.patch:
+ Fix building with libpng15 wrt #373871 by Stuart Longland. Remove automagic
+ USE="png zlib" and always depend on libpng and zlib.
14 Apr 2011; Jonathan Callen <abcd@gentoo.org> dia-0.97.1.ebuild:
Add prefix support and keywords
diff --git a/app-office/dia/dia-0.97.1.ebuild b/app-office/dia/dia-0.97.1.ebuild
index 50ca7230f07c..29b2321b454e 100644
--- a/app-office/dia/dia-0.97.1.ebuild
+++ b/app-office/dia/dia-0.97.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.97.1.ebuild,v 1.12 2011/04/14 18:28:15 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.97.1.ebuild,v 1.13 2011/08/07 16:14:59 ssuominen Exp $
EAPI="3"
GCONF_DEBUG="yes"
@@ -20,7 +20,7 @@ SRC_URI="mirror://gnome/sources/${PN}/${MY_PV_MM}/${MY_P}.tar.bz2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
# the doc USE flag doesn't seem to do anything without docbook2html
-IUSE="cairo doc gnome png python zlib"
+IUSE="cairo doc gnome python"
RDEPEND=">=x11-libs/gtk+-2.6.0:2
>=dev-libs/glib-2.6.0
@@ -29,10 +29,9 @@ RDEPEND=">=x11-libs/gtk+-2.6.0:2
>=dev-libs/libxslt-1
>=media-libs/freetype-2.0.95
dev-libs/popt
- zlib? ( sys-libs/zlib )
- png? (
- media-libs/libpng
- >=media-libs/libart_lgpl-2 )
+ sys-libs/zlib
+ media-libs/libpng
+ >=media-libs/libart_lgpl-2
gnome? (
>=gnome-base/libgnome-2.0
>=gnome-base/libgnomeui-2.0 )
@@ -65,6 +64,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+
gnome2_src_prepare
# Fix compilation in a gnome environment, bug #159831
diff --git a/app-office/dia/files/dia-0.97.1-libpng15.patch b/app-office/dia/files/dia-0.97.1-libpng15.patch
new file mode 100644
index 000000000000..37939748c54a
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.1-libpng15.patch
@@ -0,0 +1,24 @@
+From 59f67782b9e382b2d71aeabbd493799b179bdec0 Mon Sep 17 00:00:00 2001
+From: Hans Breuer <hans@breuer.org>
+Date: Sun, 27 Feb 2011 20:32:47 +0000
+Subject: Bug 642764 - use png_jmpbuf() rather than direct member access
+
+Fix from Hanno Boeck to make Dia compile with libpng 1.5
+https://bugzilla.gnome.org/show_bug.cgi?id=642764
+(cherry picked from commit 8e28086b95578d17386c3be9aea132064be829a0)
+---
+diff --git a/plug-ins/libart/export_png.c b/plug-ins/libart/export_png.c
+index f8bbdc1..33ea6c3 100644
+--- a/plug-ins/libart/export_png.c
++++ b/plug-ins/libart/export_png.c
+@@ -178,7 +178,7 @@ export_png_ok(GtkButton *button, gpointer userdata)
+ }
+
+ /* set error handling ... */
+- if (setjmp(png->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png))) {
+ fclose(fp);
+ png_destroy_write_struct(&png, &info);
+ message_error(_("Error occurred while writing PNG"));
+--
+cgit v0.9