summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-11-30 05:31:39 +0000
committerChris White <chriswhite@gentoo.org>2004-11-30 05:31:39 +0000
commitb64c5511a403edc2c8c758144715acd80c0503bb (patch)
tree13974198984e989eb2ec15885387fbfc46b7ad3a
parentFixing the mm deps for real, closes bug #60889 (Manifest recommit) (diff)
downloadgentoo-2-b64c5511a403edc2c8c758144715acd80c0503bb.tar.gz
gentoo-2-b64c5511a403edc2c8c758144715acd80c0503bb.tar.bz2
gentoo-2-b64c5511a403edc2c8c758144715acd80c0503bb.zip
Version bump to 6.0.0_p1.
-rw-r--r--media-libs/pdflib/ChangeLog7
-rw-r--r--media-libs/pdflib/Manifest14
-rw-r--r--media-libs/pdflib/files/digest-pdflib-6.0.0_p11
-rw-r--r--media-libs/pdflib/pdflib-6.0.0_p1.ebuild97
4 files changed, 107 insertions, 12 deletions
diff --git a/media-libs/pdflib/ChangeLog b/media-libs/pdflib/ChangeLog
index 7ca12c32e925..d30e7be0cfe8 100644
--- a/media-libs/pdflib/ChangeLog
+++ b/media-libs/pdflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/pdflib
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.41 2004/10/16 23:11:42 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.42 2004/11/30 05:31:39 chriswhite Exp $
+
+*pdflib-6.0.0_p1 (30 Nov 2004)
+
+ 30 Nov 2004; Chris White <chriswhite@gentoo.org> +pdflib-6.0.0_p1.ebuild:
+ Version bump to 6.0.0_p1.
17 Oct 2004; Thomas Matthijs <axxo@gentoo.org> pdflib-5.0.2.ebuild:
dojar --> java-pkg_dojar
diff --git a/media-libs/pdflib/Manifest b/media-libs/pdflib/Manifest
index 8afc4c002950..ba165ef3ade1 100644
--- a/media-libs/pdflib/Manifest
+++ b/media-libs/pdflib/Manifest
@@ -1,13 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 04e56828eb6bfdd2255bdf2011143d15 ChangeLog 5752
MD5 75452e1aedeee7f89170aafac2969be4 pdflib-5.0.2.ebuild 3071
-MD5 e4cc633e2ae7236f0d834883d1946761 ChangeLog 5615
+MD5 9b8e6ade4cfcf476eb36b2d84b8b1ef8 pdflib-6.0.0_p1.ebuild 2982
MD5 9892461f8babed0732b85ef46b5a163b files/digest-pdflib-5.0.2 79
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBcaq3/rLF9B432nYRAjZVAJ4hbgxTtwiwxrt9759aIHuo2qYNRwCfe0OX
-1aiHQOSAv8q8qcXBQ0PdAqU=
-=z5jl
------END PGP SIGNATURE-----
+MD5 9c23ee70c812e1b6942f31d06c00b1d6 files/digest-pdflib-6.0.0_p1 72
diff --git a/media-libs/pdflib/files/digest-pdflib-6.0.0_p1 b/media-libs/pdflib/files/digest-pdflib-6.0.0_p1
new file mode 100644
index 000000000000..b0228b9713b7
--- /dev/null
+++ b/media-libs/pdflib/files/digest-pdflib-6.0.0_p1
@@ -0,0 +1 @@
+MD5 602a24de413c00ec3b2ceb7b32503813 PDFlib-Lite-6.0.0p1.tar.gz 3494524
diff --git a/media-libs/pdflib/pdflib-6.0.0_p1.ebuild b/media-libs/pdflib/pdflib-6.0.0_p1.ebuild
new file mode 100644
index 000000000000..7a2637f50204
--- /dev/null
+++ b/media-libs/pdflib/pdflib-6.0.0_p1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-6.0.0_p1.ebuild,v 1.1 2004/11/30 05:31:39 chriswhite Exp $
+
+inherit java-pkg
+
+MY_PN="${PN/pdf/PDF}-Lite"
+MY_PV="${PV/_p1/p1}"
+MY_P="${MY_PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A library for generating PDF on the fly"
+HOMEPAGE="http://www.pdflib.com/"
+SRC_URI="http://www.pdflib.com/products/pdflib/download/600p1src/${MY_P}.tar.gz"
+
+LICENSE="Aladdin"
+SLOT="5"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE="tcltk perl python java"
+
+DEPEND=">=sys-apps/sed-4
+ tcltk? ( >=dev-lang/tk-8.2 )
+ perl? ( >=dev-lang/perl-5.1 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3 )"
+
+src_compile() {
+ local myconf=
+
+ PYVER="$(/usr/bin/python -V 2>&1 | cut -d ' ' -f 2 | cut -d '.' -f 1,2)"
+ use tcltk || myconf="--with-tcl=no"
+ use perl || myconf="${myconf} --with-perl=no"
+ use python \
+ && myconf="${myconf} --with-py=/usr --with-pyincl=/usr/include/python${PYVER}" \
+ || myconf="${myconf} --with-py=no"
+ use java \
+ && myconf="${myconf} --with-java=${JAVA_HOME}" \
+ || myconf="${myconf} --with-java=no"
+
+ econf \
+ --enable-cxx \
+ ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ ${S}/bind/pdflib/perl/Makefile \
+ || die "sed bind/pdflib/perl/Makefile failed"
+
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ ${S}/bind/pdflib/tcl/Makefile \
+ || die "sed bind/pdflib/tcl/Makefile failed"
+
+ # ok, this should create the correct lib dirs for perl and python.
+ # yes, i know it is messy, but as i see it, a ebuild should be generic
+ # ... ie. you should be able to just use cp to update it
+ if use perl && [ -x /usr/bin/perl ] ; then
+ local perlmajver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4 |cut -d '.' -f 1`"
+ local perlver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4`"
+ local perlarch="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 7`"
+ dodir /usr/$(get_libdir)/perl${perlmajver/v/}/site_perl/${perlver/v/}/${perlarch}
+ fi
+ if use python && [ -x /usr/bin/python ] ; then
+ dodir /usr/$(get_libdir)/python${PYVER}/lib-dynload
+ fi
+ #next line required for proper install
+ dodir /usr/bin
+ einstall || die
+
+ dodoc readme.txt doc/*
+
+ # seemant: seems like the makefiles for pdflib generate the .jar file
+ # anyway
+ use java && java-pkg_dojar bind/pdflib/java/pdflib.jar
+
+ # karltk: This is definitely NOT how it should be done!
+ # we need this to create pdflib.jar (we will not have the source when
+ # this is a binary package ...)
+# if use java
+# then
+# insinto /usr/share/pdflib
+# doins ${S}/bind/pdflib/java/pdflib.java
+#
+# mkdir -p com/pdflib
+# mv ${S}/bind/pdflib/java/pdflib.java com/pdflib
+# javac com/pdflib/pdflib.java
+#
+# jar cf pdflib.jar com/pdflib/*.class
+#
+# java-pkg_dojar pdflib.jar
+# fi
+}