summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-20 19:19:27 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-20 19:19:27 +0000
commitb8e80e4dbc8d452b4e8eb10516a9b67618e5bf40 (patch)
tree48a48bfc93191fe3719797fed886dc6a0d978059
parentdev-python/PyXML-py21 is now dev-python/pyxml-py21 - remove old ebuilds. (diff)
downloadgentoo-2-b8e80e4dbc8d452b4e8eb10516a9b67618e5bf40.tar.gz
gentoo-2-b8e80e4dbc8d452b4e8eb10516a9b67618e5bf40.tar.bz2
gentoo-2-b8e80e4dbc8d452b4e8eb10516a9b67618e5bf40.zip
Add a patch to x11-plugins/wmpinboard 1.0 so that it does not segfault when adding a new note. Closes #43369
-rw-r--r--x11-plugins/wmpinboard/ChangeLog5
-rw-r--r--x11-plugins/wmpinboard/files/wmpinboard-1.0-segfault.patch11
-rw-r--r--x11-plugins/wmpinboard/wmpinboard-1.0.ebuild18
3 files changed, 29 insertions, 5 deletions
diff --git a/x11-plugins/wmpinboard/ChangeLog b/x11-plugins/wmpinboard/ChangeLog
index 816344e8f25e..a0f5d659fc3b 100644
--- a/x11-plugins/wmpinboard/ChangeLog
+++ b/x11-plugins/wmpinboard/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmpinboard
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpinboard/ChangeLog,v 1.9 2004/06/24 23:15:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpinboard/ChangeLog,v 1.10 2004/07/20 19:19:27 s4t4n Exp $
+
+ 20 Jul 2004; Michele Noberasco <s4t4n@gentoo.org> wmpinboard-1.0.ebuild:
+ Added patch to fix segfault when adding a new note. Closes #43369.
26 Apr 2004; Aron Griffis <agriffis@gentoo.org> wmpinboard-1.0.ebuild:
Add die following econf for bug 48950
diff --git a/x11-plugins/wmpinboard/files/wmpinboard-1.0-segfault.patch b/x11-plugins/wmpinboard/files/wmpinboard-1.0-segfault.patch
new file mode 100644
index 000000000000..7d2c94458b52
--- /dev/null
+++ b/x11-plugins/wmpinboard/files/wmpinboard-1.0-segfault.patch
@@ -0,0 +1,11 @@
+--- src/wmpinboard.c 2000-04-13 13:01:17.000000000 +0200
++++ src/wmpinboard.c 2003-03-06 19:29:57.000000000 +0100
+@@ -165,7 +165,7 @@
+ char t[STRING_BUF_SIZE];
+ FILE *file;
+ int pid = (int) getpid();
+- static int sizes[6];
++ static int sizes[7];
+ sizes[0] = size_0;
+ sizes[1] = size_1;
+ sizes[2] = size_2;
diff --git a/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild b/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
index e61b4810ee66..cd8cce40f85d 100644
--- a/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
+++ b/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild,v 1.11 2004/06/24 23:15:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild,v 1.12 2004/07/20 19:19:27 s4t4n Exp $
+
+inherit eutils
IUSE=""
DESCRIPTION="Window Maker dock applet resembling a miniature pinboard."
@@ -13,12 +15,20 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc alpha amd64 ~ppc"
-src_compile() {
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/wmpinboard-1.0-segfault.patch
+}
+
+src_compile()
+{
econf || die "econf failed"
emake || die "emake failed"
}
-src_install () {
+src_install ()
+{
make DESTDIR=${D} install-strip || die "install failed"
}
-