summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-04 09:35:45 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-04 09:35:45 +0000
commitba61d7fce937582d9db6786b54dd22216d533c90 (patch)
tree4d168e6b05135e2cfff9b47c3cb34b2541240b6e
parentVersion bump. (diff)
downloadgentoo-2-ba61d7fce937582d9db6786b54dd22216d533c90.tar.gz
gentoo-2-ba61d7fce937582d9db6786b54dd22216d533c90.tar.bz2
gentoo-2-ba61d7fce937582d9db6786b54dd22216d533c90.zip
Version bump. Add USE=graph (bug #517238).
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
-rw-r--r--dev-ruby/rrdtool-bindings/ChangeLog11
-rw-r--r--dev-ruby/rrdtool-bindings/files/rrdtool-bindings-1.4.8-graph-ruby.patch70
-rw-r--r--dev-ruby/rrdtool-bindings/metadata.xml3
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r2.ebuild (renamed from dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r1.ebuild)19
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.9.ebuild58
5 files changed, 156 insertions, 5 deletions
diff --git a/dev-ruby/rrdtool-bindings/ChangeLog b/dev-ruby/rrdtool-bindings/ChangeLog
index e34fd30f1031..6b6dfd82de25 100644
--- a/dev-ruby/rrdtool-bindings/ChangeLog
+++ b/dev-ruby/rrdtool-bindings/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-ruby/rrdtool-bindings
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rrdtool-bindings/ChangeLog,v 1.13 2014/09/20 21:13:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rrdtool-bindings/ChangeLog,v 1.14 2014/10/04 09:35:45 jer Exp $
+
+*rrdtool-bindings-1.4.9 (04 Oct 2014)
+*rrdtool-bindings-1.4.8-r2 (04 Oct 2014)
+
+ 04 Oct 2014; Jeroen Roovers <jer@gentoo.org>
+ -rrdtool-bindings-1.4.8-r1.ebuild, +rrdtool-bindings-1.4.8-r2.ebuild,
+ +rrdtool-bindings-1.4.9.ebuild,
+ +files/rrdtool-bindings-1.4.8-graph-ruby.patch, metadata.xml:
+ Version bump. Add USE=graph (bug #517238).
20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> rrdtool-bindings-1.4.8.ebuild:
Stable for ppc, wrt bug #517234
diff --git a/dev-ruby/rrdtool-bindings/files/rrdtool-bindings-1.4.8-graph-ruby.patch b/dev-ruby/rrdtool-bindings/files/rrdtool-bindings-1.4.8-graph-ruby.patch
new file mode 100644
index 000000000000..8c26ce48cfb3
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/files/rrdtool-bindings-1.4.8-graph-ruby.patch
@@ -0,0 +1,70 @@
+--- a/bindings/ruby/main.c
++++ b/bindings/ruby/main.c
+@@ -216,13 +216,14 @@
+ return rb_rrd_infocall(rrd_update_v, args);
+ }
+
++#ifdef HAVE_RRD_GRAPH
+ VALUE rb_rrd_graphv(
+ VALUE self,
+ VALUE args)
+ {
+ return rb_rrd_infocall(rrd_graph_v, args);
+ }
+-
++#endif /* HAVE_RRD_GRAPH */
+
+ /* Other Calls */
+
+@@ -273,6 +274,7 @@
+ return result;
+ }
+
++#ifdef HAVE_RRD_GRAPH
+ VALUE rb_rrd_graph(
+ VALUE self,
+ VALUE args)
+@@ -302,7 +304,7 @@
+ rb_ary_store(result, 2, INT2FIX(ysize));
+ return result;
+ }
+-
++#endif /* HAVE_RRD_GRAPH */
+
+ VALUE rb_rrd_last(
+ VALUE self,
+@@ -320,6 +322,7 @@
+ return rb_funcall(rb_cTime, rb_intern("at"), 1, UINT2NUM(last));
+ }
+
++#ifdef HAVE_RRD_GRAPH
+ VALUE rb_rrd_xport(
+ VALUE self,
+ VALUE args)
+@@ -367,6 +370,7 @@
+ rb_ary_store(result, 5, rdata);
+ return result;
+ }
++#endif /* HAVE_RRD_GRAPH */
+
+ void Init_RRD(
+ )
+@@ -377,7 +381,9 @@
+ rb_define_module_function(mRRD, "create", rb_rrd_create, -2);
+ rb_define_module_function(mRRD, "dump", rb_rrd_dump, -2);
+ rb_define_module_function(mRRD, "fetch", rb_rrd_fetch, -2);
++#ifdef HAVE_RRD_GRAPH
+ rb_define_module_function(mRRD, "graph", rb_rrd_graph, -2);
++#endif /* HAVE_RRD_GRAPH */
+ rb_define_module_function(mRRD, "last", rb_rrd_last, -2);
+ rb_define_module_function(mRRD, "resize", rb_rrd_resize, -2);
+ rb_define_module_function(mRRD, "restore", rb_rrd_restore, -2);
+@@ -386,6 +392,8 @@
+ rb_define_module_function(mRRD, "flushcached", rb_rrd_flushcached, -2);
+ rb_define_module_function(mRRD, "info", rb_rrd_info, -2);
+ rb_define_module_function(mRRD, "updatev", rb_rrd_updatev, -2);
++#ifdef HAVE_RRD_GRAPH
+ rb_define_module_function(mRRD, "graphv", rb_rrd_graphv, -2);
+ rb_define_module_function(mRRD, "xport", rb_rrd_xport, -2);
++#endif /* HAVE_RRD_GRAPH */
+ }
diff --git a/dev-ruby/rrdtool-bindings/metadata.xml b/dev-ruby/rrdtool-bindings/metadata.xml
index fb22d6691302..8e9d89ef099b 100644
--- a/dev-ruby/rrdtool-bindings/metadata.xml
+++ b/dev-ruby/rrdtool-bindings/metadata.xml
@@ -3,4 +3,7 @@
<pkgmetadata>
<herd>ruby</herd>
<herd>netmon</herd>
+<use>
+<flag name='graph'>Enable support for graphing functions</flag>
+</use>
</pkgmetadata>
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r1.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r2.ebuild
index 0bd8ea9ba251..a769c41436a6 100644
--- a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r1.ebuild
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r1.ebuild,v 1.2 2014/08/05 16:00:45 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.8-r2.ebuild,v 1.1 2014/10/04 09:35:45 jer Exp $
EAPI="5"
@@ -20,14 +20,25 @@ RUBY_S="$MY_P"/bindings/ruby
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="graph test"
+REQUIRED_USE="test? ( graph )"
# Block on older versions of rrdtool that install the bindings themselves.
# requires rrd_xport which requires rrd_graph
-RDEPEND="${RDEPEND} net-analyzer/rrdtool[graph] !!<net-analyzer/rrdtool-1.4.8-r1"
-DEPEND="${DEPEND} net-analyzer/rrdtool[graph]"
+RDEPEND="
+ ~net-analyzer/rrdtool-${PV}[graph=]
+"
+DEPEND="
+ test? ( ~net-analyzer/rrdtool-${PV}[graph] )
+"
+
+RUBY_PATCHES=(
+ "${FILESDIR}"/${P}-graph-ruby.patch
+)
each_ruby_configure() {
- ${RUBY} extconf.rb || die
+ ${RUBY} extconf.rb \
+ --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH '')" || die
}
each_ruby_compile() {
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.9.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.9.ebuild
new file mode 100644
index 000000000000..435a6408995a
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.4.9.ebuild,v 1.1 2014/10/04 09:35:45 jer Exp $
+
+EAPI="5"
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-ng
+
+MY_P=${P/-bindings}
+
+DESCRIPTION="Ruby bindings for rrdtool"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${MY_P}.tar.gz"
+RUBY_S="$MY_P"/bindings/ruby
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="graph test"
+REQUIRED_USE="test? ( graph )"
+
+# Block on older versions of rrdtool that install the bindings themselves.
+# requires rrd_xport which requires rrd_graph
+RDEPEND="
+ ~net-analyzer/rrdtool-${PV}[graph=]
+"
+DEPEND="
+ test? ( ~net-analyzer/rrdtool-${PV}[graph] )
+"
+
+RUBY_PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
+)
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb \
+ --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH '')" || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_test() {
+ ${RUBY} -I. test.rb || die
+}
+
+all_ruby_install() {
+ dodoc CHANGES README
+}
+
+each_ruby_install() {
+ DESTDIR=${D} emake install
+}