summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-28 12:05:55 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-28 12:05:55 +0000
commitbc4d7daabd036728fc8aa55fca9b155f1dd7e418 (patch)
treebb2018fa9259f8bf8df36f12a4a6758fb28ac68a
parentTake maintainership of package (diff)
downloadgentoo-2-bc4d7daabd036728fc8aa55fca9b155f1dd7e418.tar.gz
gentoo-2-bc4d7daabd036728fc8aa55fca9b155f1dd7e418.tar.bz2
gentoo-2-bc4d7daabd036728fc8aa55fca9b155f1dd7e418.zip
Linux patch 3.15-rc3.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
-rw-r--r--sys-kernel/git-sources/ChangeLog7
-rw-r--r--sys-kernel/git-sources/git-sources-3.15_rc3.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-kernel/git-sources/ChangeLog b/sys-kernel/git-sources/ChangeLog
index 373b59b19da4..839098dd73e6 100644
--- a/sys-kernel/git-sources/ChangeLog
+++ b/sys-kernel/git-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/git-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1382 2014/04/21 19:14:19 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1383 2014/04/28 12:05:55 tomwij Exp $
+
+*git-sources-3.15_rc3 (28 Apr 2014)
+
+ 28 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +git-sources-3.15_rc3.ebuild:
+ Linux patch 3.15-rc3.
21 Apr 2014; Mike Pagano <mpagano@gentoo.org> git-sources-3.15_rc1.ebuild,
git-sources-3.15_rc2.ebuild:
diff --git a/sys-kernel/git-sources/git-sources-3.15_rc3.ebuild b/sys-kernel/git-sources/git-sources-3.15_rc3.ebuild
new file mode 100644
index 000000000000..0a3911aed280
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-3.15_rc3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-3.15_rc3.ebuild,v 1.1 2014/04/28 12:05:55 tomwij Exp $
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE=0
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.1-r3"
+
+pkg_postinst() {
+ postinst_sources
+}