summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-25 00:14:19 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-25 00:14:19 +0000
commitbc657170bfe8f4c0748306126bdad2621fc06915 (patch)
tree9f497c8655f07dc0ae17549fd49f904b6b733f35
parentMask new clutter/cogl/clutter-gtk (diff)
downloadgentoo-2-bc657170bfe8f4c0748306126bdad2621fc06915.tar.gz
gentoo-2-bc657170bfe8f4c0748306126bdad2621fc06915.tar.bz2
gentoo-2-bc657170bfe8f4c0748306126bdad2621fc06915.zip
Apply pax marking conditionally based on introspection and jit USE flags (thanks to Maxim Kammerer, bugs #404215 and #407085). Apply pax marking to test suite executables so the test suite can be run on PaX systems.
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
-rw-r--r--net-libs/webkit-gtk/ChangeLog8
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild18
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild18
3 files changed, 31 insertions, 13 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index da71aa0e9bdb..fb5a3bf74ebb 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.146 2012/03/17 19:22:58 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.147 2012/03/25 00:14:19 tetromino Exp $
+
+ 25 Mar 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ webkit-gtk-1.6.3-r200.ebuild, webkit-gtk-1.6.3-r300.ebuild:
+ Apply pax marking conditionally based on introspection and jit USE flags
+ (thanks to Maxim Kammerer, bugs #404215 and #407085). Apply pax marking to
+ test suite executables so the test suite can be run on PaX systems.
17 Mar 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
webkit-gtk-1.6.1-r201.ebuild, webkit-gtk-1.6.1-r301.ebuild,
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild
index 7c16d5327cc3..ab54e58b8c9b 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild,v 1.5 2012/03/17 19:22:58 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.3-r200.ebuild,v 1.6 2012/03/25 00:14:19 tetromino Exp $
EAPI="4"
@@ -55,8 +55,9 @@ DEPEND="${RDEPEND}
dev-util/gperf
dev-util/pkgconfig
dev-util/gtk-doc-am
- sys-apps/paxctl
- test? ( x11-themes/hicolor-icon-theme )
+ introspection? ( jit? ( sys-apps/paxctl ) )
+ test? ( x11-themes/hicolor-icon-theme
+ jit? ( sys-apps/paxctl ) )
"
S="${WORKDIR}/${MY_P}"
@@ -98,8 +99,10 @@ src_prepare() {
mkdir -p DerivedSources/ANGLE
# Build-time segfaults under PaX with USE="introspection jit", bug #404215
- epatch "${FILESDIR}/${PN}-1.6.3-paxctl-introspection.patch"
- cp "${FILESDIR}/gir-paxctl-lt-wrapper" "${S}/" || die
+ if use introspection && use jit; then
+ epatch "${FILESDIR}/${PN}-1.6.3-paxctl-introspection.patch"
+ cp "${FILESDIR}/gir-paxctl-lt-wrapper" "${S}/" || die
+ fi
# We need to reset some variables to prevent permissions problems and failures
# like https://bugs.webkit.org/show_bug.cgi?id=35471 and bug #323669
@@ -146,6 +149,9 @@ src_configure() {
}
src_test() {
+ # Prevents test failures on PaX systems
+ use jit && pax-mark m $(list-paxables Programs/unittests/test*) \
+ Programs/unittests/.libs/test*
unset DISPLAY
# Tests need virtualx, bug #294691, bug #310695
# Parallel tests sometimes fail
@@ -164,5 +170,5 @@ src_install() {
find "${D}" -name '*.la' -exec rm -f '{}' +
# Prevents crashes on PaX systems
- pax-mark m "${ED}usr/bin/jsc-1"
+ use jit && pax-mark m "${ED}usr/bin/jsc-1"
}
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild
index 5dcedce5ff2e..66524ba7e1d1 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild,v 1.6 2012/03/17 19:22:58 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.3-r300.ebuild,v 1.7 2012/03/25 00:14:19 tetromino Exp $
EAPI="4"
@@ -56,8 +56,9 @@ DEPEND="${RDEPEND}
dev-util/gperf
dev-util/pkgconfig
dev-util/gtk-doc-am
- sys-apps/paxctl
- test? ( x11-themes/hicolor-icon-theme )
+ introspection? ( jit? ( sys-apps/paxctl ) )
+ test? ( x11-themes/hicolor-icon-theme
+ jit? ( sys-apps/paxctl ) )
"
S="${WORKDIR}/${MY_P}"
@@ -90,8 +91,10 @@ src_prepare() {
mkdir -p DerivedSources/ANGLE
# Build-time segfaults under PaX with USE="introspection jit", bug #404215
- epatch "${FILESDIR}/${PN}-1.6.3-paxctl-introspection.patch"
- cp "${FILESDIR}/gir-paxctl-lt-wrapper" "${S}/" || die
+ if use introspection && use jit; then
+ epatch "${FILESDIR}/${PN}-1.6.3-paxctl-introspection.patch"
+ cp "${FILESDIR}/gir-paxctl-lt-wrapper" "${S}/" || die
+ fi
# We need to reset some variables to prevent permissions problems and failures
# like https://bugs.webkit.org/show_bug.cgi?id=35471 and bug #323669
@@ -140,6 +143,9 @@ src_configure() {
}
src_test() {
+ # Prevents test failures on PaX systems
+ use jit && pax-mark m $(list-paxables Programs/unittests/test*) \
+ Programs/unittests/.libs/test*
unset DISPLAY
# Tests need virtualx, bug #294691, bug #310695
# Parallel tests sometimes fail
@@ -164,5 +170,5 @@ src_install() {
find "${D}" -name '*.la' -exec rm -f '{}' +
# Prevents crashes on PaX systems
- pax-mark m "${ED}usr/bin/jsc-3"
+ use jit && pax-mark m "${ED}usr/bin/jsc-3"
}