summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-01-03 12:30:15 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-01-03 12:30:15 +0000
commitbc8d3f66ce0a7f1bdc099c3d13bfd02c6f431f2a (patch)
tree55736da4621042d23786c147105767b6aa990eab
parentbump to 6.4.8.3, bug #252956 (diff)
downloadgentoo-2-bc8d3f66ce0a7f1bdc099c3d13bfd02c6f431f2a.tar.gz
gentoo-2-bc8d3f66ce0a7f1bdc099c3d13bfd02c6f431f2a.tar.bz2
gentoo-2-bc8d3f66ce0a7f1bdc099c3d13bfd02c6f431f2a.zip
version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
-rw-r--r--dev-libs/botan/ChangeLog9
-rw-r--r--dev-libs/botan/botan-1.8.0.ebuild95
2 files changed, 102 insertions, 2 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index 918e3207ec02..4c8ff5d8948b 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/botan
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.34 2008/08/30 22:01:02 dragonheart Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.35 2009/01/03 12:30:15 dragonheart Exp $
+
+*botan-1.8.0 (03 Jan 2009)
+
+ 03 Jan 2009; Daniel Black <dragonheart@gentoo.org> +botan-1.8.0.ebuild:
+ version bump
30 Aug 2008; Daniel Black <dragonheart@gentoo.org> botan-1.6.1-r1.ebuild,
botan-1.6.5.ebuild:
diff --git a/dev-libs/botan/botan-1.8.0.ebuild b/dev-libs/botan/botan-1.8.0.ebuild
new file mode 100644
index 000000000000..a9ee3473fdb8
--- /dev/null
+++ b/dev-libs/botan/botan-1.8.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.8.0.ebuild,v 1.1 2009/01/03 12:30:15 dragonheart Exp $
+
+inherit eutils multilib toolchain-funcs
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://files.randombit.net/botan/${MY_P}.tgz"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="BSD"
+IUSE="bzip2 gmp ssl threads zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ gmp? ( >=dev-libs/gmp-4.2.2 )
+ ssl? ( >=dev-libs/openssl-0.9.8g )"
+
+# configure.pl requires Getopt::Long, File::Spec, and File::Copy;
+# all seem included in dev-lang/perl ATM.
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ # Modules that should work under any semi-recent Unix
+ local modules="alloc_mmap,egd,fd_unix,posix_rt"
+
+ if useq bzip2; then modules="$modules,bzip2"; fi
+ if useq zlib; then modules="$modules,zlib"; fi
+ if useq gmp; then modules="$modules,gnump"; fi
+ if useq ssl; then modules="$modules,openssl"; fi
+ if useq threads; then modules="$modules,pthread"; fi
+
+ # This is also supported on i586+ - hope this is correct.
+ # documention says sparc though not enables because of
+ # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
+
+ # If we have assembly code for this machine, use it
+ if [ "${ARCH}" = "x86" ]; then
+ modules="$modules,mp_ia32,alg_ia32"
+ elif [ "${ARCH}" = "amd64" ]; then
+ modules="$modules,mp_amd64"
+ #modules="$modules,monty_amd64,mp_amd64,mulop_amd64"
+ elif [ "${ARCH}" = "alpha" -o "${ARCH}" = "ia64" -o \
+ "${ARCH}" = "ppc64" -o "${PROFILE_ARCH}" = "mips64" ]; then
+ modules="$modules,mp_asm64"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="$(echo ${CHOST} | cut -d - -f 1)"
+ fi
+
+ cd "${S}"
+ elog "Enabling modules: " ${modules}
+
+ # FIXME: We might actually be on *BSD or OS X...
+ ./configure.pl \
+ --prefix="${D}"/usr \
+ --libdir=/$(get_libdir) \
+ --docdir=/share/doc/ \
+ --cc=gcc \
+ --os=linux \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --with-tr1=system || \
+ --enable-modules=$modules \
+ --distable-modules=proc_walk,unix_procs,cpu_counter \
+ die "configure.pl failed"
+ emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" \
+ "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
+}
+
+src_test() {
+ chmod -R ugo+rX "${S}"
+ emake CXX="$(tc-getCXX)" check || die "emake check failed"
+ env LD_LIBRARY_PATH="${S}" ./check --validate || die "validation tests failed"
+}
+
+src_install() {
+ make install || die "make install failed"
+ sed -i -e "s:${D}::g" \
+ ${D}/usr/bin/botan-config \
+ ${D}/usr/$(get_libdir)/pkgconfig/botan-1.8.pc || die 'bad sed'
+ mv "${D}"/usr/share/doc/Botan-${PV} "${D}"/usr/share/doc/${PF} || \
+ die 'could not rename directory'
+}