summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-10-22 17:30:26 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-10-22 17:30:26 +0000
commitbd1867e063c5a7a126c0bdfcdf2031a9798d5ece (patch)
treeb407fad7d73f1d564d9e440b0fc8e73560f51f49
parentRemoving vulnerable older versions (bug #336462 et. al.) (diff)
downloadgentoo-2-bd1867e063c5a7a126c0bdfcdf2031a9798d5ece.tar.gz
gentoo-2-bd1867e063c5a7a126c0bdfcdf2031a9798d5ece.tar.bz2
gentoo-2-bd1867e063c5a7a126c0bdfcdf2031a9798d5ece.zip
Revision bump for new genpatches, version bump.
(Portage version: 2.1.9.21/cvs/Linux x86_64)
-rw-r--r--sys-kernel/ck-sources/ChangeLog11
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.34-r5.ebuild47
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.35-r5.ebuild47
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.36.ebuild47
4 files changed, 151 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index dff3cd03845b..6012abc9202a 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.182 2010/10/08 12:25:59 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.183 2010/10/22 17:30:26 nelchael Exp $
+
+*ck-sources-2.6.36 (22 Oct 2010)
+*ck-sources-2.6.35-r5 (22 Oct 2010)
+*ck-sources-2.6.34-r5 (22 Oct 2010)
+
+ 22 Oct 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +ck-sources-2.6.34-r5.ebuild, +ck-sources-2.6.35-r5.ebuild,
+ +ck-sources-2.6.36.ebuild:
+ Revision bump for new genpatches, version bump.
*ck-sources-2.6.35-r4 (08 Oct 2010)
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.34-r5.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.34-r5.ebuild
new file mode 100644
index 000000000000..02edb9d505d7
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.34-r5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.34-r5.ebuild,v 1.1 2010/10/22 17:30:26 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="14"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+CK_REVISION="1"
+K_SECURITY_UNSUPPORTED="1"
+
+if [[ -z "${CK_REVISION}" ]]; then
+ CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+else
+ # This is ck${CK_VERSION} but resynced to apply cleanly to stable kernel
+ # release:
+ CK_URI="mirror://gentoo/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+fi
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.35-r5.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.35-r5.ebuild
new file mode 100644
index 000000000000..dcaefa18cc80
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.35-r5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.35-r5.ebuild,v 1.1 2010/10/22 17:30:26 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="12"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+CK_REVISION=""
+K_SECURITY_UNSUPPORTED="1"
+
+if [[ -z "${CK_REVISION}" ]]; then
+ CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+else
+ # This is ck${CK_VERSION} but resynced to apply cleanly to stable kernel
+ # release:
+ CK_URI="mirror://gentoo/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+fi
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.36.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.36.ebuild
new file mode 100644
index 000000000000..0e7d653f4717
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.36.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.36.ebuild,v 1.1 2010/10/22 17:30:26 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+CK_REVISION=""
+K_SECURITY_UNSUPPORTED="1"
+
+if [[ -z "${CK_REVISION}" ]]; then
+ CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+else
+ # This is ck${CK_VERSION} but resynced to apply cleanly to stable kernel
+ # release:
+ CK_URI="mirror://gentoo/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+fi
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}