summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-07 21:33:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-07 21:33:17 +0000
commitc217b2930af59ee0ee6b7826c054ec6c37689626 (patch)
treef88fa260f0386c591ece7f3c57d61818eaa6a5d3
parentfix manifest (diff)
downloadgentoo-2-c217b2930af59ee0ee6b7826c054ec6c37689626.tar.gz
gentoo-2-c217b2930af59ee0ee6b7826c054ec6c37689626.tar.bz2
gentoo-2-c217b2930af59ee0ee6b7826c054ec6c37689626.zip
Bump to 1.4.3, part of bug #254781
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--sci-libs/libgeda/ChangeLog9
-rw-r--r--sci-libs/libgeda/libgeda-1.4.3.ebuild73
2 files changed, 80 insertions, 2 deletions
diff --git a/sci-libs/libgeda/ChangeLog b/sci-libs/libgeda/ChangeLog
index a0bfb6bdcb16..d73eda9e4c3b 100644
--- a/sci-libs/libgeda/ChangeLog
+++ b/sci-libs/libgeda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libgeda
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.46 2008/12/01 14:18:26 calchan Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.47 2009/03/07 21:33:17 patrick Exp $
+
+*libgeda-1.4.3 (07 Mar 2009)
+
+ 07 Mar 2009; Patrick Lauer <patrick@gentoo.org> +libgeda-1.4.3.ebuild:
+ Bump to 1.4.3, part of bug #254781
*libgeda-1.4.1 (30 Nov 2008)
diff --git a/sci-libs/libgeda/libgeda-1.4.3.ebuild b/sci-libs/libgeda/libgeda-1.4.3.ebuild
new file mode 100644
index 000000000000..68cfb1b0ab58
--- /dev/null
+++ b/sci-libs/libgeda/libgeda-1.4.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.4.3.ebuild,v 1.1 2009/03/07 21:33:17 patrick Exp $
+
+inherit eutils fdo-mime versionator
+
+SUBDIR="v$(get_version_component_range 1-2)"
+
+HOMEPAGE="http://www.geda.seul.org"
+DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
+SRC_URI="http://www.geda.seul.org/release/${SUBDIR}/${PV}/libgeda-${PV}.tar.gz"
+
+IUSE="gd threads"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ >=dev-scheme/guile-1.6.3
+ >=dev-libs/libstroke-0.5.1
+ gd? ( >=media-libs/gd-2 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if has_version ">=dev-scheme/guile-1.8" ; then
+ built_with_use "dev-scheme/guile" deprecated \
+ || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
+ fi
+ if use gd ; then
+ built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Skip the share sub-directory, we'll install prolog.ps manually
+ sed -i \
+ -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
+ "${S}"/Makefile.in \
+ || die "Patch failed"
+}
+
+src_compile() {
+ local myconf="--disable-threads"
+ use threads || myconf="--enable-threads=posix"
+ econf \
+ ${myconf} \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-update-mime-database \
+ --with-x \
+ $(use_enable gd) \
+ || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ insinto /usr/share/gEDA
+ doins share/prolog.ps
+
+ dodoc AUTHORS BUGS ChangeLog README
+}
+
+src_postinst() {
+ fdo-mime_mime_database_update
+}
+
+src_postrm() {
+ fdo-mime_mime_database_update
+}