summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-06 13:53:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-06 13:53:50 +0000
commitc25bcc3991bc3130bd2e975f4c0a09301e2c1d9f (patch)
treef0ce0d43954200bd9239c2c94b6d189d517656e6
parentAdd pax-marking of plugin-container, bug #326715 (diff)
downloadgentoo-2-c25bcc3991bc3130bd2e975f4c0a09301e2c1d9f.tar.gz
gentoo-2-c25bcc3991bc3130bd2e975f4c0a09301e2c1d9f.tar.bz2
gentoo-2-c25bcc3991bc3130bd2e975f4c0a09301e2c1d9f.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog9
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.3.ebuild45
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.3-asneeded.patch22
3 files changed, 75 insertions, 1 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 82d1f8656e6a..2253095859f2 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.99 2010/07/31 19:42:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.100 2010/08/06 13:53:50 ssuominen Exp $
+
+*ffmpegthumbnailer-2.0.3 (06 Aug 2010)
+
+ 06 Aug 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +ffmpegthumbnailer-2.0.3.ebuild,
+ +files/ffmpegthumbnailer-2.0.3-asneeded.patch:
+ Version bump.
31 Jul 2010; Raúl Porcel <armin76@gentoo.org>
ffmpegthumbnailer-2.0.2.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.3.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.3.ebuild
new file mode 100644
index 000000000000..a74a7a3ecff4
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.3.ebuild,v 1.1 2010/08/06 13:53:50 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnome jpeg png"
+
+COMMON_DEPEND=">=media-video/ffmpeg-0.5
+ png? ( >=media-libs/libpng-1.4 )
+ jpeg? ( virtual/jpeg )"
+RDEPEND="${COMMON_DEPEND}
+ gnome? ( >=gnome-base/gnome-vfs-2 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ if use gnome; then
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable gnome gnome-vfs)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+ find "${D}" -name '*.la' -delete
+}
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.3-asneeded.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.3-asneeded.patch
new file mode 100644
index 000000000000..0a069254e882
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.3-asneeded.patch
@@ -0,0 +1,22 @@
+--- configure.ac
++++ configure.ac
+@@ -77,6 +77,8 @@
+ [ ENABLE_GNOME_VFS=$enableval ] )
+
+ if test "$ENABLE_GNOME_VFS" = "yes"; then
++ AC_CHECK_LIB([dl], [dlopen], DL_LIBS="-ldl")
++ AC_SUBST(DL_LIBS)
+ AC_DEFINE(HAVE_GNOME_VFS, [], "Gnome-vfs file uri support enabled")
+ fi
+
+--- Makefile.am
++++ Makefile.am
+@@ -39,7 +39,7 @@
+ libffmpegthumbnailer_includedir = $(includedir)/libffmpegthumbnailer
+ libffmpegthumbnailer_la_CXXFLAGS = $(AM_CXXFLAGS) $(FFMPEG_CFLAGS) $(PNG_CFLAGS)
+ libffmpegthumbnailer_la_LDFLAGS = -version-info 4:3:0
+-libffmpegthumbnailer_la_LIBADD = $(FFMPEG_LIBS) $(PNG_LIBS) $(JPEG_LIBS)
++libffmpegthumbnailer_la_LIBADD = $(DL_LIBS) $(FFMPEG_LIBS) $(PNG_LIBS) $(JPEG_LIBS)
+
+ bin_PROGRAMS = ffmpegthumbnailer
+