summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-13 13:29:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-13 13:29:07 +0000
commitc37b1ae4865809baa0e271b6c878e85fe95e9574 (patch)
tree4f2abc20b048fd5f3cfed8f324fd891c81013bdf
parentx86 stable, bug 327777 (diff)
downloadgentoo-2-c37b1ae4865809baa0e271b6c878e85fe95e9574.tar.gz
gentoo-2-c37b1ae4865809baa0e271b6c878e85fe95e9574.tar.bz2
gentoo-2-c37b1ae4865809baa0e271b6c878e85fe95e9574.zip
Version bump wrt #225277 by Didier Link.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--app-pda/jpilot/ChangeLog9
-rw-r--r--app-pda/jpilot/jpilot-1.8.0.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/app-pda/jpilot/ChangeLog b/app-pda/jpilot/ChangeLog
index a8bfaf67d3c8..d59ff80300a3 100644
--- a/app-pda/jpilot/ChangeLog
+++ b/app-pda/jpilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/jpilot
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/ChangeLog,v 1.37 2008/05/21 12:44:39 drac Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/ChangeLog,v 1.38 2010/07/13 13:29:07 ssuominen Exp $
+
+*jpilot-1.8.0 (13 Jul 2010)
+
+ 13 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> +jpilot-1.8.0.ebuild:
+ Version bump wrt #225277 by Didier Link.
21 May 2008; Samuli Suominen <drac@gentoo.org> jpilot-0.99.9.ebuild:
Move gettext and pkgconfig to DEPEND.
diff --git a/app-pda/jpilot/jpilot-1.8.0.ebuild b/app-pda/jpilot/jpilot-1.8.0.ebuild
new file mode 100644
index 000000000000..e9da4ce95aed
--- /dev/null
+++ b/app-pda/jpilot/jpilot-1.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot/jpilot-1.8.0.ebuild,v 1.1 2010/07/13 13:29:07 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+HOMEPAGE="http://www.jpilot.org/"
+SRC_URI="http://www.jpilot.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-pda/pilot-link-0.12.5
+ dev-libs/libgcrypt
+ >=x11-libs/gtk+-2.18.9:2"
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool
+ sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e "/^Icon/s:jpilot.xpm:/usr/share/pixmaps/jpilot/jpilot-icon1.xpm:" \
+ jpilot.desktop || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ icondir="/usr/share/pixmaps/${PN}" \
+ miscdir="/usr/share/doc/${PF}" \
+ install || die
+
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL} \
+ "${D}"/usr/share/pixmaps/${PN}/README
+
+ find "${D}" -name '*.la' -delete
+}