summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-02-12 19:01:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-02-12 19:01:50 +0000
commitc7b5f61d6abf8fa4a3e30ec3ff849889c881192a (patch)
treea8933bb2fa78a4d131aa1e5ce33c8bd281f74698
parentold (diff)
downloadgentoo-2-c7b5f61d6abf8fa4a3e30ec3ff849889c881192a.tar.gz
gentoo-2-c7b5f61d6abf8fa4a3e30ec3ff849889c881192a.tar.bz2
gentoo-2-c7b5f61d6abf8fa4a3e30ec3ff849889c881192a.zip
old
(Portage version: 2.1.3.19)
-rw-r--r--games-action/btanks/btanks-0.5.4740-r1.ebuild58
-rw-r--r--games-action/btanks/files/btanks-0.5.4740-scons-blows.patch54
2 files changed, 0 insertions, 112 deletions
diff --git a/games-action/btanks/btanks-0.5.4740-r1.ebuild b/games-action/btanks/btanks-0.5.4740-r1.ebuild
deleted file mode 100644
index 34bd12b80b26..000000000000
--- a/games-action/btanks/btanks-0.5.4740-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.5.4740-r1.ebuild,v 1.4 2008/01/17 06:57:38 tupone Exp $
-
-inherit eutils games
-
-DESCRIPTION="Fast 2D tank arcade game with multiplayer and split-screen modes"
-HOMEPAGE="http://btanks.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-libs/libsigc++-2.0
- media-libs/openal
- media-libs/libsdl
- media-libs/libvorbis
- virtual/opengl
- dev-libs/expat
- media-libs/sdl-image"
-DEPEND="${RDEPEND}
- dev-util/scons
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-scons-blows.patch
-}
-
-src_compile() {
- scons \
- mode="release" \
- prefix=/usr \
- lib_dir="$(games_get_libdir)/${PN}" \
- resources_dir="${GAMES_DATADIR}/${PN}" \
- || die "scons"
-}
-
-src_install() {
- newgamesbin bt btanks || die "newgamesbin"
-
- insinto "$(games_get_libdir)"/${PN}
- doins lib{mrt,bt,sdlx}.so || die "doins for lib.so failed"
-
- exeinto "${GAMES_DATADIR}/${PN}"
- doexe libbt_objects.so || die "doins for libbt_objects.so failed"
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r data || die "doins for data failed"
- dodoc ChangeLog *.txt
-
- newicon src/bt.xpm ${PN}.xpm || die "newicon"
- make_desktop_entry ${PN} "Battle Tanks" ${PN}.xpm
-
- prepgamesdirs
-}
diff --git a/games-action/btanks/files/btanks-0.5.4740-scons-blows.patch b/games-action/btanks/files/btanks-0.5.4740-scons-blows.patch
deleted file mode 100644
index 1290bb5b98e0..000000000000
--- a/games-action/btanks/files/btanks-0.5.4740-scons-blows.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Respect env build settings, dont force crappy flags, and make sure -rpath is added properly.
-
---- SConstruct
-+++ SConstruct
-@@ -41,6 +41,18 @@
- debug = buildmode == "debug"
- Export('debug')
-
-+import SCons.Util
-+if os.environ.has_key('CC'):
-+ env['CC'] = os.environ['CC']
-+if os.environ.has_key('CFLAGS'):
-+ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
-+if os.environ.has_key('CXX'):
-+ env['CXX'] = os.environ['CXX']
-+if os.environ.has_key('CXXFLAGS'):
-+ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
-+if os.environ.has_key('LDFLAGS'):
-+ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
-+
- if (env['gcc_visibility']):
- env.Append(CCFLAGS=' -fvisibility-inlines-hidden -fvisibility=hidden -DGCC_HASCLASSVISIBILITY ')
- env.Append(CXXFLAGS=' -fvisibility-inlines-hidden -fvisibility=hidden -DGCC_HASCLASSVISIBILITY ')
-@@ -81,16 +81,10 @@
- if env['gcc_visibility']:
- env.Append(CCFLAGS=' -fvisibility-inlines-hidden -fvisibility=hidden ');
- env.Append(CPPFLAGS=' -fvisibility-inlines-hidden -fvisibility=hidden ');
-- if debug:
-- env.Append(CCFLAGS='-ggdb ')
-- env.Append(CPPFLAGS='-ggdb ')
-- else:
-- env.Append(CCFLAGS='-O3 ')
-- env.Append(CPPFLAGS='-O3 ')
-
- al_lib = 'openal'
-- env.Append(CPPFLAGS=' -Wall -pedantic -Wno-long-long -pipe -pthread ')
-- env.Append(CCFLAGS=' -Wall -pedantic -Wno-long-long -pipe -pthread ')
-+ env.Append(CPPFLAGS=' -Wall -pedantic -Wno-long-long -pthread ')
-+ env.Append(CCFLAGS=' -Wall -pedantic -Wno-long-long -pthread ')
-
-
- conf_env = env.Copy()
---- SConscript
-+++ SConscript
-@@ -94,7 +94,7 @@
-
- Import('lib_dir')
- if sys.platform != 'win32':
-- bt_env.Append(LINKFLAGS=' -Wl,-rpath '+ lib_dir + ' -Wl,-rpath-link build/' + env['mode'] + '/mrt')
-- bt_env.Append(LINKFLAGS=' -Wl,-rpath '+ lib_dir + ' -Wl,-rpath-link build/' + env['mode'] + '/sdlx')
-+ bt_env.Append(LINKFLAGS=' -Wl,-rpath,'+ lib_dir + ' -Wl,-rpath-link,build/' + env['mode'] + '/mrt')
-+ bt_env.Append(LINKFLAGS=' -Wl,-rpath,'+ lib_dir + ' -Wl,-rpath-link,build/' + env['mode'] + '/sdlx')
-
- bt_main = bt_env.Program('bt', bt_main_sources, LIBS=bt_main_libs, RPATH=[lib_dir])