summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-07-31 22:36:54 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-07-31 22:36:54 +0000
commitc8040e4530a2adff904928c9ce32ba6f33fafdb4 (patch)
tree59dce3e45e9b49f3584cd5873f4c4c946b4c68c2
parentmerkaartor add nls support to svn ebuild (diff)
downloadgentoo-2-c8040e4530a2adff904928c9ce32ba6f33fafdb4.tar.gz
gentoo-2-c8040e4530a2adff904928c9ce32ba6f33fafdb4.tar.bz2
gentoo-2-c8040e4530a2adff904928c9ce32ba6f33fafdb4.zip
Force the use of sci-libs/gsl to avoid accidental generation of x86 assembly code on non x86 architectures (see bug #233318).
(Portage version: 2.2_rc3/cvs/Linux 2.6.26-SENTINEL-1 i686)
-rw-r--r--x11-misc/xaos/ChangeLog6
-rw-r--r--x11-misc/xaos/xaos-3.2.ebuild20
-rw-r--r--x11-misc/xaos/xaos-3.4.ebuild17
3 files changed, 27 insertions, 16 deletions
diff --git a/x11-misc/xaos/ChangeLog b/x11-misc/xaos/ChangeLog
index c6794a321426..772cf4cf9e51 100644
--- a/x11-misc/xaos/ChangeLog
+++ b/x11-misc/xaos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xaos
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/ChangeLog,v 1.27 2008/07/23 21:27:09 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/ChangeLog,v 1.28 2008/07/31 22:36:54 markusle Exp $
+
+ 31 Jul 2008; Markus Dittrich <markusle@gentoo.org> xaos-3.4.ebuild:
+ Force the use of sci-libs/gsl to avoid accidental generation of x86
+ assembly code on non x86 architectures (see bug #233318).
*xaos-3.4 (23 Jul 2008)
diff --git a/x11-misc/xaos/xaos-3.2.ebuild b/x11-misc/xaos/xaos-3.2.ebuild
index f2ae5bfdfebd..4bc91cf996ca 100644
--- a/x11-misc/xaos/xaos-3.2.ebuild
+++ b/x11-misc/xaos/xaos-3.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.2.ebuild,v 1.6 2007/06/22 07:05:55 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.2.ebuild,v 1.7 2008/07/31 22:36:54 markusle Exp $
inherit eutils
@@ -62,16 +62,16 @@ src_compile() {
src_install() {
# these get installed, assuming that the directories exist!
- mkdir -p ${D}/usr/share/locale/{hu,es,fr,cs,de}/LC_MESSAGES
- mkdir -p ${D}/usr/share/{man,info}
+ mkdir -p "${D}"/usr/share/locale/{hu,es,fr,cs,de}/LC_MESSAGES
+ mkdir -p "${D}"/usr/share/{man,info}
make \
- prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- LOCALEDIR=${D}/usr/share/locale \
+ prefix="${D}"/usr \
+ infodir="${D}"/usr/share/info \
+ mandir="${D}"/usr/share/man \
+ LOCALEDIR="${D}"/usr/share/locale \
install || die
- use nls || rm -r ${D}/usr/share/locale
+ use nls || rm -r "${D}"/usr/share/locale
- dodoc ChangeLog* COPYING INSTALL* TODO*
+ dodoc ChangeLog* INSTALL* TODO*
}
diff --git a/x11-misc/xaos/xaos-3.4.ebuild b/x11-misc/xaos/xaos-3.4.ebuild
index e3a63f80adbd..4f06dc885270 100644
--- a/x11-misc/xaos/xaos-3.4.ebuild
+++ b/x11-misc/xaos/xaos-3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.4.ebuild,v 1.1 2008/07/23 21:27:09 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.4.ebuild,v 1.2 2008/07/31 22:36:54 markusle Exp $
IUSE="aalib nls png svga threads X"
@@ -27,7 +27,8 @@ RDEPEND="X? (
svga? ( >=media-libs/svgalib-1.4.3 )
aalib? ( media-libs/aalib )
png? ( media-libs/libpng )
- sys-libs/zlib"
+ sys-libs/zlib
+ sci-libs/gsl"
# xaos has ggi support, but it doesn't build
# ggi? ( media-libs/libggi )
@@ -42,16 +43,22 @@ DEPEND="${RDEPEND}
)"
src_compile() {
+ local myconf="--with-sffe=yes --with-ggi-driver=no"
+
+ # make sure we use gsl and not nasm (see bug #233318)
+ myconf="${myconf} --with-i386asm=no --with-gsl=yes"
+
econf \
$(use_with png) \
$(use_with aalib aa-driver) \
$(use_with svga svga-driver) \
$(use_with threads pthread) \
$(use_with X x11-driver) \
- $(use_with X) \
+ $(use_with X x) \
$(use_enable nls) \
- --with-sffe=yes --with-ggi-driver=no || die
- emake || die
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
}
src_install() {