summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-09-03 07:33:41 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-09-03 07:33:41 +0000
commitc869af8dd6f7b7071a3142c04a68c00bc2ce87e0 (patch)
tree0cc6a6061f5e9c46ccadd6ca0c955b254c666531
parentreplace virtual/tetex with virtual/latex-base (diff)
downloadgentoo-2-c869af8dd6f7b7071a3142c04a68c00bc2ce87e0.tar.gz
gentoo-2-c869af8dd6f7b7071a3142c04a68c00bc2ce87e0.tar.bz2
gentoo-2-c869af8dd6f7b7071a3142c04a68c00bc2ce87e0.zip
replace virtual/tetex with virtual/latex-base and remove unnecessary COPYRIGHT file installation
(Portage version: 2.1.4.4)
-rw-r--r--sys-cluster/mpich2/ChangeLog7
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild86
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.3.ebuild20
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.6.ebuild128
4 files changed, 123 insertions, 118 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index c391816ca334..ccae77d37372 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.30 2008/07/28 20:19:28 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.31 2008/09/03 07:33:41 opfer Exp $
+
+ 03 Sep 2008; Christian Faulhammer <opfer@gentoo.org> mpich2-1.0.3.ebuild,
+ mpich2-1.0.3-r1.ebuild, mpich2-1.0.6.ebuild:
+ replace virtual/tetex with virtual/latex-base and remove unnecessary
+ COPYRIGHT file installation
28 Jul 2008; Panagiotis Christopoulos <pchrist@gentoo.org> metadata.xml:
Update metadata.xml to include USE flag descriptions. Entries taken from
diff --git a/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild b/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
index 7239fde92e0a..1dff0d68ed56 100644
--- a/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild,v 1.11 2008/05/29 18:07:10 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3-r1.ebuild,v 1.12 2008/09/03 07:33:41 opfer Exp $
WANT_AUTOCONF="2.5"
inherit fortran distutils eutils autotools toolchain-funcs
@@ -37,18 +37,18 @@ pkg_setup() {
einfo "Custom configure options are ${MPICH_CONFIGURE_OPTS}."
fi
if use fortran ; then
- if [ $(gcc-major-version) -ge 4 ] \
+ if [ $(gcc-major-version) -ge 4 ] \
&& built_with_use sys-devel/gcc fortran ; then
- FORTRAN="gfortran"
- fortran_pkg_setup
- else
+ FORTRAN="gfortran"
+ fortran_pkg_setup
+ else
ewarn "You need gcc-4 built with fortran support in order to"
ewarn "build the f90 mpi interface, which is required for f90"
ewarn "and mpi support in hdf5 (for example)."
- fi
+ fi
else
- einfo "Unless you have another f90 compiler installed, we can only"
- einfo "build the f77 and C++ interfaces with gcc-3.x"
+ einfo "Unless you have another f90 compiler installed, we can only"
+ einfo "build the f77 and C++ interfaces with gcc-3.x"
fi
}
@@ -56,9 +56,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
ebegin "Reconfiguring"
- find . -name configure -print | xargs rm
- ./maint/updatefiles
- use mpe-sdk && ./src/mpe2/maint/updatefiles
+ find . -name configure -print | xargs rm
+ ./maint/updatefiles
+ use mpe-sdk && ./src/mpe2/maint/updatefiles
eend
epatch "${FILESDIR}"/${P}-make.patch || die "make patch failed"
# damn, have to patch the createshlib script here...
@@ -81,23 +81,23 @@ src_compile() {
local myconf="${MPICH_CONFIGURE_OPTS}"
if ! use debug ; then
- myconf="${myconf} --enable-fast --enable-g=none"
+ myconf="${myconf} --enable-fast --enable-g=none"
else
- myconf="${myconf} --enable-g=dbg --enable-debuginfo \
+ myconf="${myconf} --enable-g=dbg --enable-debuginfo \
--enable-error-messages=all"
fi
if ! use mpe-sdk ; then
- myconf="${myconf} --enable-graphics=no --enable-rlog=no \
+ myconf="${myconf} --enable-graphics=no --enable-rlog=no \
--enable-clog=no --enable-slog2=no"
fi
use mpe && MPE_SRC_DIR="${S}"/src/mpe2
if use threads ; then
- myconf="${myconf} --with-thread-package=pthreads"
+ myconf="${myconf} --with-thread-package=pthreads"
else
- myconf="${myconf} --with-thread-package=none"
+ myconf="${myconf} --with-thread-package=none"
fi
./configure \
@@ -121,13 +121,13 @@ src_compile() {
--datadir=/usr/share/${PN} || die "configure failed"
if use mpe-sdk ; then
- "${MPE_SRC_DIR}"/configure --prefix=/usr --enable-mpich \
+ "${MPE_SRC_DIR}"/configure --prefix=/usr --enable-mpich \
--with-mpicc=mpicc --with-mpif77=mpif77 --enable-wrappers \
--enable-collchk --with-flib_path_leader="-Wl,-L"
fi
if use mpe ; then
- epatch "${FILESDIR}"/${P}-mpe-install.patch || die "install patch failed"
+ epatch "${FILESDIR}"/${P}-mpe-install.patch || die "install patch failed"
fi
# parallel makes are currently broken, so no emake...
@@ -135,29 +135,29 @@ src_compile() {
make || die "make failed"
if has test "${FEATURES}" ; then
- # get setup for src_test
- #export LDFLAGS='-L../../lib'
- export LD_LIBRARY_PATH="${S}"/lib:$LD_LIBRARY_PATH
- cd "${S}"/test/mpi
- #make clean || die "make clean failed"
- echo
- einfo "Using ./configure --prefix="${S}" --with-mpi="${S}" --disable-f90"
- echo
- ./configure --prefix="${S}" --with-mpi="${S}" $(use_enable threads) \
- --exec-prefix="${S}" --includedir="${S}"/src/include --disable-f90 \
+ # get setup for src_test
+ #export LDFLAGS='-L../../lib'
+ export LD_LIBRARY_PATH="${S}"/lib:$LD_LIBRARY_PATH
+ cd "${S}"/test/mpi
+ #make clean || die "make clean failed"
+ echo
+ einfo "Using ./configure --prefix="${S}" --with-mpi="${S}" --disable-f90"
+ echo
+ ./configure --prefix="${S}" --with-mpi="${S}" $(use_enable threads) \
+ --exec-prefix="${S}" --includedir="${S}"/src/include --disable-f90 \
|| die "configure test failed"
- make dependencies
- # make doesn't work here for some reason, although it works fine
- # when run manually. Go figure...
- #cd ${S}/test/mpi/util
- #make all || die "make util failed"
- cd "${S}"/test
- install -g portage -o portage -m 0600 "${FILESDIR}"/mpd.conf "${HOME}"/.mpd.conf
- #${S}/bin/mpd --daemon
- make all || die "make pre-test failed"
- #cd ${S}/test/mpi
- #make || die "make test failed"
- #${S}/bin/mpdallexit
+ make dependencies
+ # make doesn't work here for some reason, although it works fine
+ # when run manually. Go figure...
+ #cd ${S}/test/mpi/util
+ #make all || die "make util failed"
+ cd "${S}"/test
+ install -g portage -o portage -m 0600 "${FILESDIR}"/mpd.conf "${HOME}"/.mpd.conf
+ #${S}/bin/mpd --daemon
+ make all || die "make pre-test failed"
+ #cd ${S}/test/mpi
+ #make || die "make test failed"
+ #${S}/bin/mpdallexit
fi
}
@@ -179,7 +179,7 @@ src_install() {
dodir /etc/${PN}
rm -rf src/mpe2/etc/*.in
make install DESTDIR="${D}" \
- LIBDIR="${D}"usr/$(get_libdir) || die "make install failed"
+ LIBDIR="${D}"usr/$(get_libdir) || die "make install failed"
dodir /usr/share/${PN}
mv "${D}"usr/examples/cpi" ${D}"usr/share/${PN}/cpi
@@ -188,13 +188,13 @@ src_install() {
dodir /usr/share/doc/${PF}
if use doc; then
- dodoc COPYRIGHT README README.romio README.testing CHANGES
+ dodoc README README.romio README.testing CHANGES
dodoc README.developer RELEASE_NOTES
newdoc src/pm/mpd/README README.mpd
else
rm -rf "${D}"usr/share/doc/
rm -rf "${D}"usr/share/man/
- dodoc README CHANGES COPYRIGHT RELEASE_NOTES
+ dodoc README CHANGES RELEASE_NOTES
fi
}
diff --git a/sys-cluster/mpich2/mpich2-1.0.3.ebuild b/sys-cluster/mpich2/mpich2-1.0.3.ebuild
index cfc4917216a6..bcb0498446d1 100644
--- a/sys-cluster/mpich2/mpich2-1.0.3.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3.ebuild,v 1.13 2008/03/22 00:56:29 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3.ebuild,v 1.14 2008/09/03 07:33:41 opfer Exp $
inherit eutils autotools
@@ -33,7 +33,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
ebegin "Reconfiguring"
- ./maint/updatefiles
+ ./maint/updatefiles
eend ${ret} "Reconfigure failed"
epatch "${FILESDIR}"/${P}-make.patch || die "make patch failed"
# damn, have to patch the createshlib script here...
@@ -55,15 +55,15 @@ src_compile() {
local myconf="${MPICH_CONFIGURE_OPTS}"
if ! use debug ; then
- myconf="${myconf} --enable-fast --enable-g=none"
+ myconf="${myconf} --enable-fast --enable-g=none"
else
- myconf="${myconf} --enable-g=dbg --enable-debuginfo"
+ myconf="${myconf} --enable-g=dbg --enable-debuginfo"
fi
if use threads ; then
- myconf="${myconf} --with-thread-package=pthreads"
+ myconf="${myconf} --with-thread-package=pthreads"
else
- myconf="${myconf} --with-thread-package=none"
+ myconf="${myconf} --with-thread-package=none"
fi
WANT_AUTOCONF="2.5" \
@@ -85,7 +85,7 @@ src_compile() {
--datadir=/usr/share/mpich2 || die "configure failed"
if use mpe ; then
- epatch "${FILESDIR}"/${P}-mpe-install.patch || die "install patch failed"
+ epatch "${FILESDIR}"/${P}-mpe-install.patch || die "install patch failed"
fi
make || die "make failed"
@@ -95,7 +95,7 @@ src_install() {
dodir /etc/${PN}
rm -rf src/mpe2/etc/*.in
make install DESTDIR="${D}" LIBDIR="${D}"usr/$(get_libdir) \
- || die "make install failed"
+ || die "make install failed"
dodir /usr/share/${PN}
mv "${D}"usr/examples/cpi "${D}"usr/share/${PN}/cpi
@@ -104,12 +104,12 @@ src_install() {
dodir /usr/share/doc/${PF}
if use doc; then
- dodoc COPYRIGHT README README.romio README.testing CHANGES
+ dodoc README README.romio README.testing CHANGES
dodoc README.developer RELEASE_NOTES
newdoc src/pm/mpd/README README.mpd
else
rm -rf "${D}"usr/share/doc/
rm -rf "${D}"usr/share/man/
- dodoc README CHANGES COPYRIGHT RELEASE_NOTES
+ dodoc README CHANGES RELEASE_NOTES
fi
}
diff --git a/sys-cluster/mpich2/mpich2-1.0.6.ebuild b/sys-cluster/mpich2/mpich2-1.0.6.ebuild
index 1bce55460e2f..87a7a4c00ae9 100644
--- a/sys-cluster/mpich2/mpich2-1.0.6.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.6.ebuild,v 1.6 2008/05/29 18:07:10 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.6.ebuild,v 1.7 2008/09/03 07:33:41 opfer Exp $
WANT_AUTOCONF="2.5"
inherit autotools distutils eutils flag-o-matic fortran java-pkg-2
@@ -28,7 +28,7 @@ DEPEND="virtual/libc
pvfs2? ( >=sys-cluster/pvfs2-2.7.0 )
mpe-sdk? ( >=virtual/jdk-1.5
x11-proto/xproto )
- doc? ( virtual/tetex )"
+ doc? ( virtual/latex-base )"
RDEPEND="${DEPEND}
mpe-sdk? ( x11-libs/libX11 )
@@ -48,37 +48,37 @@ RESTRICT="test"
pkg_setup() {
if [ -n "${MPICH_CONFIGURE_OPTS}" ]; then
- elog "User-specified configure options are ${MPICH_CONFIGURE_OPTS}."
+ elog "User-specified configure options are ${MPICH_CONFIGURE_OPTS}."
else
- elog "User-specified configure options are not set."
- elog "If needed, see the docs and set MPICH_CONFIGURE_OPTS."
+ elog "User-specified configure options are not set."
+ elog "If needed, see the docs and set MPICH_CONFIGURE_OPTS."
fi
if use fortran ; then
- if [ $(gcc-major-version) -ge 4 ] \
+ if [ $(gcc-major-version) -ge 4 ] \
&& built_with_use sys-devel/gcc fortran ; then
- FORTRAN="gfortran"
- MPI_FFLAGS="-ff2c"
- fortran_pkg_setup
- else
+ FORTRAN="gfortran"
+ MPI_FFLAGS="-ff2c"
+ fortran_pkg_setup
+ else
ewarn "You need gcc-4 built with fortran support in order to"
ewarn "build the f90 mpi interface, which is required for f90"
ewarn "and mpi support in hdf5 (for example)."
FORTRAN="g77 f2c"
fortran_pkg_setup
- fi
+ fi
else
- ewarn "Unless you have another f90 compiler installed, we can only"
- ewarn "build the C and C++ interfaces with gcc-3.x"
+ ewarn "Unless you have another f90 compiler installed, we can only"
+ ewarn "build the C and C++ interfaces with gcc-3.x"
fi
if use mpe-sdk; then
- java-pkg-2_pkg_setup
- if use x86; then
+ java-pkg-2_pkg_setup
+ if use x86; then
jvmarch=i386
- else
+ else
jvmarch="${ARCH}"
- fi
+ fi
fi
}
@@ -87,9 +87,9 @@ src_unpack() {
cd "${S}"
ebegin "Reconfiguring"
- find . -name configure -print | xargs rm
- ./maint/updatefiles
- use mpe-sdk && ./src/mpe2/maint/updatefiles
+ find . -name configure -print | xargs rm
+ ./maint/updatefiles
+ use mpe-sdk && ./src/mpe2/maint/updatefiles
eend
# a few fixes for building the shared libs, PIC, etc
@@ -99,17 +99,17 @@ src_unpack() {
epatch "${FILESDIR}/${P}-makefile.patch" || die "make patch failed"
if use pvfs2; then
- sed -i -e "s:-laio:-laio -lpvfs2:g" Makefile.in \
+ sed -i -e "s:-laio:-laio -lpvfs2:g" Makefile.in \
|| die "sed pvfs2 failed"
else
- epatch "${FILESDIR}/${P}-no-pvfs2.patch" || die "no pvfs patch failed"
- elog ""
- ewarn "If you wish to build without pvfs2 support, then you will"
- ewarn "need to remove the pvfs2 package if already installed."
- ewarn "Please remove pvfs2 and then rebuild mpich2. If pvfs2"
- ewarn "is not installed, then you can safely ignore this warning."
- elog ""
- epause 5
+ epatch "${FILESDIR}/${P}-no-pvfs2.patch" || die "no pvfs patch failed"
+ elog ""
+ ewarn "If you wish to build without pvfs2 support, then you will"
+ ewarn "need to remove the pvfs2 package if already installed."
+ ewarn "Please remove pvfs2 and then rebuild mpich2. If pvfs2"
+ ewarn "is not installed, then you can safely ignore this warning."
+ elog ""
+ epause 5
fi
use mpe-sdk && setup-jvm-opts
@@ -117,9 +117,9 @@ src_unpack() {
src_compile() {
if use crypt ; then
- RSHCOMMAND="ssh -x"
+ RSHCOMMAND="ssh -x"
else
- RSHCOMMAND="rsh"
+ RSHCOMMAND="rsh"
fi
export RSHCOMMAND
@@ -133,27 +133,27 @@ src_compile() {
filter-flags -fomit-frame-pointer
if ! use debug ; then
- myconf="${myconf} --enable-g=none"
+ myconf="${myconf} --enable-g=none"
else
- myconf="${myconf} --enable-g=dbg,mem,log --enable-debuginfo"
+ myconf="${myconf} --enable-g=dbg,mem,log --enable-debuginfo"
fi
if ! use mpe-sdk ; then
- myconf="${myconf} --enable-rlog=no --enable-slog2=no"
+ myconf="${myconf} --enable-rlog=no --enable-slog2=no"
fi
if use threads ; then
- myconf="${myconf} --with-thread-package=pthreads"
+ myconf="${myconf} --with-thread-package=pthreads"
else
- myconf="${myconf} --with-thread-package=none"
+ myconf="${myconf} --with-thread-package=none"
fi
# enable f90 support for appropriate compilers
case "${FORTRANC}" in
- gfortran|ifc|ifort|f95)
+ gfortran|ifc|ifort|f95)
myconf="${myconf} --enable-f77 --enable-f90"
;;
- g77|f77|f2c)
+ g77|f77|f2c)
myconf="${myconf} --enable-f77 --disable-f90"
;;
esac
@@ -164,11 +164,11 @@ src_compile() {
# several of these are romio-specific configure options
myconf="${myconf} --enable-aio --with-mpi=mpich2_mpi"
if use pvfs2; then
- myconf="${myconf} --with-file-system=pvfs2+nfs+ufs \
+ myconf="${myconf} --with-file-system=pvfs2+nfs+ufs \
--with-pvfs2=/usr"
else
- # support for nfs and unix-like filesystems is the minimum
- myconf="${myconf} --with-file-system=nfs+ufs --with-pvfs2=no"
+ # support for nfs and unix-like filesystems is the minimum
+ myconf="${myconf} --with-file-system=nfs+ufs --with-pvfs2=no"
fi
# enable debug for romio
use debug && myconf="${myconf} --enable-debug"
@@ -177,25 +177,25 @@ src_compile() {
# I'm sure there's a better way to do this...
if use cxx; then
- tc-export CPP CC CXX LD
- CXXLIBPATH="/usr/$(get_libdir)/gcc/${CHOST}/$(gcc-fullversion)"
- sed -i -e "s:nerdboy:${CXXLIBPATH}:g" Makefile.in \
+ tc-export CPP CC CXX LD
+ CXXLIBPATH="/usr/$(get_libdir)/gcc/${CHOST}/$(gcc-fullversion)"
+ sed -i -e "s:nerdboy:${CXXLIBPATH}:g" Makefile.in \
|| die "sed 3 failed"
fi
if use doc; then
- doc_conf="--docdir=/usr/share/doc/${PF} \
+ doc_conf="--docdir=/usr/share/doc/${PF} \
--with-docdir=/usr/share/doc/${PF} \
--with-htmldir=/usr/share/doc/${PF}/html \
--with-pdfdir=/usr/share/doc/${PF} \
--with-psdir=/usr/share/doc/${PF}"
else
- doc_conf="--with-docdir=/usr/share/doc/${PF} \
+ doc_conf="--with-docdir=/usr/share/doc/${PF} \
--with-htmldir=/usr/share/doc/${PF}/html"
fi
if use mpe-sdk; then
- mpe_conf="--with-java=${JDK_TOPDIR} --with-java2=${JDK_TOPDIR} \
+ mpe_conf="--with-java=${JDK_TOPDIR} --with-java2=${JDK_TOPDIR} \
--enable-slog2=build \
--with-mpicc=\"${WORKDIR}\"/build/bin/mpicc \
--with-mpif77=\"${WORKDIR}\"/build/bin/mpif77 \
@@ -204,12 +204,12 @@ src_compile() {
--with-flib_path_leader=-Wl,-L --enable-mpich \
--enable-misc --enable-callstack --enable-logging"
- use debug && mpe_conf="${mpe_conf} --enable-g"
+ use debug && mpe_conf="${mpe_conf} --enable-g"
- sed -i -e "s:fpic:fPIC:g" \
+ sed -i -e "s:fpic:fPIC:g" \
src/mpe2/src/slog2sdk/trace_sample/configure \
|| die "sed 1 failed"
- sed -i -e "s:fpic:fPIC:g" \
+ sed -i -e "s:fpic:fPIC:g" \
src/mpe2/src/slog2sdk/trace_rlog/configure \
|| die "sed 2 failed"
fi
@@ -259,9 +259,9 @@ src_test() {
export MPIO_USER_PATH="${TEST}"/t1
sed -i -e "s:/usr/bin/mpiexec:${TEST}/bin/mpiexec:g" test/mpi/Makefile \
- || die "sed 4 failed"
+ || die "sed 4 failed"
sed -i -e "s:/usr:${TEST}:g" test/commands/cmdtests \
- || die "sed 5 failed"
+ || die "sed 5 failed"
cd test
make clean || die "make clean in test failed"
@@ -273,9 +273,9 @@ src_test() {
export LD_LIBRARY_PATH="${TEST}/lib:$LD_LIBRARY_PATH"
"${S}"/configure \
- --exec-prefix="${TEST}" --with-mpi="${TEST}" \
- --disable-f90 --with-mpich2="${TEST}" $(use_enable threads) \
- || die "configure test failed"
+ --exec-prefix="${TEST}" --with-mpi="${TEST}" \
+ --disable-f90 --with-mpich2="${TEST}" $(use_enable threads) \
+ || die "configure test failed"
nice --adjustment=3 make testing || die "make testing failed"
@@ -289,7 +289,7 @@ src_install() {
cd ../build
make DESTDIR="${D}" LIBDIR="${D}"usr/$(get_libdir) install \
- || die "make install failed"
+ || die "make install failed"
cd "${S}"
@@ -298,18 +298,18 @@ src_install() {
dodir /usr/share/doc/"${PF}"
if use doc; then
- dodoc COPYRIGHT README README.romio README.testing CHANGES
- dodoc README.developer RELEASE_NOTES
- newdoc src/pm/mpd/README README.mpd
+ dodoc README README.romio README.testing CHANGES
+ dodoc README.developer RELEASE_NOTES
+ newdoc src/pm/mpd/README README.mpd
- if use mpe-sdk; then
+ if use mpe-sdk; then
dodoc src/mpe2/src/slog2sdk/README.sdk \
- src/mpe2/src/slog2sdk/README.rte
+ src/mpe2/src/slog2sdk/README.rte
newdoc src/mpe2/src/slog2sdk/FAQ FAQ.sdk
- fi
+ fi
else
- rm -rf "${D}"usr/share/doc/"${PF}"/{html,*.pdf}
- dodoc README CHANGES COPYRIGHT RELEASE_NOTES
+ rm -rf "${D}"usr/share/doc/"${PF}"/{html,*.pdf}
+ dodoc README CHANGES RELEASE_NOTES
fi
# Tidy up a bit