summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-04-22 18:50:49 +0000
committerRoy Marples <uberlord@gentoo.org>2006-04-22 18:50:49 +0000
commitc9f9ee46074f0e71a28aaf656edad9c250edc27c (patch)
treeda4fd4f0b2824fcdc1864a17161cc4a2fbf95f41
parentRemove portage-2.1_pre3-r1.ebuild because it's old. (diff)
downloadgentoo-2-c9f9ee46074f0e71a28aaf656edad9c250edc27c.tar.gz
gentoo-2-c9f9ee46074f0e71a28aaf656edad9c250edc27c.tar.bz2
gentoo-2-c9f9ee46074f0e71a28aaf656edad9c250edc27c.zip
Punt old version
(Portage version: 2.1_pre7-r5)
-rw-r--r--net-misc/pump/files/digest-pump-0.8.21-r82
-rw-r--r--net-misc/pump/files/pump-0.8.21-gcc4.patch101
-rw-r--r--net-misc/pump/pump-0.8.21-r8.ebuild69
3 files changed, 0 insertions, 172 deletions
diff --git a/net-misc/pump/files/digest-pump-0.8.21-r8 b/net-misc/pump/files/digest-pump-0.8.21-r8
deleted file mode 100644
index 0a9f7d804d9f..000000000000
--- a/net-misc/pump/files/digest-pump-0.8.21-r8
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 a6925de6cd011605237934a907f8a9c4 pump_0.8.21.orig.tar.gz 79289
-MD5 22e1a2a142117fe41781e5437a03fcdb pump_0.8.21-2.diff.gz 22259
diff --git a/net-misc/pump/files/pump-0.8.21-gcc4.patch b/net-misc/pump/files/pump-0.8.21-gcc4.patch
deleted file mode 100644
index f37392ad17ca..000000000000
--- a/net-misc/pump/files/pump-0.8.21-gcc4.patch
+++ /dev/null
@@ -1,101 +0,0 @@
---- pump-0.8.21/pump.c.orig 2005-11-18 09:43:38.634480153 +0000
-+++ pump-0.8.21/pump.c 2005-11-18 09:42:26.736658004 +0000
-@@ -306,7 +306,7 @@
- static void runDaemon(int sock, int sock_in) {
- int conn;
- struct sockaddr_un addr;
-- int addrLength = sizeof(struct sockaddr_un);
-+ socklen_t addrLength = sizeof(struct sockaddr_un);
- struct command cmd;
- struct pumpNetIntf intf[20];
- const int maxIntf = sizeof(intf) / sizeof(intf[0]);
---- pump-0.8.21/dhcp.c.orig 2005-11-18 09:43:46.883546029 +0000
-+++ pump-0.8.21/dhcp.c 2005-11-18 09:55:24.672589943 +0000
-@@ -406,7 +406,7 @@
- unsigned char option, length;
-
-
-- chptr = response->vendor;
-+ chptr = (unsigned char *) response->vendor;
-
- chptr += 4;
- while (*chptr != 0xFF) {
-@@ -483,7 +483,7 @@
- intf->set |= PUMP_INTFINFO_HAS_NEXTSERVER;
- syslog (LOG_DEBUG, "intf: next server: %s", inet_ntoa (intf->nextServer));
-
-- chptr = breq->vendor;
-+ chptr = (unsigned char *) breq->vendor;
- chptr += 4;
- while (*chptr != 0xFF && (void *) chptr < (void *) breq->vendor + DHCP_VENDOR_LENGTH) {
- option = *chptr++;
-@@ -739,7 +739,7 @@
- syslog (LOG_DEBUG, "%s: servername: %s", name, breq->servername);
- syslog (LOG_DEBUG, "%s: bootfile: %s", name, breq->bootfile);
-
-- vndptr = breq->vendor;
-+ vndptr = (unsigned char *) breq->vendor;
- sprintf (vendor, "0x%02x 0x%02x 0x%02x 0x%02x", vndptr[0], vndptr[1], vndptr[2], vndptr[3]);
- vndptr += 4;
- syslog (LOG_DEBUG, "%s: vendor: %s", name, vendor);
-@@ -751,7 +751,7 @@
- if (option == 0xFF)
- {
- sprintf (vendor, "0x%02x", option);
-- vndptr = breq->vendor + DHCP_VENDOR_LENGTH;
-+ vndptr = (unsigned char *)breq->vendor + DHCP_VENDOR_LENGTH;
- }
- else if (option == 0x00)
- {
-@@ -794,10 +794,11 @@
- fd_set readfs;
- int i, j;
- struct sockaddr_pkt tmpAddress;
-+ socklen_t addrLength;
- int gotit = 0;
- int tries;
- int nextTimeout = 2;
-- time_t timeoutTime;
-+ time_t timeoutTime = 0;
- int sin;
- int resend = 1;
- struct ethhdr;
-@@ -884,9 +885,9 @@
- break;
-
- case 1:
-- i = sizeof(tmpAddress);
-+ addrLength = sizeof(tmpAddress);
- if ((j = recvfrom(sin, ethPacket, sizeof(ethPacket), 0,
-- (struct sockaddr *) &tmpAddress, &i)) < 0)
-+ (struct sockaddr *) &tmpAddress, &addrLength)) < 0)
- return perrorstr("recvfrom");
-
- /* We need to do some basic sanity checking of the header */
-@@ -998,7 +999,7 @@
- unsigned char * chptr;
- int theOption, theLength;
-
-- chptr = breq->vendor;
-+ chptr = (unsigned char *) breq->vendor;
- chptr += 4;
- while (*chptr != 0xFF && *chptr != option) {
- theOption = *chptr++;
-@@ -1018,7 +1019,7 @@
- unsigned char * chptr;
- unsigned int length, theOption;
-
-- chptr = bresp->vendor;
-+ chptr = (unsigned char *) bresp->vendor;
- chptr += 4;
- while (*chptr != 0xFF && *chptr != option) {
- theOption = *chptr++;
-@@ -1290,7 +1291,7 @@
- struct sockaddr_in serverAddr;
- struct sockaddr_ll broadcastAddr;
- struct bootpRequest breq, bresp;
-- unsigned char * chptr;
-+ char * chptr;
- time_t startTime = pumpUptime();
- char * saveDeviceName;
- unsigned char messageType;
diff --git a/net-misc/pump/pump-0.8.21-r8.ebuild b/net-misc/pump/pump-0.8.21-r8.ebuild
deleted file mode 100644
index 1080a53cd5a6..000000000000
--- a/net-misc/pump/pump-0.8.21-r8.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.21-r8.ebuild,v 1.3 2005/11/18 14:06:22 uberlord Exp $
-
-inherit eutils
-
-PATCHLEVEL="2"
-
-DESCRIPTION="This is the DHCP/BOOTP client written by RedHat"
-HOMEPAGE="http://ftp.debian.org/debian/pool/main/p/pump/"
-SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz
- mirror://debian/pool/main/p/${PN}/${PN}_${PV}-${PATCHLEVEL}.diff.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
-IUSE=""
-
-DEPEND=">=dev-libs/popt-1.5"
-
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- cd "${WORKDIR}"
- unpack "${PN}_${PV}.orig.tar.gz"
- cd "${S}"
-
- # Apply Debians pump patchset - they fix things good :)
- epatch "${DISTDIR}/${PN}_${PV}-${PATCHLEVEL}.diff.gz"
-
- # Enable the -e (--etc-dir) option to specify where to make
- # resolv.conf - default /etc
- # Enable the -m (--route-metric) option to specify the default
- # metric applied to routes
- # Enable the --keep-up option to keep interfaces up when we release
- # Enable the creation of /etc/ntp.conf and the --no-ntp option
- epatch "${FILESDIR}/pump-${PV}-gentoo.diff"
-
- # Clean compile on GCC4
- epatch "${FILESDIR}/pump-${PV}-gcc4.patch"
-
- # Only install specific po files if LINGUAS is set
- if [[ -n ${LINGUAS} ]]; then
- cd po
- local p
- for l in $(ls *.po) ; do
- [[ " ${LINGUAS} " != *" ${l%%.po} "* ]] && rm -f "${l}"
- done
- fi
-}
-
-src_compile() {
- make DEB_CFLAGS="-fPIC ${CFLAGS}" pump || die
-}
-
-src_install() {
- into /
- dosbin pump || die
-
- doman pump.8
- dodoc CREDITS
-
- into /usr/
- dolib.a libpump.a
- insinto /usr/include/
- doins pump.h
-
- make -C po install datadir="${D}/usr/share/"
-}