summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-09-17 05:24:46 +0000
committerHans de Graaff <graaff@gentoo.org>2014-09-17 05:24:46 +0000
commitca076608ed0c98f7f0edfffa2f0f9deb8386f5d3 (patch)
treec34427e6e8e1cc4593aac0ae7712d416a703de25
parentFix pypy masks for all utilities affected (diff)
downloadgentoo-2-ca076608ed0c98f7f0edfffa2f0f9deb8386f5d3.tar.gz
gentoo-2-ca076608ed0c98f7f0edfffa2f0f9deb8386f5d3.tar.bz2
gentoo-2-ca076608ed0c98f7f0edfffa2f0f9deb8386f5d3.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/psych/ChangeLog7
-rw-r--r--dev-ruby/psych/psych-2.0.6.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/psych/ChangeLog b/dev-ruby/psych/ChangeLog
index c9ee1d9ea5de..b478647707ed 100644
--- a/dev-ruby/psych/ChangeLog
+++ b/dev-ruby/psych/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/psych
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/psych/ChangeLog,v 1.2 2014/06/27 21:53:06 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/psych/ChangeLog,v 1.3 2014/09/17 05:24:46 graaff Exp $
+
+*psych-2.0.6 (17 Sep 2014)
+
+ 17 Sep 2014; Hans de Graaff <graaff@gentoo.org> +psych-2.0.6.ebuild:
+ Version bump.
27 Jun 2014; Manuel Rüger <mrueg@gentoo.org> psych-2.0.5.ebuild:
Remove useless blank line.
diff --git a/dev-ruby/psych/psych-2.0.6.ebuild b/dev-ruby/psych/psych-2.0.6.ebuild
new file mode 100644
index 000000000000..2f13fdadd402
--- /dev/null
+++ b/dev-ruby/psych/psych-2.0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/psych/psych-2.0.6.ebuild,v 1.1 2014/09/17 05:24:46 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A libyaml wrapper for Ruby"
+HOMEPAGE="https://github.com/tenderlove/psych"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" dev-libs/libyaml"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/${PN}$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:test/${PN} test/${PN}/test_*.rb || die
+ ${RUBY} -Ilib:test:test/${PN} test/${PN}/nodes/*.rb || die
+ ${RUBY} -Ilib:test:test/${PN} test/${PN}/visitors/*.rb || die
+ ${RUBY} -Ilib:test:test/${PN} test/${PN}/json/*.rb || die
+}