summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-02 23:01:32 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-02 23:01:32 +0000
commitcaa6a78554c31cb0aff3bb224cc89c0eea6ecc58 (patch)
tree358f39b95acbd88c15fba94bbd2ba0f0275312bc
parentFix building with gcc-4.3 (diff)
downloadgentoo-2-caa6a78554c31cb0aff3bb224cc89c0eea6ecc58.tar.gz
gentoo-2-caa6a78554c31cb0aff3bb224cc89c0eea6ecc58.tar.bz2
gentoo-2-caa6a78554c31cb0aff3bb224cc89c0eea6ecc58.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
-rw-r--r--games-sports/foosball/ChangeLog8
-rw-r--r--games-sports/foosball/files/foosball-0.92-gcc43.patch16
-rw-r--r--games-sports/foosball/foosball-0.92-r1.ebuild14
-rw-r--r--games-sports/foosball/foosball-0.92.ebuild22
4 files changed, 32 insertions, 28 deletions
diff --git a/games-sports/foosball/ChangeLog b/games-sports/foosball/ChangeLog
index d8e2d6706649..99de0356c695 100644
--- a/games-sports/foosball/ChangeLog
+++ b/games-sports/foosball/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/foosball
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foosball/ChangeLog,v 1.5 2007/05/28 22:39:06 tupone Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foosball/ChangeLog,v 1.6 2008/05/02 23:01:31 nyhm Exp $
+
+ 02 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/foosball-0.92-gcc43.patch, foosball-0.92-r1.ebuild:
+ Fix building with gcc-4.3
*foosball-0.92-r1 (28 May 2007)
diff --git a/games-sports/foosball/files/foosball-0.92-gcc43.patch b/games-sports/foosball/files/foosball-0.92-gcc43.patch
new file mode 100644
index 000000000000..19c853179088
--- /dev/null
+++ b/games-sports/foosball/files/foosball-0.92-gcc43.patch
@@ -0,0 +1,16 @@
+--- foosball/foosball.hxx
++++ foosball/foosball.hxx
+@@ -15,9 +15,10 @@
+ * *
+ ***************************************************************************/
+
+- #include <stdio.h>
+- #include <stdlib.h>
+- #include <math.h>
++ #include <cstdio>
++ #include <cstdlib>
++ #include <cmath>
++ #include <cstring>
+ #include "sgw.hxx"
+
+ #define PLAYER1 (0) // Left to Right Player
diff --git a/games-sports/foosball/foosball-0.92-r1.ebuild b/games-sports/foosball/foosball-0.92-r1.ebuild
index 1dbeb081d400..adbc48afecd4 100644
--- a/games-sports/foosball/foosball-0.92-r1.ebuild
+++ b/games-sports/foosball/foosball-0.92-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foosball/foosball-0.92-r1.ebuild,v 1.1 2007/05/28 22:39:06 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foosball/foosball-0.92-r1.ebuild,v 1.2 2008/05/02 23:01:31 nyhm Exp $
inherit eutils games
@@ -10,13 +10,19 @@ SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ppc x86"
IUSE=""
DEPEND="media-libs/libsdl"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README TODO
make_desktop_entry ${PN} Foosball
prepgamesdirs
diff --git a/games-sports/foosball/foosball-0.92.ebuild b/games-sports/foosball/foosball-0.92.ebuild
deleted file mode 100644
index 0c11cda21466..000000000000
--- a/games-sports/foosball/foosball-0.92.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foosball/foosball-0.92.ebuild,v 1.8 2006/07/16 16:27:46 dertobi123 Exp $
-
-inherit games
-
-DESCRIPTION="foosball game that uses SDL"
-HOMEPAGE="http://freshmeat.net/projects/foosball/"
-SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl"
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog README TODO
- prepgamesdirs
-}