summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-03-18 22:35:00 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-03-18 22:35:00 +0000
commitcd0e6ac0e40ce4e73cda627d3fe747da93de918f (patch)
treee486e6d209a0969b46fd80cac30f019280359455
parentFix bug #167480 and #171290. (diff)
downloadgentoo-2-cd0e6ac0e40ce4e73cda627d3fe747da93de918f.tar.gz
gentoo-2-cd0e6ac0e40ce4e73cda627d3fe747da93de918f.tar.bz2
gentoo-2-cd0e6ac0e40ce4e73cda627d3fe747da93de918f.zip
Fix bug #167480 and #171290.
(Portage version: 2.1.2.2)
-rw-r--r--app-office/kexi/ChangeLog8
-rw-r--r--app-office/kexi/files/digest-kexi-1.6.2-r13
-rw-r--r--app-office/kexi/files/kexi-1.6.2-build_kexi_file.diff15
-rw-r--r--app-office/kexi/kexi-1.6.2-r1.ebuild50
4 files changed, 75 insertions, 1 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index 94c2297e3f8a..7c8d397ff84d 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.74 2007/03/02 02:53:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.75 2007/03/18 22:35:00 carlo Exp $
+
+*kexi-1.6.2-r1 (18 Mar 2007)
+
+ 18 Mar 2007; Carsten Lohrke <carlo@gentoo.org>
+ +files/kexi-1.6.2-build_kexi_file.diff, +kexi-1.6.2-r1.ebuild:
+ Fix bug #167480 and #171290.
02 Mar 2007; Jeroen Roovers <jer@gentoo.org> kexi-1.6.1.ebuild:
Stable for HPPA.
diff --git a/app-office/kexi/files/digest-kexi-1.6.2-r1 b/app-office/kexi/files/digest-kexi-1.6.2-r1
new file mode 100644
index 000000000000..cfd7d14fcad4
--- /dev/null
+++ b/app-office/kexi/files/digest-kexi-1.6.2-r1
@@ -0,0 +1,3 @@
+MD5 74ef62a5f8f766fe8192d5b7d65a3928 koffice-1.6.2.tar.bz2 57049103
+RMD160 fb4ef5870870d80481a4a9d2864199428f495460 koffice-1.6.2.tar.bz2 57049103
+SHA256 fa5ca02eba02219d34c3c6efff92bf767060b4b1343da56eb63139661d53f380 koffice-1.6.2.tar.bz2 57049103
diff --git a/app-office/kexi/files/kexi-1.6.2-build_kexi_file.diff b/app-office/kexi/files/kexi-1.6.2-build_kexi_file.diff
new file mode 100644
index 000000000000..bd235d9591da
--- /dev/null
+++ b/app-office/kexi/files/kexi-1.6.2-build_kexi_file.diff
@@ -0,0 +1,15 @@
+--- branches/koffice/1.6/koffice/kexi/examples/build_kexi_file.sh 2007/01/24 18:50:22 626851
++++ branches/koffice/1.6/koffice/kexi/examples/build_kexi_file.sh 2007/02/15 13:50:16 633840
+@@ -8,8 +8,10 @@
+ # ksqlite is needed on the $PATH.
+
+ KEXISQL3PATH=../3rdparty/kexisql3/src/.libs/
+-PATH=$PATH:$KEXISQL3PATH
+-LD_LIBRARY_PATH=$KEXISQL3PATH:$KEXISQL3PATH
++PATH=$KEXISQL3PATH:$PATH
++export PATH
++LD_LIBRARY_PATH=$KEXISQL3PATH:$LD_LIBRARY_PATH
++export LD_LIBRARY_PATH
+ which ksqlite > /dev/null || exit 1
+
+ [ $# -lt 1 ] && echo "Missing .sql filename." && exit 1
diff --git a/app-office/kexi/kexi-1.6.2-r1.ebuild b/app-office/kexi/kexi-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..836d26817ef0
--- /dev/null
+++ b/app-office/kexi/kexi-1.6.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.6.2-r1.ebuild,v 1.1 2007/03/18 22:35:00 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres kdeenablefinal"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ sys-libs/readline
+ mysql? ( virtual/mysql )
+ postgres? ( <dev-libs/libpqxx-2.6.9 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkoproperty lib/koproperty
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkrossmain lib/kross/main/
+ libkrossapi lib/kross/api/"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.4
+
+PATCHES="${FILESDIR}/kexi-1.6.2-build_kexi_file.diff"
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"
+
+ # Labplot needs the header file
+ sed -i -e "s:utils.h:utils.h parser/parser.h:" kexi/kexidb/Makefile.am || die "sed failed"
+ kde-meta_src_compile
+}