summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-08 12:04:58 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-08 12:04:58 +0000
commitcd41851e79d5501fef4b1a3ce72af3bc07810faf (patch)
tree9bf4e0fb2b380d9ca678514cc35e807c48d6b9a1
parentFixed build failure in function 'dissect_sflow_sample_rawheaderdata' (diff)
downloadgentoo-2-cd41851e79d5501fef4b1a3ce72af3bc07810faf.tar.gz
gentoo-2-cd41851e79d5501fef4b1a3ce72af3bc07810faf.tar.bz2
gentoo-2-cd41851e79d5501fef4b1a3ce72af3bc07810faf.zip
Bump to 0.3.5-r1.
* Don't build tests if not requested, bug #226219. * Don't build examples if not requested bug #226303. * Don't depend on glib if examples are not built, bug #204002. * Don't forced uneeded make -j1, bug #236012. (Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--dev-libs/liboil/ChangeLog12
-rw-r--r--dev-libs/liboil/liboil-0.3.15-r1.ebuild54
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/liboil/ChangeLog b/dev-libs/liboil/ChangeLog
index 905b3065c823..268dc9c10ed9 100644
--- a/dev-libs/liboil/ChangeLog
+++ b/dev-libs/liboil/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-libs/liboil
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liboil/ChangeLog,v 1.72 2009/03/08 07:39:21 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liboil/ChangeLog,v 1.73 2009/03/08 12:04:58 eva Exp $
+
+*liboil-0.3.15-r1 (08 Mar 2009)
+
+ 08 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +liboil-0.3.15-r1.ebuild:
+ Bump to 0.3.5-r1.
+ * Don't build tests if not requested, bug #226219.
+ * Don't build examples if not requested bug #226303.
+ * Don't depend on glib if examples are not built, bug #204002.
+ * Don't forced uneeded make -j1, bug #236012.
08 Mar 2009; Joshua Kinard <kumba@gentoo.org> liboil-0.3.15.ebuild:
Added ~mips to KEYWORDS.
diff --git a/dev-libs/liboil/liboil-0.3.15-r1.ebuild b/dev-libs/liboil/liboil-0.3.15-r1.ebuild
new file mode 100644
index 000000000000..4285071aa69e
--- /dev/null
+++ b/dev-libs/liboil/liboil-0.3.15-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liboil/liboil-0.3.15-r1.ebuild,v 1.1 2009/03/08 12:04:58 eva Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+
+DESCRIPTION="library of simple functions that are optimized for various CPUs"
+HOMEPAGE="http://liboil.freedesktop.org/"
+SRC_URI="http://liboil.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +examples test"
+
+RDEPEND="examples? ( =dev-libs/glib-2* )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+src_prepare() {
+ if ! use examples; then
+ sed "s/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die "sed failed."
+ fi
+
+ if ! use test; then
+ sed "s/^\(SUBDIRS =.*\)testsuite\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die "sed failed."
+ fi
+
+}
+
+src_configure() {
+ strip-flags
+ filter-flags -O?
+ append-flags -O2
+ econf --disable-dependency-tracking \
+ $(use_enable doc gtk-doc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS BUG-REPORTING HACKING NEWS README || die "dodoc failed."
+}
+
+pkg_postinst() {
+ if ! use examples; then
+ ewarn "You have disabled examples USE flag. Beware that upstream might"
+ ewarn "want the output of some utilities that are only built with"
+ ewarn "USE='examples' if you report bugs to them."
+ fi
+}